Re: MPLS TE

From: Gaurav Thukral <pearlgaurav_at_gmail.com>
Date: Tue, 2 Nov 2010 14:04:55 +0530

Hi Shagun

PFA the below ISIS Config:

mpls traffic-eng tunnels

interface Loopback0
 ip address 5.5.7.7 255.255.255.255
 ip router isis
 isis circuit-type level-2-only

interface Ethernet3/0
 ip address 5.5.78.7 255.255.255.0
 ip router isis
 full-duplex
 mpls traffic-eng tunnels
 tag-switching ip
 isis circuit-type level-2-only
 isis priority 127
 ip rsvp bandwidth 100000 50000 sub-pool 20000

interface Ethernet3/1
 ip address 5.5.79.7 255.255.255.0
 ip router isis
 full-duplex
 mpls traffic-eng tunnels
 tag-switching ip
 isis circuit-type level-2-only
 isis priority 127
 ip rsvp bandwidth 100000 50000 sub-pool 20000

router isis
 net 49.0005.0000.0000.0007.00
 is-type level-2-only
 metric-style wide level-2
 log-adjacency-changes
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2

R7#sh ip route isis
     5.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
i L2 5.5.9.9/32 [115/20] via 5.5.79.9, Ethernet3/1
i L2 5.5.8.8/32 [115/20] via 5.5.78.8, Ethernet3/0
i L2 5.5.89.0/24 [115/20] via 5.5.79.9, Ethernet3/1
                    [115/20] via 5.5.78.8, Ethernet3/0

@@@@@@@@@@@@@@@@@@

R8

mpls traffic-eng tunnels

interface Loopback0
 ip address 5.5.8.8 255.255.255.255
 ip router isis
 isis circuit-type level-2-only

interface Loopback2
 ip address 5.5.88.8 255.255.255.255

interface Ethernet3/0
 ip address 5.5.78.8 255.255.255.0
 ip router isis
 full-duplex
 mpls traffic-eng tunnels
 tag-switching ip
 isis circuit-type level-2-only
 ip rsvp bandwidth 100000 50000 sub-pool 20000

interface Ethernet3/2
 ip address 5.5.89.8 255.255.255.0
 ip router isis
 full-duplex
 mpls traffic-eng tunnels
 tag-switching ip
 isis circuit-type level-2-only
 isis network point-to-point
 ip rsvp bandwidth 100000 50000 sub-pool 20000

router isis
 net 49.0005.0000.0000.0008.00
 is-type level-2-only
 metric-style wide level-2
 log-adjacency-changes
 mpls traffic-eng router-id Loopback2
 mpls traffic-eng level-2

R8#sh ip route isis
     5.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
i L2 5.5.9.9/32 [115/20] via 5.5.89.9, Ethernet3/2
i L2 5.5.7.7/32 [115/20] via 5.5.78.7, Ethernet3/0
i L2 5.5.79.0/24 [115/20] via 5.5.89.9, Ethernet3/2
                    [115/20] via 5.5.78.7, Ethernet3/0

@@@@@@@@@@@@@@@@@@@

R9

mpls traffic-eng tunnels

interface Loopback0
 ip address 5.5.9.9 255.255.255.255
 ip router isis
 isis circuit-type level-2-only

interface Loopback2
 ip address 5.5.99.9 255.255.255.255

interface FastEthernet2/0
 ip address 5.5.89.9 255.255.255.0
 ip router isis
 duplex auto
 speed auto
 mpls traffic-eng tunnels
 tag-switching ip
 isis circuit-type level-2-only
 isis network point-to-point
 ip rsvp bandwidth 100000 50000 sub-pool 20000

interface FastEthernet1/0
 ip address 5.5.79.9 255.255.255.0
 ip router isis
 duplex auto
 speed auto
 mpls traffic-eng tunnels
 tag-switching ip
 isis circuit-type level-2-only
 ip rsvp bandwidth 100000 50000 sub-pool 20000
end

router isis
 net 49.0005.0000.0000.0009.00
 is-type level-2-only
 metric-style wide level-2
 log-adjacency-changes
 mpls traffic-eng router-id Loopback2
 mpls traffic-eng level-2

R9#sh ip route isis
     5.0.0.0/8 is variably subnetted, 11 subnets, 2 masks
i L2 5.5.8.8/32 [115/20] via 5.5.89.8, FastEthernet2/0
i L2 5.5.7.7/32 [115/20] via 5.5.79.7, FastEthernet1/0
i L2 5.5.78.0/24 [115/20] via 5.5.89.8, FastEthernet2/0
                    [115/20] via 5.5.79.7, FastEthernet1/0

Regards,
Gaurav

On Tue, Nov 2, 2010 at 1:01 PM, Shaughn Smith <maniac.smg_at_gmail.com> wrote:

> Can you post your ISIS configs
>
> CCIE # 23962 (SP)
>
> Sent from my iPhone 4
>
> On 02 Nov 2010, at 9:01 AM, Gaurav Thukral <pearlgaurav_at_gmail.com> wrote:
>
> > Hi guys,
> >
> > I have three Routers connected in a Traingle Having routers names R7 R8
> R9
> > respectively.
> >
> > I have created Dynamic tunnel between R9 & R8 on their Loop2. ISIS is
> > running as the IGP.
> >
> > under all the MPLS TE link i have configured the following command
> >
> > ip rsvp bandwidth 100000 50000 sub-pool 20000
> >
> > Means 100Mb , 50Mb(Flow) and subpool BW 20Mb & Tunnel should use 5Mb
> > bandwidth.
> >
> >
> > R8
> >
> > interface Tunnel89
> > ip unnumbered Loopback2
> > tunnel destination 5.5.99.9
> > tunnel mode mpls traffic-eng
> > tunnel mpls traffic-eng priority 7 7
> > tunnel mpls traffic-eng bandwidth 5000
> > tunnel mpls traffic-eng path-option 1 dynamic
> >
> > ip route 5.5.99.9 255.255.255.255 Tunnel89
> >
> > R9
> >
> > interface Tunnel98
> > ip unnumbered Loopback2
> > tunnel destination 5.5.88.8
> > tunnel mode mpls traffic-eng
> > tunnel mpls traffic-eng priority 7 7
> > tunnel mpls traffic-eng bandwidth 5000
> > tunnel mpls traffic-eng path-option 1 dynamic
> >
> > ip route 5.5.88.8 255.255.255.255 Tunnel98
> >
> > But my requirement is Tunnel should use BW from subpool.
> > So under Tunnel interface if i use subpool BW Tuunel become down?
> >
> > Please Help me.
> >
> > Thanks in advance.
> >
> > Regards,
> > gaurav
> >
> >
> > Blogs and organic groups at http://www.ccie.net
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Tue Nov 02 2010 - 14:04:55 ART

This archive was generated by hypermail 2.2.0 : Sun Dec 05 2010 - 22:14:55 ART