Re: matching on interface or access-list

From: Sergio Silva (spmsilva@gmail.com)
Date: Thu Nov 23 2006 - 10:01:12 ART


Hi Guys

I beg to differ

Here is a configuration between two routers running ospf in a area 0

R1

!
interface Loopback0
 ip address 111.111.111.111 255.255.255.255
!
interface Loopback1
 ip address 112.112.112.112 255.255.255.255
!
interface Loopback2
 ip address 113.113.113.113 255.255.255.255
!
interface Serial0/0
 description BB2
 ip address 1.1.1.1 255.255.255.252
 fair-queue
!
router ospf 1
 log-adjacency-changes
 redistribute connected subnets route-map loopbacks
 network 1.1.1.0 0.0.0.3 area 0
!
route-map loopbacks permit 10
 match interface Loopback0 Loopback1 Loopback2

@@@@@@@@@@@@@@@Router 2@@@@@@@@@@@@@@@@

R2
!
interface Loopback0
 ip address 220.220.220.220 255.255.255.255
!
interface Loopback1
 ip address 221.221.221.221 255.255.255.255
!
interface Loopback2
 ip address 222.222.222.222 255.255.255.255
!
interface Serial0/0
 description BB1
 bandwidth 128
 ip address 1.1.1.2 255.255.255.252
 clock rate 128000
 no fair-queue
!
router ospf 1
 log-adjacency-changes
 redistribute connected subnets route-map loopbacks
 network 1.1.1.0 0.0.0.3 area 0
!
ip access-list standard loopback
 permit 220.220.220.220
 permit 221.221.221.221
 permit 222.222.222.222
!
route-map loopbacks permit 10
 match ip address loopback

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Routing Table of Router 2 whereby Router 1 in injecting the connected
loopbacks via route-map with the match interface

BB2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     221.221.221.0/32 is subnetted, 1 subnets
C 221.221.221.221 is directly connected, Loopback1
     220.220.220.0/32 is subnetted, 1 subnets
C 220.220.220.220 is directly connected, Loopback0
     222.222.222.0/32 is subnetted, 1 subnets
C 222.222.222.222 is directly connected, Loopback2
     1.0.0.0/30 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Serial0/0
     113.0.0.0/32 is subnetted, 1 subnets
O E2 113.113.113.113 [110/20] via 1.1.1.1, 00:03:21, Serial0/0
     112.0.0.0/32 is subnetted, 1 subnets
O E2 112.112.112.112 [110/20] via 1.1.1.1, 00:03:21, Serial0/0
     111.0.0.0/32 is subnetted, 1 subnets
O E2 111.111.111.111 [110/20] via 1.1.1.1, 00:03:23, Serial0/0
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Route Table of Router 1 whereby router 2 is injecting via a route-map
calling an access-list

BB1#sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     221.221.221.0/32 is subnetted, 1 subnets
O E2 221.221.221.221 [110/20] via 1.1.1.2, 00:04:39, Serial0/0
     220.220.220.0/32 is subnetted, 1 subnets
O E2 220.220.220.220 [110/20] via 1.1.1.2, 00:04:39, Serial0/0
     222.222.222.0/32 is subnetted, 1 subnets
O E2 222.222.222.222 [110/20] via 1.1.1.2, 00:04:39, Serial0/0
     1.0.0.0/30 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Serial0/0
     113.0.0.0/32 is subnetted, 1 subnets
C 113.113.113.113 is directly connected, Loopback2
     112.0.0.0/32 is subnetted, 1 subnets
C 112.112.112.112 is directly connected, Loopback1
     111.0.0.0/32 is subnetted, 1 subnets
C 111.111.111.111 is directly connected, Loopback0
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

As far as I can see they are being injected in the exact same way!

So where would the difference be?

With the exception of calling an acl

Please anyone?

Best Regards
Paul



This archive was generated by hypermail 2.1.4 : Fri Dec 01 2006 - 08:05:48 ART