Cyscoexpert Official Configs

From: IPSec (ipsec@xxxxxxxxxxxxx)
Date: Sun Jul 14 2002 - 02:12:31 GMT-3


   
Hi Group,

Here are the official lab solutions:

TermServ-34>1
[Resuming connection 1 to rack3r1 ... ]

R1#sh run
Building configuration...

Current configuration : 2014 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
enable password cisco
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ipx routing 0001.0001.0001
!
!
dlsw local-peer peer-id 150.1.1.1
dlsw remote-peer 0 tcp 150.1.3.3
dlsw icanreach mac-exclusive
dlsw icanreach mac-address 7145.a0e3.0000 mask ffff.ffff.0000
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.1.1.1 255.255.255.0
 ipx network 1
!
interface Loopback1
 ip address 220.1.0.1 255.255.255.0
!
interface Loopback2
 ip address 220.1.1.1 255.255.255.0
!
interface Loopback3
 ip address 220.1.2.1 255.255.255.0
!
interface Loopback4
 ip address 220.1.3.1 255.255.255.0
!
interface Loopback10
 ip address 195.1.1.1 255.255.255.0
!
interface Ethernet0
 ip address 150.1.10.1 255.255.255.0
 ipx network 10
 bridge-group 1
!
interface Serial0
 ip address 150.1.14.1 255.255.255.0
 ip summary-address eigrp 100 220.1.0.0 255.255.252.0 5
 ipx network 14
 no fair-queue
 clockrate 2000000
!
interface Serial1
 ip address 150.1.12.1 255.255.255.0
 ipx network 12
 clockrate 2000000
!
interface TokenRing0
 no ip address
 shutdown
!
router eigrp 100
 network 150.1.14.1 0.0.0.0
 network 220.1.0.0 0.0.3.255
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 router-id 150.1.1.1
 log-adjacency-changes
 area 12 nssa
 network 150.1.1.1 0.0.0.0 area 12
 network 150.1.12.1 0.0.0.0 area 12
!
router bgp 1
 bgp log-neighbor-changes
 network 195.1.1.0
 neighbor 150.1.12.2 remote-as 256
 neighbor 150.1.14.4 remote-as 34
 neighbor 150.1.14.4 route-map PREPEND out
!
ip classless
ip http server
!
!
ip prefix-list R1_LOOPBACK seq 5 permit 195.1.1.0/24
route-map PREPEND permit 10
 match ip address prefix-list R1_LOOPBACK
 set as-path prepend 1 1
!
route-map PREPEND permit 20
!
!
!
!
!
bridge 1 protocol ieee
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 no login
!
end

R1#
TermServ-34>2
[Resuming connection 2 to rack3r2 ... ]

R2#sh run
Building configuration...

Current configuration : 2171 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
enable password cisco
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ipx routing 0002.0002.0002
ipx internal-network 2222
!
!
!
interface Loopback0
 ip address 150.1.2.2 255.255.255.0
 ipx network 2
!
interface Loopback10
 ip address 195.1.2.2 255.255.255.0
!
interface Tunnel0
 ip address 150.1.24.2 255.255.255.0
 ipx network 24
 tunnel source Loopback0
 tunnel destination 150.1.4.4
!
interface Ethernet0
 ip address 150.1.222.2 255.255.255.0
 no ip redirects
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-multipoint
 ipx network 222
 ipx nlsp enable
 standby 1 ip 150.1.222.1
 standby 1 priority 50
 standby 1 preempt
 standby 1 track Serial0 50
!
interface Serial0
 ip address 150.1.12.2 255.255.255.0
 ipx network 12
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 100
 redistribute ospf 1 metric 1 1 1 1 1
 network 150.1.24.2 0.0.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 router-id 150.1.2.2
 log-adjacency-changes
 area 0 authentication
 area 12 nssa
 area 51 authentication message-digest
 area 51 virtual-link 150.1.5.5 authentication-key cisco
 redistribute eigrp 100 subnets
 network 150.1.2.2 0.0.0.0 area 51
 network 150.1.12.2 0.0.0.0 area 12
 network 150.1.222.2 0.0.0.0 area 51
!
router bgp 256
 no synchronization
 bgp log-neighbor-changes
 network 195.1.2.0
 neighbor 150.1.4.4 remote-as 34
 neighbor 150.1.4.4 ebgp-multihop 255
 neighbor 150.1.4.4 update-source Loopback0
 neighbor 150.1.12.1 remote-as 1
 neighbor 150.1.12.1 route-map LOCALPREF in
 neighbor 150.1.222.6 remote-as 256
!
ip classless
ip http server
!
!
ip prefix-list R3_LOOPBACK seq 5 permit 195.1.3.0/24
route-map LOCALPREF permit 10
 match ip address prefix-list R3_LOOPBACK
 set local-preference 200
!
route-map LOCALPREF permit 20
!
!
!
!
ipx router nlsp
 area-address 0 0
!
!
ipx router rip
 no network 222
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 no login
!
end

R2#
TermServ-34>3
[Resuming connection 3 to rack3r3 ... ]

R3#sh run
Building configuration...

Current configuration : 1973 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
enable password cisco
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ipx routing 0003.0003.0003
!
!
dlsw local-peer peer-id 150.1.3.3
dlsw remote-peer 0 tcp 150.1.1.1
dlsw remote-peer 0 frame-relay interface Serial0 304
dlsw icannotreach sap F0
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.1.3.3 255.255.255.0
 ipx network 3
!
interface Loopback10
 ip address 195.1.3.3 255.255.255.0
!
interface Serial0
 ip address 150.1.111.3 255.255.255.248
 encapsulation frame-relay
 ip ospf authentication-key cisco
 ip ospf priority 255
 ipx network 111
 no ipx split-horizon eigrp 11
 no arp frame-relay
 frame-relay map llc2 304 broadcast
 frame-relay map ip 150.1.111.4 304 broadcast
 frame-relay map ip 150.1.111.5 305 broadcast
 frame-relay map ipx 111.0004.0004.0004 304 broadcast
 frame-relay map ipx 111.0005.0005.0005 305 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial1
 no ip address
 shutdown
!
interface Ethernet0
 ip address 150.1.30.3 255.255.255.0
 ipx network 30
 bridge-group 1
!
interface BRI0
 no ip address
 shutdown
 isdn x25 static-tei 0
!
router ospf 1
 router-id 150.1.3.3
 log-adjacency-changes
 area 0 authentication
 redistribute connected subnets route-map CONNECTED
 network 150.1.3.3 0.0.0.0 area 0
 network 150.1.111.3 0.0.0.0 area 0
 neighbor 150.1.111.5
 neighbor 150.1.111.4
!
router bgp 34
 no synchronization
 bgp log-neighbor-changes
 network 195.1.3.0
 neighbor 150.1.111.4 remote-as 34
!
ip classless
ip http server
!
route-map CONNECTED permit 10
 match interface Ethernet0
!
!
!
!
ipx router eigrp 11
 network 111
!
!
ipx router rip
 no network 111
!
!
!
bridge 1 protocol ieee
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 no login
!
end

R3#
TermServ-34>4
[Resuming connection 4 to rack3r4 ... ]

R4#sh run
Building configuration...

Current configuration : 3401 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
enable password cisco
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ipx routing 0004.0004.0004
!
!
dlsw local-peer peer-id 150.1.4.4
dlsw remote-peer 0 frame-relay interface Serial0 403
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.1.4.4 255.255.255.0
 ipx network 4
!
interface Loopback10
 ip address 195.1.4.4 255.255.255.0
!
interface Tunnel0
 ip address 150.1.24.4 255.255.255.0
 ipx network 24
 ipx output-sap-filter 1001
 tunnel source Loopback0
 tunnel destination 150.1.2.2
!
interface Ethernet0
 ip address 170.1.1.1 255.255.255.0
 ipx input-sap-filter 1000
 ipx network 1000
 bridge-group 1
!
interface Serial0
 ip address 150.1.111.4 255.255.255.248
 encapsulation frame-relay
 ip ospf authentication-key cisco
 ip ospf priority 0
 ipx network 111
 ipx output-sap-filter 1001
 no arp frame-relay
 frame-relay map llc2 403 broadcast
 frame-relay map ip 150.1.111.3 403 broadcast
 frame-relay map ip 150.1.111.5 403 broadcast
 frame-relay map ipx 111.0003.0003.0003 403 broadcast
 frame-relay map ipx 111.0005.0005.0005 403 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial1
 ip address 150.1.14.4 255.255.255.0
 ipx network 14
 ipx output-sap-filter 1001
!
interface BRI0
 no ip address
 shutdown
 isdn x25 static-tei 0
!
router eigrp 100
 redistribute rip metric 1 1 1 1 1
 network 150.1.14.4 0.0.0.0
 network 150.1.24.4 0.0.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 router-id 150.1.4.4
 log-adjacency-changes
 area 0 authentication
 redistribute rip subnets route-map RIP2OSPF
 network 150.1.4.4 0.0.0.0 area 0
 network 150.1.111.4 0.0.0.0 area 0
 distance 171 0.0.0.0 255.255.255.255 1
!
router rip
 timers basic 10 60 60 80
 network 170.1.0.0
!
router bgp 34
 no synchronization
 bgp log-neighbor-changes
 network 195.1.4.0
 neighbor 150.1.2.2 remote-as 256
 neighbor 150.1.2.2 ebgp-multihop 255
 neighbor 150.1.2.2 update-source Loopback0
 neighbor 150.1.2.2 route-map MED out
 neighbor 150.1.14.1 remote-as 1
 neighbor 150.1.14.1 route-map MED out
 neighbor 150.1.111.3 remote-as 34
 neighbor 150.1.111.3 route-map MED out
 neighbor 170.1.1.254 remote-as 100
 neighbor 170.1.1.254 route-map NO-EXPORT in
!
ip classless
ip http server
ip as-path access-list 1 permit _1000_
ip as-path access-list 2 permit ^100_
!
!
ip access-list standard EVEN_SECOND_OCTET
 permit 0.0.0.0 255.254.255.255
ip access-list standard ODD_THIRD_OCTET
 permit 0.0.1.0 255.255.254.255
access-list 1 permit 150.1.30.0
access-list 1000 deny FFFFFFFF 4
access-list 1000 permit FFFFFFFF
access-list 1001 deny 1.0000.0000.0000 FFFFFFFE.ffff.ffff.ffff 7
access-list 1001 permit FFFFFFFF
route-map NO-EXPORT permit 10
 match as-path 1
 set community no-export
!
route-map NO-EXPORT permit 20
!
route-map MED permit 10
 match ip address ODD_THIRD_OCTET
 match as-path 2
 set metric 31337
!
route-map MED permit 20
!
route-map RIP2OSPF permit 10
 match ip address EVEN_SECOND_OCTET
 set metric 1000
!
route-map RIP2OSPF permit 20
 set metric-type type-1
!
!
!
!
ipx router eigrp 11
 network 111
!
!
ipx router rip
 no network 111
!
!
!
bridge 1 protocol ieee
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 no login
!
end

R4#
TermServ-34>5
[Resuming connection 5 to rack3r5 ... ]

R5#sh run
Building configuration...

Current configuration : 2019 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R5
!
enable password cisco
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ipx routing 0005.0005.0005
ipx internal-network 5555
!
!
!
interface Loopback0
 ip address 150.1.5.5 255.255.255.0
 ipx network 5
!
interface Loopback10
 ip address 195.1.5.5 255.255.255.0
!
interface Ethernet0
 ip address 150.1.222.5 255.255.255.0
 no ip redirects
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-multipoint
 ipx network 222
 ipx nlsp enable
 standby 1 ip 150.1.222.1
 standby 1 preempt
 standby 1 track Serial0 100
!
interface Serial0
 ip address 150.1.111.5 255.255.255.248
 encapsulation frame-relay
 ip ospf authentication-key cisco
 ip ospf priority 0
 ipx network 111
 no arp frame-relay
 frame-relay map ip 150.1.111.3 503 broadcast
 frame-relay map ip 150.1.111.4 503 broadcast
 frame-relay map ipx 111.0003.0003.0003 503 broadcast
 frame-relay map ipx 111.0004.0004.0004 503 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial1
 no ip address
 shutdown
!
interface Serial2
 no ip address
 shutdown
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
 isdn x25 static-tei 0
!
router ospf 1
 router-id 150.1.5.5
 log-adjacency-changes
 area 0 authentication
 area 51 authentication message-digest
 area 51 virtual-link 150.1.2.2 authentication-key cisco
 network 150.1.5.5 0.0.0.0 area 0
 network 150.1.111.5 0.0.0.0 area 0
 network 150.1.222.5 0.0.0.0 area 51
!
router bgp 256
 no synchronization
 bgp log-neighbor-changes
 network 195.1.5.0
 neighbor 150.1.222.6 remote-as 256
!
ip classless
ip http server
!
!
!
!
ipx router eigrp 11
 network 111
!
!
ipx router nlsp
 area-address 0 0
!
!
ipx router rip
 no network 111
 no network 222
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 no login
!
end

R5#
TermServ-34>6
[Resuming connection 6 to rack3r6 ... ]

R6#sh run
Building configuration...

Current configuration : 1945 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R6
!
logging rate-limit console 10 except errors
enable password cisco
!
ip subnet-zero
!
!
no ip finger
no ip domain-lookup
!
ipx routing 0006.0006.0006
ipx internal-network 6666
call rsvp-sync
cns event-service server
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.6.6 255.255.255.0
 ipx network 6
!
interface Loopback10
 ip address 195.1.6.6 255.255.255.0
!
interface BRI0/0
 no ip address
 shutdown
!
interface Ethernet0/0
 ip address 150.1.222.6 255.255.255.0
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-multipoint
 half-duplex
 ipx network 222
 ipx nlsp enable
 standby 1 priority 25 preempt
 standby 1 ip 150.1.222.1
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 shutdown
 frame-relay lmi-type cisco
!
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ATM3/0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
router ospf 1
 router-id 150.1.6.6
 log-adjacency-changes
 area 51 authentication message-digest
 network 150.1.6.6 0.0.0.0 area 51
 network 150.1.222.6 0.0.0.0 area 51
!
router bgp 256
 no synchronization
 bgp log-neighbor-changes
 network 195.1.6.0
 neighbor 150.1.222.2 remote-as 256
 neighbor 150.1.222.2 route-reflector-client
 neighbor 150.1.222.5 remote-as 256
 neighbor 150.1.222.5 route-reflector-client
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
!
ipx router nlsp
 area-address 0 0
!
!
ipx router rip
 no network 222
!
!
!
!
voice-port 2/0/0
!
voice-port 2/0/1
!
dial-peer cor custom
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
line aux 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 no login
!
end

> Guys,
>
> I have re created the configs for Cyscoexpert labs, since I was getting
> a
> few queries. It would create havoc to send the config to the whole group
> (also, zipped or attachments are not supported).
>
> Can someone suggest if a similar service exists on Group study FTP
> server
> (if such a thing exists). Otherwise I will prolly upload it on one of
> the
> free sites and post the url..
>
> The reason I want to do is to get the discussion on the ways other
> people
> have configged it, and I am also planning to suggest different ways
> (where
> possible) to acheive the same result.
>
> rgds
> Nick



This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:36:29 GMT-3