Re: Multicast VPN

From: John Neiberger <jneiberger_at_gmail.com>
Date: Sun, 10 Feb 2013 17:23:56 -0700

If R2 is the PE closest to the source, don't you need to configure mdt
default in your VRF config there? I see you have it on R4, but isn't that
backward? I'm pretty new to mVPN, so I'm not really sure. It just seems
like you need it on R2.

John

On Sun, Feb 10, 2013 at 2:53 PM, Mohammad Khalil <eng_mssk_at_hotmail.com>wrote:

> Hi all
> I have the below topology
> R1 -- R2 -- R3 -- R4 -- R5
> R2 and R4 are my PE routers , I am trying to implement multicast VPN ,
> please find below
>
> R1#sh run int f1/0
> Building configuration...
>
> Current configuration : 114 bytes
> !
> interface FastEthernet1/0
> ip address 192.1.12.1 255.255.255.0
> speed 100
> duplex full
> end
>
> R1#sh run | inc ip route
> ip route 0.0.0.0 0.0.0.0 192.1.12.2
>
> R2#sh run int f1/0
> Building configuration...
>
> Current configuration : 136 bytes
> !
> interface FastEthernet1/0
> vrf forwarding VPN_A
> ip address 192.1.12.2 255.255.255.0
> ip pim sparse-mode
> speed 100
> duplex full
> end
>
> R2#sh run int f1/1
> Building configuration...
>
> Current configuration : 123 bytes
> !
> interface FastEthernet1/1
> ip address 192.1.23.2 255.255.255.0
> ip pim sparse-mode
> speed 100
> duplex full
> mpls ip
> end
>
> R2#sh run int lo0
> Building configuration...
>
> Current configuration : 83 bytes
> !
> interface Loopback0
> ip address 2.2.2.2 255.255.255.255
> ip pim sparse-mode
> end
>
> R2#sh run | sec router bgp
> router bgp 100
> bgp log-neighbor-changes
> no bgp default ipv4-unicast
> neighbor 4.4.4.4 remote-as 100
> neighbor 4.4.4.4 update-source Loopback0
> !
> address-family ipv4
> exit-address-family
> !
> address-family vpnv4
> neighbor 4.4.4.4 activate
> neighbor 4.4.4.4 send-community both
> exit-address-family
>
> address-family ipv4 mdt
> neighbor 4.4.4.4 activate
> neighbor 4.4.4.4 send-community both
> exit-address-family
> !
> address-family ipv4 vrf VPN_A
> network 192.1.12.0
> exit-address-family
> R2#sh run | sec router ospf
> router ospf 1
> router-id 2.2.2.2
> network 2.2.2.2 0.0.0.0 area 0
> network 192.1.23.2 0.0.0.0 area 0
>
> R2#sh run | inc multi
> ip multicast-routing
> ip multicast-routing vrf VPN_A
>
> R3#sh run int f1/0
> Building configuration...
>
> Current configuration : 123 bytes
> !
> interface FastEthernet1/0
> ip address 192.1.23.3 255.255.255.0
> ip pim sparse-mode
> speed 100
> duplex full
> mpls ip
> end
>
> R3#sh run int f1/1
> Building configuration...
>
> Current configuration : 123 bytes
> !
> interface FastEthernet1/1
> ip address 192.1.34.3 255.255.255.0
> ip pim sparse-mode
> speed 100
> duplex full
> mpls ip
> end
>
> R3#sh run int lo0
> Building configuration...
>
> Current configuration : 63 bytes
> !
> interface Loopback0
> ip address 3.3.3.3 255.255.255.255
> end
>
> R3#sh run | sec router ospf
> router ospf 1
> router-id 3.3.3.3
> network 3.3.3.3 0.0.0.0 area 0
> network 192.1.23.3 0.0.0.0 area 0
> network 192.1.34.3 0.0.0.0 area 0
> R3#sh run | inc multic
> ip multicast-routing
>
> R4#sh run int f1/0
> Building configuration...
>
> Current configuration : 123 bytes
> !
> interface FastEthernet1/0
> ip address 192.1.34.4 255.255.255.0
> ip pim sparse-mode
> speed 100
> duplex full
> mpls ip
> end
>
> R4#sh run int f1/1
> Building configuration...
>
> Current configuration : 136 bytes
> !
> interface FastEthernet1/1
> vrf forwarding VPN_A
> ip address 192.1.45.4 255.255.255.0
> ip pim sparse-mode
> speed 100
> duplex full
> end
>
> R4#sh run int lo0
> Building configuration...
>
> Current configuration : 113 bytes
> !
> interface Loopback0
> ip address 4.4.4.4 255.255.255.255
> ip pim sparse-mode
> ip igmp join-group 234.4.4.4
> end
>
> R4#sh run | sec router ospf
> router ospf 1
> router-id 4.4.4.4
> network 4.4.4.4 0.0.0.0 area 0
> network 192.1.34.4 0.0.0.0 area 0
> R4#sh run | sec router bgp
> router bgp 100
> bgp log-neighbor-changes
> no bgp default ipv4-unicast
> neighbor 2.2.2.2 remote-as 100
> neighbor 2.2.2.2 update-source Loopback0
> !
> address-family ipv4
> exit-address-family
> !
> address-family vpnv4
> neighbor 2.2.2.2 activate
> neighbor 2.2.2.2 send-community both
> exit-address-family
>
> address-family ipv4 mdt
> neighbor 2.2.2.2 activate
> neighbor 2.2.2.2 send-community both
> exit-address-family
> !
> address-family ipv4 vrf VPN_A
> network 192.1.45.0
> exit-address-family
> R4#sh run | inc multi
> ip multicast-routing
> ip multicast-routing vrf VPN_A
>
> R4#sh run | sec vrf def
> vrf definition VPN_A
> rd 100:1
> route-target export 100:1
> route-target import 100:1
> !
> address-family ipv4
> mdt default 232.0.0.1
> mdt data 232.0.1.0 0.0.0.255
> exit-address-family
>
> R5#sh run int f1/0
> Building configuration...
>
> Current configuration : 144 bytes
> !
> interface FastEthernet1/0
> ip address 192.1.45.5 255.255.255.0
> ip pim sparse-mode
> ip igmp join-group 235.5.5.5
> speed 100
> duplex full
> end
>
> R5#sh run | inc ip route
> ip route 0.0.0.0 0.0.0.0 192.1.45.4
>
> R1#ping 192.1.45.5 sou f1/0
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 192.1.45.5, timeout is 2 seconds:
> Packet sent with a source address of 192.1.12.1
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 16/18/28 ms
>
> R2#sh bgp ipv4 mdt all summary
> BGP router identifier 2.2.2.2, local AS number 100
> BGP table version is 3, main routing table version 3
> 2 network entries using 320 bytes of memory
> 2 path entries using 168 bytes of memory
> 2/2 BGP path/bestpath attribute entries using 272 bytes of memory
> 1 BGP extended community entries using 24 bytes of memory
> 0 BGP route-map cache entries using 0 bytes of memory
> 0 BGP filter-list cache entries using 0 bytes of memory
> BGP using 784 total bytes of memory
> BGP activity 4/0 prefixes, 6/2 paths, scan interval 60 secs
>
> Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
> State/PfxRcd
> 4.4.4.4 4 100 26 26 3 0 0 00:16:08
> 1
> R2#sh bgp ipv4 mdt all
> BGP table version is 3, local router ID is 2.2.2.2
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal,
> r RIB-failure, S Stale, m multipath, b backup-path, f
> RT-Filter,
> x best-external, a additional-path, c RIB-compressed,
> Origin codes: i - IGP, e - EGP, ? - incomplete
> RPKI validation codes: V valid, I invalid, N Not found
>
> Network Next Hop Metric LocPrf Weight Path
> Route Distinguisher: 100:1 (default for vrf VPN_A)
> *> 2.2.2.2/32 0.0.0.0 0 ?
> *>i 4.4.4.4/32 4.4.4.4 0 100 0 ?
>
> But i am not able to ping the group joined on R5 F1/0
>
> R1#ping 235.5.5.5 repeat 1
> Type escape sequence to abort.
> Sending 1, 100-byte ICMP Echos to 235.5.5.5, timeout is 2 seconds:
> .
>
> Thanks
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Sun Feb 10 2013 - 17:23:56 ART

This archive was generated by hypermail 2.2.0 : Fri Mar 01 2013 - 07:57:58 ART