Re: Route Leaking MPLS VPN Scenario

From: garry baker <baker.garry_at_gmail.com>
Date: Wed, 24 Nov 2010 18:04:09 -0800

try this:

ip route static inter-vrf *******without this command i got this message -
*Mar 1 01:17:26.247: %IPRT-3-STATICROUTESACROSSVRF: Un-installing static
route 10.10.10.0/24 from global routing table with outgoing interface
FastEt!*******

ip route 10.10.10.0 255.255.255.0 FastEthernet0/0
ip route vrf VAS 1.1.1.1 255.255.255.255 42.42.42.2 global

--
Garry L. Baker
"There is no 'patch' for stupidity." - www.sqlsecurity.com
On Wed, Nov 24, 2010 at 11:26 AM, SD <networker.ccie_at_gmail.com> wrote:
> *Access layer router*
>
> interface Loopback0
>  ip address 1.1.1.1 255.255.255.255
>  no clns route-cache
> !
> !
> interface FastEthernet1/1
>  ip address 42.42.42.2 255.255.255.252
>  duplex auto
>  speed auto
>  no clns route-cache
>
> ip classless
>
> ip route 0.0.0.0 0.0.0.0 42.42.42.1
>
>
> *VRF-Lite CE*
>
> !
> ip vrf VAS
>  rd 1:1
> !
> !
> interface FastEthernet1/1
>  ip address 42.42.42.1 255.255.255.252
>  description ***Link to Access Layer Router***
>  duplex auto
>  speed auto
>  no clns route-cache
> end
>
> !
> interface FastEthernet0/0.100
>  encapsulation dot1Q 100
>  description ***Link to PE***
>  ip vrf forwarding VAS
>  ip address 10.10.10.9 255.255.255.252
> end
>
> router bgp 200
>  no synchronization
>  bgp log-neighbor-changes
>  no auto-summary
>  !
>  address-family ipv4 vrf VAS
>  redistribute static
>  neighbor 10.10.10.10 remote-as 100
>  neighbor 10.10.10.10 activate
>  no auto-summary
>  no synchronization
>  exit-address-family
>
>  ip route vrf VAS 1.1.1.1 255.255.255.255 42.42.42.2 global
>
>
> *PE ROUTER*
>
> ip vrf VAS
>  rd 1:1
>  route-target both 1:1
>
> interface FastEthernet0/0.100
>  encapsulation dot1Q 100
>  description ***link to VRF-LITE CE***
>  ip vrf forwarding VAS
>  ip address 10.10.10.34 255.255.255.252
> end
>
> router bgp 100
>  no synchronization
>  bgp log-neighbor-changes
>
> address-family ipv4 vrf VAS
>  neighbor 10.10.10.33 remote-as 200
>  neighbor 10.10.10.33 activate
>  no auto-summary
>  no synchronization
>  exit-address-family
>
>
>
>
>
> now I don't want to configure VRF on interface Fa1/1 but forward traffic
> coming from fa0/0.100 to access layer router and vice versa.
>
>
>
> Regards
> Sachin
>
>
>
>
> On Wed, Nov 24, 2010 at 10:11 PM, garry baker <baker.garry_at_gmail.com>wrote:
>
>> can you send the configs?
>>
>>
>> --
>> Garry L. Baker
>>
>> "There is no 'patch' for stupidity." - www.sqlsecurity.com
>>
>>
>> On Wed, Nov 24, 2010 at 1:02 PM, SD <networker.ccie_at_gmail.com> wrote:
>>
>>> simple diagramin 1 line
>>>
>>>
>>> [Access Layer Router] <<<<<Fa0/0<<>>>>>Fa0/0>>>[ VRF-Lite CE]<<(VRF
>>> Test)<<<Fa0/1<<<>>>>>Fa0/1>>>(VRF Test)>>[MPLS PE]>>>>>>>>>>>>>>>>>Remote
>>> Site CE in VRF Test
>>>
>>>
>>>
>>>
>>> On Wed, Nov 24, 2010 at 9:57 PM, garry baker <baker.garry_at_gmail.com>wrote:
>>>
>>>> your diagram came out all garbled but i had this link to route leaking
>>>> bookmarked:
>>>>
>>>>
>>>> http://www.cisco.com/en/US/tech/tk436/tk832/technologies_configuration_example09186a0080231a3e.shtml
>>>>
>>>> maybe it will help out...
>>>>
>>>>
>>>> --
>>>> Garry L. Baker
>>>>
>>>> "There is no 'patch' for stupidity." - www.sqlsecurity.com
>>>>
>>>>
>>>> On Wed, Nov 24, 2010 at 12:45 PM, SD <networker.ccie_at_gmail.com> wrote:
>>>>
>>>>> Hi All
>>>>>
>>>>>
>>>>> ______________________                        __________________
>>>>>                                _________________
>>>>> | Access Layer route r      | Fa0/0      Fa0/0| VRF-Lite CE          |
>>>>> fa1/1               fa1/1   |   MPLS PE Router |
>>>>> |_____________________|------------------------|_________________| VRF
>>>>> test-----VRF test|_________________|
>>>>>
>>>>>
>>>>> Access Layer Router has loopback 1.1.1.1 which should be advertised in
>>>>> vrf
>>>>> test on PE in ebgp, I have ebgp running between CE and PE and CE has an
>>>>> interface configured in vrf test as this is a vrf lite scenario, there
>>>>> is a
>>>>> static route in global routing table of CE for network 1.1.1.1 pointing
>>>>> towards access layer router, now i want to reach 1.1.1.1 without
>>>>> configuring
>>>>> VRF test on CE's interface to access layer router.
>>>>>
>>>>>
>>>>> How we can achieve this using route leaking from global roiuting table
>>>>> to
>>>>> VRF routing table.
>>>>>
>>>>> Regards
>>>>>
>>>>>
>>>>> Blogs and organic groups at http://www.ccie.net
>>>>>
>>>>> _______________________________________________________________________
>>>>> Subscription information may be found at:
>>>>> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Wed Nov 24 2010 - 18:04:09 ART

This archive was generated by hypermail 2.2.0 : Sun Dec 05 2010 - 22:14:56 ART