Re: ISIS route-leaking help..

From: JR Garcia <ttuner_at_gmail.com>
Date: Tue, 12 Jan 2010 21:54:44 -0900

Router 1:

hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
 ip router isis 2
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.252
 ip router isis 1
 duplex auto
 speed auto
 isis circuit-type level-1
!
router isis 2
 net 02.0000.0000.0001.00
 is-type level-2-only
 metric-style wide
!
router isis 1
 net 00.0000.0000.0001.00
 is-type level-1
 metric-style wide
 redistribute isis ip level-2 into level-1 distribute-list 102
!
ip http server
ip classless
!
!
access-list 102 permit ip any any
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Router 2

hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.2 255.255.255.252
 ip router isis 1
 duplex auto
 speed auto
!
router isis 1
 net 00.0000.0000.0002.00
 is-type level-1
 metric-style wide
!
ip http server
ip classless
!
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Sh ip route from router 2:

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

     2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback1
     192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/0
i*L1 0.0.0.0/0 [115/10] via 192.168.1.1, FastEthernet0/0

Blogs and organic groups at http://www.ccie.net
Received on Tue Jan 12 2010 - 21:54:44 ART

This archive was generated by hypermail 2.2.0 : Thu Feb 04 2010 - 20:28:41 ART