Re: MPLS VPN - difficulties in last level trouble shooting

From: Akber Ali Mirza <akberali.cisco_at_gmail.com>
Date: Tue, 21 Apr 2009 21:40:23 +0530

Hi GS,

I wasnt aware earlier that we should not attach files in this study group!

Hence pasting my Configuration & Diagram in below -

 Example

*MPLS Configuraion using above diagram*
**
+++++++++++++++++++++++++++++++++++++++++++++++
R1:
int se 1/0
no shut
ip add 192.168.13.2 255.255.255.0
int lo 0
ip add 150.1.1.1 255.255.255.255
int Lo 1
ip add 172.31.1.1 255.255.255.0
no shut
router bgp 1
bgp router-id 150.1.1.1
no synchr
redistribute connected
neighbor 192.168.13.1 remote-as 101
no auto-summary
exit
router rip
ver 2
no auto-sum
network 172.31.1.0
+++++++++++++++++++++++++++++++++++++++++++++++++++
R2:
int ser 1/0
no shut
ip add 192.168.25.2 255.255.255.0
int lo 0
ip add 150.1.2.2 255.255.255.255
int Lo 1
ip add 172.31.2.1 255.255.255.0
router bgp 2
bgp router-id 150.1.2.2
no synchr
redistribute connected
neighbor 192.168.25.1 remote-as 101
no auto-summary
exit
router rip
ver 2
no auto-sum
network 172.31.2.0
++++++++++++++++++++++++++++++++++++++++++++++++++++
R7:
int ser 1/0
no shut
ip add 192.168.67.2 255.255.255.0
int Lo 1
ip add 172.31.7.1 255.255.255.0
int lo 0
ip add 150.1.7.7 255.255.255.255
router bgp 7
bgp router-id 150.1.7.7
no synchr
redistribute connected
neighbor 192.168.67.1 remote-as 101
no auto-summary
exit
router rip
ver 2
no auto-sum
network 172.31.7.0
+++++++++++++++++++++++++++++++++++++++++++++++++++++
R8:
int ser 1/0
no shut
ip add 192.168.58.2 255.255.255.0
int Lo 1
ip add 172.31.8.1 255.255.255.0
int lo 0
ip add 150.1.8.8 255.255.255.255
router bgp 8
bgp router-id 150.1.8.8
no synchro
redistribute connected
neighbor 192.168.58.1 remote-as 101
no auto-summary
exit
router rip
ver 2
no auto-sum
network 172.31.8.0

++++++++++++++++++++++++++++++++++++++++++++++++++++
R3:
ip vrf CustB
description Customer B
rd 1:1
route-target export 1:1
route-target import 1:1
interface Serial1/0
no shut
ip vrf forwarding CustB
ip address 192.168.13.1 255.255.255.252
int ser 1/1
no shut
ip add 192.168.36.1 255.255.255.0
int gi 2/0
no shut
ip add 192.168.34.1 255.255.255.0
int Lo 0
ip add 150.1.3.3 255.255.255.0
router bgp 101
no synch
redistribute connected
bgp router-id 150.1.3.3
no bgp default ipv4-unicast
neighbor 192.168.13.2 remote-as 1
address-family ipv4 vrf CustB
neighbor 192.168.13.2 remote-as 1
neighbor 192.168.13.2 activate
exit-address-family
mpls ip
mpls label protocol ldp
mpls ldp advertise-labels
router bgp 101
neighbor 150.1.5.5 remote-as 101
neighbor 150.1.5.5 update-source lo0
neighbor 150.1.6.6 remote-as 101
neighbor 150.1.6.6 update-source lo0
address-family vpnv4
neighbor 150.1.5.5 activate
neighbor 150.1.5.5 send-community extended
neighbor 150.1.6.6 activate
neighbor 150.1.6.6 send-community extended
exit-address-family
ip route 192.168.67.0 255.255.255.0 192.168.36.2
ip route 192.168.25.0 255.255.255.0 192.168.34.2
ip route 192.168.58.0 255.255.255.0 192.168.34.2
ip route 150.1.5.5 255.255.255.255 192.168.34.2
ip route 150.1.6.6 255.255.255.255 192.168.36.2
+++++++++++++++++++++++++++++++++++++++++++++++++++
R5:
ip vrf CustA
description Customer A
rd 2:1
route-target export 2:1
route-target import 2:1
ip vrf CustB
description Customer B
rd 1:1
route-target export 1:1
route-target import 1:1
exit
interface Serial1/2
ip vrf forwarding CustA
ip address 192.168.25.1 255.255.255.252
no shut
interface Serial1/1
ip vrf forwarding CustB
ip address 192.168.58.1 255.255.255.252
no shut
int serial 1/0
no shut
ip add 192.168.56.1 255.255.255.0
int gi 2/0
no shut
ip add 192.168.45.1 255.255.255.0
int Lo 0
ip add 150.1.5.5 255.255.255.0
router bgp 101
no synch
redistribute connected
bgp router-id 150.1.5.5
no bgp default ipv4-unicast
neighbor 192.168.25.2 remote-as 2
neighbor 192.168.58.2 remote-as 8
address-family ipv4 vrf CustA
neighbor 192.168.25.2 remote-as 2
neighbor 192.168.25.2 activate
exit-address-family
address-family ipv4 vrf CustB
neighbor 192.168.58.2 remote-as 8
neighbor 192.168.58.2 activate
exit-address-family
mpls ip
mpls label protocol ldp
mpls ldp advertise-labels
router bgp 101
neighbor 150.1.3.3 remote-as 101
neighbor 150.1.3.3 update-source lo0
neighbor 150.1.6.6 remote-as 101
neighbor 150.1.6.6 update-source lo0
address-family vpnv4
neighbor 150.1.3.3 activate
neighbor 150.1.3.3 send-community extended
neighbor 150.1.6.6 activate
neighbor 150.1.6.6 send-community extended
exit-address-family
ip route 192.168.67.0 255.255.255.0 192.168.56.2
ip route 192.168.13.0 255.255.255.0 192.168.45.2
ip route 150.1.3.3 255.255.255.255 192.168.45.2
ip route 150.1.6.6 255.255.255.255 192.168.56.2
+++++++++++++++++++++++++++++++++++++++++++++++++
R6
ip vrf CustA
description Customer A
rd 2:1
route-target export 2:1
route-target import 2:1
exit
interface Serial1/1
ip vrf forwarding CustA
ip address 192.168.67.1 255.255.255.252
no shut
int ser 1/0
no shut
ip add 192.168.36.2 255.255.255.0
int ser 1/2
no shut
ip add 192.168.56.2 255.255.255.0
int Lo 0
ip add 150.1.6.6 255.255.255.0
router bgp 101
neighbor 150.1.3.3 remote-as 101
neighbor 150.1.3.3 update-source lo0
neighbor 150.1.5.5 remote-as 101
neighbor 150.1.5.5 update-source lo0
address-family vpnv4
neighbor 150.1.3.3 activate
neighbor 150.1.3.3 send-community extended
neighbor 150.1.5.5 activate
neighbor 150.1.5.5 send-community extended
exit-address-family
ip route 192.168.13.0 255.255.255.0 192.168.36.1
ip route 192.168.25.0 255.255.255.0 192.168.56.1
ip route 192.168.58.0 255.255.255.0 192.168.56.1
ip route 150.1.3.3 255.255.255.255 192.168.36.1
ip route 150.1.5.5 255.255.255.255 192.168.56.1
router bgp 101
no sync
bgp router-id 150.1.6.6
no bgp default ipv4-unicast
neighbor 192.168.67.2 remote-as 7
address-family ipv4 vrf CustA
neighbor 192.168.67.2 remote-as 7
neighbor 192.168.67.2 activate
exit-address-family
mpls ip
mpls label protocol ldp
mpls ldp advertise-labels
++++++++++++++++++++++++++++++++++++++++++++++++++
R4:
int gi 1/0
no shut
ip add 192.168.34.2 255.255.255.0
int gi 2/0
no shut
ip add 192.168.45.2 255.255.255.0
ip route 192.168.34.0 255.255.255.0 192.168.36.1
ip route 192.168.45.0 255.255.255.0 192.168.56.1
ip route 0.0.0.0 0.0.0.0 192.168.34.1
ip route 0.0.0.0 0.0.0.0 192.168.45.1
ip route 150.1.5.5 255.255.255.255 192.168.45.1
ip route 150.1.3.3 255.255.255.255 192.168.34.1
++++++++++++++++++++++++++++++++++++++++++++++++++++

Regards,
Mirza.

--------------------------------------------------------------------------------------------------------------------------
On Tue, Apr 21, 2009 at 6:01 PM, Akber Ali Mirza
<akberali.cisco_at_gmail.com>wrote:

> Hi GS,
>
> Please help me to configure MPLS VPN in GNS3( 7200 router) lab with the
> following Diagram/Configuration/output commands.
>
>
> Currently my E-BGP ( R1&R3 ; R2,R8 &R5 ; R7&R6) & MP-BGP between R3,R5
> &R6 are working fine.
>
> R1.& R8 belongs to Cust B and R2 & R7 belongs to Cust A.
> R3/R5/R6 are PE routers
> R4-P router.
> R1/R2/R7/R8 are CE routers.
>
> I have configured MPLS VPN using above scenario & configs , *but unbale
> to achieve the below* -
>
> 1) ping from R1 to R8 IP (as they are within CustB)
> 2) ping R3 to R5 IP's & R3 to R4's IP 192.168.45.2 ( plz chk if any
> routing issue between R3-R4-R5 )
> 3) ping from R3 to R8 Interface IP.
>
>
> I am finding difficulties to do the last level trouble shooting to get the
> above queries working fine!
>
> I sincerely appreciate and thankful for all your suggestions & replies.
>
> Please let me know if any further information needed for you to trouble
> shoot my issue.
>
> Regards,
> Mirza.

Blogs and organic groups at http://www.ccie.net
Received on Tue Apr 21 2009 - 21:40:23 ART

This archive was generated by hypermail 2.2.0 : Mon May 04 2009 - 07:39:12 ART