From: Victor Cappuccio (vcappuccio@gmail.com)
Date: Sat Jul 12 2008 - 04:21:08 ART
from your question, I've decided to bring our friends the routers,
with the following topology: R1 s0/0 -- Fr -- s1/0 Rc
Just to let you know, how to watch this bits been shipped over the
frame-relay links between these 2 routers and the different
alternative (with the command suggested by Henk and with other tool
named MQC to count those packets), that in 20 min of witting this
email I can come up (for sure there are 1000 of other alternative more
:)) that why we all love Cisco...
The basic Configuration I have in R1 is:
R1#show run int s0/0
Building configuration...
Current configuration : 162 bytes
!
interface Serial0/0
ip address 192.1.1.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.1.1.2 111 broadcast
end
and the configuration in the other router is like:
RC(config-if)#do show run int s1/0
Building configuration...
Current configuration : 263 bytes
!
interface Serial1/0
ip address 192.1.1.2 255.255.255.0
clock rate 128000
no dce-terminal-timing-enable
frame-relay map ip 192.1.1.1 111 broadcast
no frame-relay inverse-arp
frame-relay intf-type dce
end
Using part of your initial mail configuration, I just created the
following in R1:
R1(config)#do show run | in de-|Serial0/0
frame-relay de-list 1 protocol ip list 101
interface Serial0/0
frame-relay de-group 1 111
R1(config)#do show ip access-list
Extended IP access list 101
10 permit ip any any precedence immediate
This is the output from the Rc Router, watch here that NO DE bit in
being marked incoming to that PVC
RC#show frame-relay pvc 111 | in DE
out BECN pkts 0 in DE pkts 0 out DE pkts 0
Now, lets do an extended Ping with Precedence Immediate marked to 0x40
(immediate - match also by the ACL in RC) ICMP Echo-Request Packets,
and lets send those packets over the frame-relay network:
R1#ping
Protocol [ip]:
Target IP address: 192.1.1.2
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface:
Type of service [0]: 0x40
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Now here, we can see the output in RC, now with those packets being
received as marked with DE
RC(config-if)#do show frame-relay pvc 111
PVC Statistics for interface Serial1/0 (Frame Relay DCE)
DLCI = 111, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0
input pkts 130 output pkts 130 in bytes 13520
out bytes 13520 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 5 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:09:03, last time pvc status changed 00:08:12
RC(config-if)#do show frame-relay pvc 111 | in DE
out BECN pkts 0 in DE pkts 5 out DE pkts 0
Aother Method to count the packets marked with the DE bit could be MQC
RC(config)#policy-map TEST
RC(config-pmap)#class COUNTER
RC(config-pmap-c)#set ip prec 1 ! just for nothing
RC(config-pmap-c)#exit
RC(config-pmap)#int s1/0
RC(config-if)#service-policy in TEST
RC(config-if)#do show policy-map int s1/0
Serial1/0
Service-policy input: TEST
Class-map: COUNTER (match-all)
5 packets, 520 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: fr-de
QoS Set
precedence 1
Packets marked 5
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
RC(config-if)#do show frame-relay pvc | in DE
out BECN pkts 0 in DE pkts 10 out DE pkts 0
--- 5 more packets here in the counter of the show frame-relay pvc
111, and 5 in the show policy-map inter, since I applied that command
without clearing the frame-relay counters.
An alternative configuration could be on R1, using now the Modular QOS CLI
R1(config-pmap)#class-map IMM
R1(config-cmap)#ma access-group 101
R1(config-cmap)#policy-map TEST
R1(config-pmap)#class IMM
R1(config-pmap-c)#set fr-de
R1(config-pmap-c)#do show run class-map
Building configuration...
Current configuration : 58 bytes
!
class-map match-all IMM
match access-group 101
!
end
R1(config-pmap-c)#do show run policy-map
Building configuration...
Current configuration : 70 bytes
!
policy-map TEST
class IMM
set fr-de
class class-default
!
end
R1(config-pmap)#int s0/0
R1(config-if)#no frame-relay de-group 1 111
R1(config-if)#serv out TEST
-------- Verification:
RC(config-if)#do show policy-map int s1/0
Serial1/0
Service-policy input: TEST
Class-map: COUNTER (match-all)
15 packets, 1560 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: fr-de
QoS Set
precedence 1
Packets marked 15
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
RC(config-if)#do show frame-relay pvc | in DE
out BECN pkts 0 in DE pkts 20 out DE pkts 0
5 more packets there.!!!!!
About the frame-relay traffic shaping, and the marking of the DE Bit,
is responsibility of the Frame-relay switch to mark this BIT when the
BE excess burst size corresponds to the number of noncommitted bits
--- that are still accepted by the Frame Relay switch but marked as
DE. AFAIR the options do you have for setting DE is using that
DE-LIST, MQC, CAR, to mark from the router the DE, more information
about Frame-relay traffic shapping
http://www.cisco.com/warp/public/125/21.shtml &&
http://www.internetworkexpert.com/resources/01700368.htm or at the
main link for plenty of other topics.
HTH to someone
Victor.-
On Fri, Jul 11, 2008 at 3:28 PM, Henk de Tombe <henk.de.Tombe@qi.nl> wrote:
> Hi Amin,
>
> I just saw your question while labbing up some Frame relay clouds.
> The output of the command show frame pvc 405 will show you the answer.
> This command will show you how much packets are marked with the DE bit.
>
>
> Have fun,
>
> Regards,
> Henk
>
>
>
> Met vriendelijke groet, With kind regards,
>
> Henk de Tombe
> senior network engineer
>
> Qi ict
> Delftechpark 35-37
> Postbus 402, 2600 AK Delft
>
> T : +31 15 888 0 444
> F : +31 15 888 0 445
> E : mailto:henk.de.Tombe@qi.nl
> I : http://www.qi.nl/
> -----Oorspronkelijk bericht-----
> Van: nobody@groupstudy.com [mailto:nobody@groupstudy.com] Namens ccie
> Verzonden: Monday, July 07, 2008 10:14 AM
> Aan: ccielab@groupstudy.com
> Onderwerp: DE traffic marking in case there is no traffic shaping nor
> adaptive shaping
>
> DE traffic marking in case there is no traffic shaping nor adaptive
> shaping
>
>
>
> Hi Experts,
>
> Assume I have configure this type of traffic for eligibility to be DE
> marked.
>
>
>
> access-list 101 permit ip any any precedence flash
>
> frame-relay de-list 1 protocol ip list 101
>
> int ser0/0/0
>
> frame-relay de-group 1 405
>
>
>
> In case I didn't configure any type of traffic shaping on PVC 405, will
> the router mark anything with DE?
>
>
>
>
>
> Regards,
>
> Amin
>
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
-- Victor Cappuccio CCIE R/S# 20657 CCSI# 30452 www.vcappuccio.wordpress.com
This archive was generated by hypermail 2.1.4 : Mon Aug 04 2008 - 06:11:54 ART