From: YourPal (dearprudence28@gmail.com)
Date: Wed Feb 27 2008 - 16:22:43 ARST
Hi Douglas,
Have a look at this link:
http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094374.shtml#protocols
It says:
RIP advertises a route to 0.0.0.0 if a gateway of last resort is selected
using the "ip default-network" command. This network specified in the "ip
default-network" command need not be explicitly advertised under RIP.
In my case, R3 has already flagged the static route 198.10.1.0/24 as
candidate default route (as verified with "sh ip ro"). It has selected its
gateway of last resort. So it should advertise a 0.0.0.0 into RIP domain
(out interface s0/2) but it doesn't (as verified with "deb ip rip" on R3 and
"sh ip ro" on R1).
I tried EIGRP. It seems to work. Please see the following configs and
results.
R1:
!
router eigrp 123
network 131.108.99.1 0.0.0.0
no auto-summary
!
ip classless
!
R3:
!
router eigrp 123
redistribute static
network 131.108.99.3 0.0.0.0
no auto-summary
!
ip default-network 198.10.1.0
ip route 198.10.1.0 255.255.255.0 161.44.192.2
!
ip classless
!
R3#sh ip ro
Gateway of last resort is 161.44.192.2 to network 198.10.1.0
161.44.0.0/24 is subnetted, 1 subnets
C 161.44.192.0 is directly connected, Serial0/3
131.108.0.0/24 is subnetted, 1 subnets
C 131.108.99.0 is directly connected, Serial0/2
S* 198.10.1.0/24 [1/0] via 161.44.192.2
R1#sh ip ro
Gateway of last resort is 131.108.99.3 to network 198.10.1.0
131.108.0.0/24 is subnetted, 1 subnets
C 131.108.99.0 is directly connected, Serial0/0/1
D*EX 198.10.1.0/24 [170/21024000] via 131.108.99.3, 03:29:07, Serial0/0/1
Thank you.
BR,
Emil
On 2/27/08, Todd, Douglas M. <DTODD@partners.org> wrote:
>
> Hi:
> my 2c..
>
>
> This is expected from what I believe. The use of the default-network
> allows the
> router to send all unknown destinations toward this network. This causes a
> recursive lookup on the router, this is the way it works. But the
> default-network command works in conjuction with other routing protocols -
>
>
> CCO:
> Cisco IOS software will source the default network with RIP if one of the
> following conditions is met:
> *The ip default-network command is configured.
> *The default-information originate command is configured.
> *The default route is learned via another routing protocol or static route
> and
> then redistributed into RIP
>
>
> This I see as the default network, not the default route..
>
>
> For rip the default route needs to come from a nother protocol, other wise
> you
> need to have a static route
> ip route 0.0.0.0 0.0.0.0 1.1.1.1 and then redistribute that route w/in
> rip.
>
> If you have eigrp/ospf/bgp sending a default route then you can
> redistribute
> that into rip (and use the default information originate command).
>
> Otherwise, you will just see the default network if the above conditions
> exist.
>
> CCO:
> If dynamic default information is not being passed to the software,
> candidates
> for the default route are specified with the ip default-network global
> configuration command. In this usage, the ip default-network command takes
> an
> unconnected network as an argument. If this network appears in the routing
> table
> from any source (dynamic or static), it is flagged as a candidate default
> route
> and is a possible choice as the default route.
> If the router has no interface on the default network, but does have a
> route to
> it, it considers this network as a candidate default path. The route
> candidates
> are examined and the best one is chosen, based on administrative distance
> and
> metric. The gateway to the best default path becomes the gateway of last
> resort.
>
> So,
>
> Create an ospf domain and get a default route advertised into it, then
> redistribute it into rip. You will then have a default route.
>
> DMT
> ________________________________
>
> From: nobody@groupstudy.com on behalf of YourPal
> Sent: Tue 2/26/2008 10:14 PM
> To: ccielab@groupstudy.com
> Subject: Issue advertising default route into RIP using "ip
> default-network"
>
>
>
> Hi Group,
>
> I'm facing a problem advertising a default route into RIP using the "ip
> default-network" command. My setup as follows:
>
> R1(s0/0/1)--------
>
> 131.108.99.0/24--------(s0/2)R3(s0/3)--------161.44.192.0/24--------(s0/0/1)R2
>
>
> R1:
> !
> interface Serial0/0/1
> ip address 131.108.99.1 255.255.255.0
> clockrate 125000
> !
> router rip
> version 2
> network 131.108.0.0
> no auto-summary
> !
> ip classless
> !
>
> R2:
> !
> interface Loopback0
> ip address 198.10.1.1 255.255.255.0
> !
> interface Serial0/0/1
> ip address 161.44.192.2 255.255.255.0
> clockrate 125000
> !
> ip classless
> !
> R3:
> !
> interface Serial0/2
> ip address 131.108.99.3 255.255.255.0
> !
> interface Serial0/3
> ip address 161.44.192.3 255.255.255.0
> !
> router rip
> version 2
> network 131.108.0.0
> no auto-summary
> !
> ip default-network 198.10.1.0
> ip route 198.10.1.0 255.255.255.0 161.44.192.2
> !
> ip classless
> !
>
>
> R3#sh ip ro
> Gateway of last resort is 161.44.192.2 to network 198.10.1.0
>
> 161.44.0.0/24 is subnetted, 1 subnets
> C 161.44.192.0 is directly connected, Serial0/3
> 131.108.0.0/24 is subnetted, 1 subnets
> C 131.108.99.0 is directly connected, Serial0/2
> S* 198.10.1.0/24 [1/0] via 161.44.192.2
>
> R3#deb ip rip
> RIP protocol debugging is on
> *Mar 1 07:10:47.535: RIP: sending v2 update to 224.0.0.9 via Serial0/2 (
> 131.108.99.3)
> *Mar 1 07:10:47.535: RIP: build update entries - suppressing null update
>
> R1#sh ip ro
> Gateway of last resort is not set
>
> 131.108.0.0/24 is subnetted, 1 subnets
> C 131.108.99.0 is directly connected, Serial0/0/1
>
>
>
> I'm expecting R3 to advertise a default route into RIP as a result of the
> "ip default-network" command. However it doesn't. Can anyone tell me what
> am
> I missing in my configuration?
>
>
>
> Thank you.
>
> BR,
> Emil
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
> The information transmitted in this electronic communication is intended
> only
> for the person or entity to whom it is addressed and may contain
> confidential
> and/or privileged material. Any review, retransmission, dissemination or
> other
> use of or taking of any action in reliance upon this information by
> persons or
> entities other than the intended recipient is prohibited. If you received
> this
> information in error, please contact the Compliance HelpLine at
> 800-856-1983 and
> properly dispose of this information.
This archive was generated by hypermail 2.1.4 : Sat Mar 01 2008 - 16:54:50 ARST