RE: Multicast helper-map - What is wrong with it?

From: Joseph Brunner (joe@affirmedsystems.com)
Date: Sun Nov 18 2007 - 23:17:12 ART


Why is this on r2's serial?

 

ip pim dr-priority 0

 

take it off for now, and please make every interface ip pim sparse-dense
mode

 

then, also, make sure we are neighbored up in pim

 

show ip pim neighbor

 

do the debugs on R3 again

 

at the very least you should be able to ping 224.2.2.2 from R2 regardless of
the helper-map

 

  _____

From: Hugo Viana [mailto:zorby@doglover.com]
Sent: Sunday, November 18, 2007 9:13 PM
To: Joseph Brunner; ccielab@groupstudy.com
Subject: RE: Multicast helper-map - What is wrong with it?

 

R2
!
interface FastEthernet0/0
 ip address 150.2.4.1 255.255.255.0
 ip directed-broadcast
 ip multicast helper-map broadcast 224.2.2.2 111 ttl 16
!

R2#debug ip packet detail 111
IP packet debugging is on (detailed) for access list 111
R2#
*Nov 19 02:47:01.611: IP: s=150.2.4.254 (FastEthernet0/0),
d=255.255.255.255, len 44, rcvd 2
*Nov 19 02:47:01.611: UDP src=51207, dst=3434
*Nov 19 02:47:02.611: IP: s=150.2.4.254 (FastEthernet0/0),
d=255.255.255.255, len 44, rcvd 2
*Nov 19 02:47:02.611: UDP src=57194, dst=3434

On R3:

R3#
R3#debug ip mpacket detail
IP multicast packets debugging is on (detailed)
R3#ter mon
% Console already monitors
R3#

Nothing happens...

Thanks!

----- Original Message -----
From: "Joseph Brunner"
To: "'Hugo Viana'" , ccielab@groupstudy.com
Subject: RE: Multicast helper-map - What is wrong with it?
Date: Sun, 18 Nov 2007 21:04:27 -0500

Go ahead and give me a ttl remap on R2's multicast helper-map command
(facing the broadcast)

 

So ttl 16

 

At the end of the map

 

Then lets do a #debug ip mpacket detail on R3

 

-Joe

 

  _____

From: Hugo Viana [mailto:zorby@doglover.com]
Sent: Sunday, November 18, 2007 8:59 PM
To: Joseph Brunner; ccielab@groupstudy.com
Subject: RE: Multicast helper-map - What is wrong with it?

 

R2#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 01:05:15/stopped, RP 4.4.24.2, flags: SJPCL
  Incoming interface: Serial0/1/0.1, RPF nbr 4.4.24.2
  Outgoing interface list: Null

R3#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.6.6.6), 07:08:26/00:03:25, RP 4.4.24.2, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/0, Forward/Sparse-Dense, 07:08:09/00:03:25

(*, 224.2.2.2), 00:05:40/00:02:53, RP 4.4.24.2, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/1/0.1, Forward/Sparse, 00:04:53/00:00:00
    FastEthernet0/0, Forward/Sparse-Dense, 00:05:41/00:02:45

(*, 224.0.1.40), 07:08:37/00:02:51, RP 4.4.24.2, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/1/0.1, Forward/Sparse, 01:05:11/00:02:53
    FastEthernet0/0, Forward/Sparse-Dense, 07:08:37/00:02:43

R3#sh run int fa0/0
Building configuration...

Current configuration : 240 bytes
!
interface FastEthernet0/0
 ip address 4.4.26.2 255.255.255.0
 ip broadcast-address 4.4.26.255
 ip directed-broadcast
 ip pim sparse-dense-mode
 ip igmp join-group 224.2.2.2
!

----- Original Message -----
From: "Joseph Brunner"
To: zorby@doglover.com, ccielab@groupstudy.com
Subject: RE: Multicast helper-map - What is wrong with it?
Date: Sun, 18 Nov 2007 20:39:16 -0500

We'll help you doglover, don't worry...

Go ahead and give me a ip igmp join-group 224.2.2.2 on R3's F0/0 and a
Ip pim sparse-dense.

Now post back a "show ip mroute" on R2 and R3. I want to see what's in the
Multicast O.I.L.

Thanks,

Joe

(BTW: if you want to a webex to observe this work in my lab, we can, I
played this command for hours and hours and found several ways to get its
functionality without the helper-map)

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
zorby@doglover.com
Sent: Sunday, November 18, 2007 7:44 PM
To: ccielab@groupstudy.com
Subject: Multicast helper-map - What is wrong with it?

Hello!
I am trying to simulate the forward of broadcast traffic into multicast
packets using the command "ip multicast helper-map", as the LAB8 of IE.
The network is the following:

R1 (e0/0) --- (f0/0) R2 (s0/1/0.1) <--FR--> (s0/1/0.1) R3 (fa0/0) ---
(fa0/0) R4

CONFIGS:
----------------------------------------------------------------------------
-------
***R1 - Sender Broadcast traffic via SAA:

!
rtr 1
rtr schedule 1 life forever start-time now
!
type udpEcho dest-ipaddr 255.255.255.255 dest-port 3434 control disable
timeout 1
frequency 1
!

***R2 - Receive broadcast and send into multicast packets to 224.2.2.2
group:

!
interface FastEthernet0/0
ip address 150.2.4.1 255.255.255.0
ip multicast helper-map broadcast 224.2.2.2 111
!
interface Serial0/1/0.1 point-to-point
ip address 4.4.24.4 255.255.255.0
ip pim dr-priority 0
ip pim sparse-mode
!
access-list 111 permit udp any any eq 3434
!
ip forward-protocol udp 3434
!

***R3 - Receive multicast traffic and send to broadcast address (fa0/0)

!
interface Serial0/1/0.1 point-to-point
ip address 4.4.24.2 255.255.255.0
ip pim sparse-mode
ip multicast helper-map 224.2.2.2 4.4.26.255 111
!
access-list 111 permit udp any any eq 3434
!
ip forward-protocol udp 3434
!
interface FastEthernet0/0
ip address 4.4.26.2 255.255.255.0
ip directed-broadcast
ip pim sparse-mode
!

----------------------------------------------------------------------------
------

Verification on routers:

R1:

R1#sh rtr totals-statistics
Entry number: 1
Start Time Index: *04:25:25.046 UTC Mon Mar 1 1993
Age of statistics entry (seconds): 3034
Number of initiations: 3035

R2:

I can see the broadcast traffic on ethernet interface:

R2#debug ip packet detail 111
IP packet debugging is on (detailed) for access list 111
R2#
*Nov 18 19:53:21.187: IP: s=150.2.4.254 (FastEthernet0/0),
d=255.255.255.255, len 44, rcvd 2
*Nov 18 19:53:21.187: UDP src=56958, dst=3434
*Nov 18 19:53:22.187: IP: s=150.2.4.254 (FastEthernet0/0),
d=255.255.255.255, len 44, rcvd 2
*Nov 18 19:53:22.187: UDP src=49314, dst=3434
*Nov 18 19:53:23.187: IP: s=150.2.4.254 (FastEthernet0/0),
d=255.255.255.255, len 44, rcvd 2
*Nov 18 19:53:23.187: UDP src=50778, dst=3434
*Nov 18 19:53:24.187: IP: s=150.2.4.254 (FastEthernet0/0),
d=255.255.255.255, len 44, rcvd 2
*Nov 18 19:53:24.187: UDP src=57531, dst=3434

But When I try to see the multicast packets:

R2#debug ip mp
R2#debug ip mpacket
IP multicast packets debugging is on
R2#
R2#
R2#

Nothing happens at all...

R3:

R3#debug ip packet detail 111
IP packet debugging is on (detailed) for access list 111
R3#

Nothing happens too...

----------------------------------------------------------------------------
-----

Anybody has any idea about what is wrong? Brian, could you help me?
I read everything that I found about this, but i really don't know what is
wrong...:

- Developing IP Multicast Networks - Chapter 16 - "Broadcast-Multicast
Traffic Conversion"
- IEWB - LAB 8 - Version 4
- "ip multicast helper-map" command:
http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cr/himc_r
/mlt_i1h.htm#wp1134745

Thanks for any help,
Zorby



This archive was generated by hypermail 2.1.4 : Sat Dec 01 2007 - 06:37:30 ART