Re: STRANGE OSPF ISSUE WITH VL

From: NITIN NITIN (ccie_study_123@yahoo.com)
Date: Sat Aug 11 2007 - 15:14:58 ART


Hi ,
   
  Beloow is the config for R3
   
  Sorry for pasting wrong config
   
  
boot-start-marker
boot-end-marker
!
enable password cisco
!
aaa new-model
!
!
aaa authentication login default none
aaa authentication login TELNET local
aaa authentication login h local
aaa session-id common
ip subnet-zero
!
!
ip tcp intercept list 103
ip tcp intercept watch-timeout 60
no ip domain lookup
ip dhcp excluded-address 152.1.125.100
ip dhcp excluded-address 152.1.125.1
ip dhcp excluded-address 152.1.125.2
ip dhcp excluded-address 152.1.125.5
!
ip dhcp pool k
   network 152.1.125.0 255.255.255.0
   default-router 152.1.125.100
   dns-server 152.1.37.100
!
ip multicast-routing
ip multicast cache-headers
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
username NOC password 0 CISCO
!
!
!
!
interface Loopback0
 ip address 150.1.3.3 255.255.255.0
 ipv6 address 2001:150:1:3::3/64
 ipv6 rip RIPng enable
!
interface Tunnel3
 ip unnumbered FastEthernet1/0
 ip pim dense-mode
 tunnel source Loopback0
 tunnel destination 150.1.5.5
!
interface FastEthernet0/0
 ip address 152.1.37.3 255.255.255.0
 duplex full
 ipv6 address 2001:192:10:1::/64 eui-64
 ipv6 rip RIPng enable
!
interface FastEthernet1/0
 ip address 152.1.3.3 255.255.255.0
 ip pim dense-mode
 ip ospf network non-broadcast
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 152.1.123.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf hello-interval 30
 ipv6 address 2001:152:1:123::3/64
 ipv6 address FE80::3 link-local
 ipv6 verify unicast reverse-path
 ipv6 rip RIPng enable
 serial restart-delay 0
 no fair-queue
 frame-relay traffic-shaping
 frame-relay map ipv6 FE80::2 302
 frame-relay map ipv6 2001:152:1:123::1 301 broadcast
 frame-relay map ipv6 2001:152:1:123::2 302 broadcast
 frame-relay map ipv6 FE80::1 301
 frame-relay interface-dlci 301
  class R1
 frame-relay interface-dlci 302
  class R2
!
interface Serial2/0.1 multipoint
 frame-relay interface-dlci 304
 frame-relay interface-dlci 305
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 150.1.3.3
 log-adjacency-changes
 area 123 virtual-link 150.1.1.1 authentication message-digest
 area 123 virtual-link 150.1.1.1 message-digest-key 1 md5 CISCO
 area 123 virtual-link 150.1.2.2 authentication message-digest
 area 123 virtual-link 150.1.2.2 message-digest-key 1 md5 CISCO
 passive-interface Tunnel3
 network 150.1.3.3 0.0.0.0 area 37
 network 152.1.3.3 0.0.0.0 area 3
 network 152.1.37.3 0.0.0.0 area 37
 network 152.1.123.3 0.0.0.0 area 123
 distance 255 150.1.5.5 0.0.0.0 89

!
router bgp 3000
 no synchronization
 bgp router-id 150.1.3.3
 bgp log-neighbor-changes
 bgp confederation identifier 200
 bgp confederation peers 1000 2000 7000
 neighbor 152.1.37.7 remote-as 7000
 neighbor 152.1.123.1 remote-as 1000
 neighbor 152.1.123.2 remote-as 2000
 no auto-summary
!
ip classless
no ip http server
!
ip mroute 0.0.0.0 0.0.0.0 Tunnel3
!
!
map-class frame-relay R1
 frame-relay cir 896000
 frame-relay bc 28672
!
map-class frame-relay R2
 frame-relay cir 640000
 frame-relay bc 20480
access-list 89 permit 150.1.5.0 0.0.0.255
access-list 89 permit 150.1.4.0 0.0.0.255
access-list 89 permit 152.1.4.0 0.0.0.255
access-list 89 permit 152.1.5.0 0.0.0.255
access-list 89 permit 152.1.54.0 0.0.0.255
access-list 89 permit 152.1.45.0 0.0.0.255
access-list 103 permit tcp any 152.1.3.0 0.0.0.255 eq www
ipv6 router rip RIPng
  no split-horizon
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 stopbits 1
line vty 0 4
 password cisco
 login authentication h
!
scheduler allocate 3998 200
!
end
  Rack1R3#

Ryan <ryan95842@gmail.com> wrote:
  What the R3 config look like? Looks like you put the R1 config in twice

-Ryan

  On 8/11/07, NITIN NITIN < ccie_study_123@yahoo.com> wrote: Hi EXPERTS,

  Sorry to bother again, but hope u understand exam is near

  Issue I'm facing now is ----
  R1 and R2 are spokes and R3 is hub

  R3 virtual link is not coming up after router rebbot with R1 , it was up eralier

  WITH R2 ---- VL of R3 is up

  R3-------------

  interface Serial2/0
ip address 152.1.123.1 255.255.255.0
encapsulation frame-relay
ip ospf priority 0
ipv6 address 2001:152:1:123::1/64
ipv6 address FE80::1 link-local
ipv6 rip RIPng enable
serial restart-delay 0
no fair-queue
frame-relay traffic-shaping
frame-relay map ipv6 FE80::2 103
frame-relay map ipv6 FE80::3 103
frame-relay map ipv6 2001:152:1:123::2 103
frame-relay map ipv6 2001:152:1:123::3 103 broadcast
frame-relay interface-dlci 103
  class R1

  router ospf 1
router-id 150.1.1.1
max-metric router-lsa
log-adjacency-changes
area 123 virtual-link 150.1.3.3 authentication message-digest
area 123 virtual-link 150.1.3.3 message-digest-key 1 md5 CISCO
network 150.1.1.1 0.0.0.0 area 123
network 152.1.123.1 0.0.0.0 area 123
network 152.1.125.1 0.0.0.0 area 0
distribute-list 1 in Serial2/0

  R2-----

  router ospf 1
router-id 150.1.2.2
log-adjacency-changes
area 123 virtual-link 150.1.3.3 authentication message-digest
area 123 virtual-link 150.1.3.3 message-digest-key 1 md5 CISCO
network 150.1.2.2 0.0.0.0 area 123
network 152.1.123.2 0.0.0.0 area 123
network 152.1.125.2 0.0.0.0 area 0
default-information originate always
distribute-list 1 in Serial2/0
!

  R1----

  router ospf 1
router-id 150.1.1.1
max-metric router-lsa
log-adjacency-changes
area 123 virtual-link 150.1.3.3 authentication message-digest
area 123 virtual-link 150.1.3.3 message-digest-key 1 md5 CISCO
network 150.1.1.1 0.0.0.0 area 123
network 152.1.123.1 0.0.0.0 area 123
network 152.1.125.1 0.0.0.0 area 0
distribute-list 1 in Serial2/0

  ISSUE

  Rack1R3# sh ip ospf virtual-links
Virtual Link OSPF_VL7 to router 150.1.2.2 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 123, via interface Serial2/0, Cost of using 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
    Adjacency State FULL (Hello suppressed)
    Index 1/4, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec
Virtual Link OSPF_VL6 to router 150.1.1.1 is down
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 123, Cost of using 65535
  Transmit Delay is 1 sec, State DOWN,
  Timer intervals configured, Hello 10, Dead 40, Wa

  Rack1R1#sh ip ospf virtual-links
Virtual Link OSPF_VL2 to router 150.1.3.3 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 123, via interface Serial2/0, Cost of using 65535
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:04

---------------------------------
Looking for a deal? Find great prices on flights and hotels with Yahoo! FareChase.



This archive was generated by hypermail 2.1.4 : Sat Sep 01 2007 - 11:32:10 ART