From: Sadiq Yakasai (sadiqtanko@gmail.com)
Date: Fri Jun 22 2007 - 20:45:43 ART
Hi Mohammed,
Just out of curiousity here, whats the purpose of the tagging please?
-------------------------------------------------
route-map test1 permit 10
match ip address 1
set tag 255
!
route-map test1 permit 20
match tag 255
-------------------------------------------------
I would think this would work as well, without setting a tag:
-------------------------------------------------
route-map test1 permit 10
match ip address 1
------------------------------------------------
Thanks
Sadiq
On 6/23/07, Mohmmad, Imran <Imran.Mohmmad@amd.com> wrote:
> Hi,
>
> Hi,
>
> I try the same as per the below topology
>
> R1---(RIP)-------R2--------R3
>
> and I am able to achieve the same when the both non RIP enabled
> interface on R2(Serial1/2 and loopback 900) are down it will not
> generate any default route into RIP Domain.
>
>
>
>
> R3#
> interface Serial1/2
> ip address 200.200.200.3 255.255.255.0
> serial restart-delay 0
> no dce-terminal-timing-enable
>
>
> R2#
>
> interface Loopback900
> ip address 90.90.90.90 255.255.255.0
>
> !
> interface FastEthernet0/0
> no ip address
> duplex half
> !
> interface Serial1/0
> ip address 100.100.100.2 255.255.255.0
> serial restart-delay 0
> no dce-terminal-timing-enable
>
> interface Serial1/2
> ip address 200.200.200.2 255.255.255.0
> shutdown
> serial restart-delay 0
> no dce-terminal-timing-enable
>
> router rip
> version 2
> network 100.0.0.0
> default-information originate route-map test1
> no auto-summary
>
> access-list 1 permit 200.200.200.0 0.0.0.255
> access-list 1 permit 90.90.90.0 0.0.0.255
> !
> route-map test1 permit 10
> match ip address 1
> set tag 255
> !
> route-map test1 permit 20
> match tag 255
>
>
> R2#sh ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
> level-2
> ia - IS-IS inter area, * - candidate default, U - per-user static
> route
> o - ODR, P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> C 200.200.200.0/24 is directly connected, Serial1/2
> 1.0.0.0/32 is subnetted, 1 subnets
> C 1.1.1.1 is directly connected, Loopback1
> 100.0.0.0/24 is subnetted, 1 subnets
> C 100.100.100.0 is directly connected, Serial1/0
> 90.0.0.0/24 is subnetted, 1 subnets
> C 90.90.90.0 is directly connected, Loopback900
>
>
>
>
>
> R1#
>
> interface Serial1/0
> description ****Connected to R2******
> ip address 100.100.100.1 255.255.255.0
> serial restart-delay 0
> no dce-terminal-timing-enable
>
>
> router rip
> version 2
> network 100.0.0.0
> no auto-summary
>
>
> R1#sh ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
> level-2
> ia - IS-IS inter area, * - candidate default, U - per-user static
> route
> o - ODR, P - periodic downloaded static route
>
> Gateway of last resort is 100.100.100.2 to network 0.0.0.0
>
> R 200.200.200.0/24 [120/1] via 100.100.100.2, 00:00:20, Serial1/0
> 100.0.0.0/24 is subnetted, 1 subnets
> C 100.100.100.0 is directly connected, Serial1/0
> R* 0.0.0.0/0 [120/1] via 100.100.100.2, 00:00:20, Serial1/0
>
>
> when both the interfaces are down on R2 below is the output of routing
> table:-
>
>
> Router R2 routing table is as follows:-
>
> R2#sh ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
> level-2
> ia - IS-IS inter area, * - candidate default, U - per-user static
> route
> o - ODR, P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 1.0.0.0/32 is subnetted, 1 subnets
> C 1.1.1.1 is directly connected, Loopback1
> 100.0.0.0/24 is subnetted, 1 subnets
> C 100.100.100.0 is directly connected, Serial1/0
>
>
> and Router R1 is not having any default route generated by RIP
>
>
> R1#sh ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
> level-2
> ia - IS-IS inter area, * - candidate default, U - per-user static
> route
> o - ODR, P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 100.0.0.0/24 is subnetted, 1 subnets
> C 100.100.100.0 is directly connected, Serial1/0
>
>
> Regards,
> Imran
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> michel
> Sent: Friday, June 22, 2007 2:14 PM
> To: cisco efiko; Cisco certification
> Subject: Re: originate default rip route only when 2 interfaces are down
>
> thanks but i don't see how this would work only ''when an interface is
> going
> down''
> the route map let me match interface, metric and so on.
>
> I just want to originate a default route into rip when I lost my
> specific
> routes because the interfaces are down.
>
>
>
> On 6/22/07, cisco efiko <ciscoefiko@googlemail.com> wrote:
> >
> > Michel,
> >
> > Try conditional default-information originate with a route-map under
> RIP.
> > Let me know if that works.
> >
> > Regards,
> >
> > E
> >
> >
> > On 6/22/07, michel <ccie.rs.lab@gmail.com> wrote:
> >
> > > Hello,
> > >
> > > I want to originate a default route in my rip network when 2
> interfaces
> > > (non
> > > rip) are down and not advertised anymore. What would be a proper way
> to
> > > achieve that ?
> > >
> > > Thanks,
> > >
> > > Michel
> > >
> > >
> _______________________________________________________________________
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sun Jul 01 2007 - 17:24:51 ART