From: ismail el-shalh (ishelh_mdsa@yahoo.com)
Date: Sat Jun 23 2007 - 00:56:57 ART
BB2--.254----(192.10.1.0/24)----.4---E1-R4-----E0---(167.1.4.0/24)
|
S0
|
|
(167.1.34.0/24)
R4 should generate a default route and send it to BB2 only if E0 and S0 is down
Try the following configuration :
router rip
version 2
default-information originate route-map CONDITION
network 192.10.1.0
no auto-summary
access-list 10 permit 167.1.4.0 0.0.0.255
access-list 20 permit 167.1.34.0 0.0.0.255
access-list 30 permit 150.1.4.0 0.0.0.255
!
!
route-map CONDITION permit 10
match ip address 10
set interface Null0
!
route-map CONDITION permit 20
match ip address 20
set interface Null0
!
route-map CONDITION permit 30
match ip address 30
set interface Ethernet1
I did the above configuration according to the following :
1- Ethernet 0 has the subnet 167.1.4.0/24
2 -Serial 0 has the subnet 167.1.34.0/24
3- Loopback 0 has the subnet 150.1.4.0
in the first route-map I told the router to match the access-list of Ethernet 0, if it found it present then it should send the update to interface null 0
in the second route-map I told the router to match the access-list of Serial 0, if it found it present i.e. UP/UP then it should send the update to interface null 0
in the third route-map I told the router to match the loopback which is always up, then it will send the update through ethernet 1 where my other router is connected to, there the router will receive the default route
now do the following :
shutdown Ethernet 0 and serial 0
the first route-map will not match, hence it will go to the second route-map , again the route-map will not match because serial 0 is not present so it will go to the third route-map.
In the third route-map it will match the presence of the loopback so it will send the default route through Ethernet 1.
Ismail El-Shalh :)
Senior Network Engineer
Computer & Communication
MMR/MDSA
Mobile : +966-505-893-568
ishelh@mdsa.com
----- Original Message ----
From: michel <ccie.rs.lab@gmail.com>
To: Cisco certification <ccielab@groupstudy.com>
Sent: Friday, June 22, 2007 9:09:31 PM
Subject: originate default rip route only when 2 interfaces are down
Hello,
I want to originate a default route in my rip network when 2 interfaces (non
rip) are down and not advertised anymore. What would be a proper way to
achieve that ?
Thanks,
Michel
This archive was generated by hypermail 2.1.4 : Sun Jul 01 2007 - 17:24:51 ART