RIP lab with PAT

From: Tariq Sharif (sharif.tariq@gmail.com)
Date: Wed Oct 04 2006 - 10:47:08 ART


Hi there

I got a simple RIP lab with PAT setup as below:

s1 --- r1 ------RCore ------r2 ---- s2

Ping between the s2 and s2 doesn't work. I can see from the debugs that r2
gets the replies for the icmp sent by s2 to s1 but it seems to drop it. I
think the reason is one of the 2:
1- becuase r2 is NOT expecting icmp reply from the PATed IP of
10.140.1.2(the return packet is getting PATed)
2-the PAT port number is changed on the return packet and therefore r2
rejects it.

I think it is 1 but want to see if I can make sure of this. Any thoghts?

thanks

Tariq

hostname s1
!
interface FastEthernet0/1
!
interface VLAN1
 ip address 10.2.2.11 255.255.255.0
!
ip default-gateway 10.2.2.3

 login
!
end

hostname r1
!
ip subnet-zero
!
interface Ethernet0
 ip address 10.2.2.3 255.255.255.0
 ip nat inside
!
interface Serial0
 ip address 10.140.1.2 255.255.255.0
 ip nat outside
!
router rip
 network 10.0.0.0
!
ip nat inside source list 10 interface Serial0 overload
ip classless
!
access-list 10 permit 10.2.2.0 0.0.0.255
end

hostname RCore
!
ip subnet-zero

!
interface FastEthernet0/0
 ip address 10.1.1.3 255.255.255.0
!
interface Serial0/0
 ip address 10.140.1.1 255.255.255.0
 clockrate 64000
 no fair-queue
!
interface Serial0/1
 ip address 10.140.2.1 255.255.255.0
 clockrate 64000

router rip
 network 10.0.0.0
!
ip http server
ip classless
!
end

hostname r2
!
ip subnet-zero
!
interface Ethernet0
 ip address 10.3.3.3 255.255.255.0
 ip nat inside
!
interface Serial0
 ip address 10.140.2.2 255.255.255.0
 ip nat outside

router rip
 network 10.0.0.0
!
ip nat inside source list 10 interface Serial0 overload
ip classless
!
access-list 10 permit 10.3.3.0 0.0.0.255
!
end

!
hostname s2
!
ip subnet-zero
!
interface FastEthernet0/1
!
interface VLAN1
 ip address 10.3.3.11 255.255.255.0
!
ip default-gateway 10.3.3.3

!
end



This archive was generated by hypermail 2.1.4 : Wed Nov 01 2006 - 07:29:04 ART