RE: Multicast trouble shooting

From: Feras Abunamous \(fabunamo\) (fabunamo@cisco.com)
Date: Sun Jun 11 2006 - 19:01:21 ART


Here it is,

R1

interface FastEthernet0/1

connects to R5

 ip address 20.0.25.1 255.255.255.0

 ip pim sparse-mode

 ip igmp join-group 225.25.25.25

 ip igmp join-group 225.25.25.6

 duplex auto

 speed auto

interface Serial0/0

 ip address 10.0.0.1 255.255.255.0

 ip pim sparse-mode

 encapsulation frame-relay

 ip ospf priority 0

 frame-relay map ip 10.0.0.3 105

 frame-relay map ip 10.0.0.5 105 broadcast

 no frame-relay inverse-arp

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

 ip pim sparse-mode

R5

ip multicast-routing

interface Loopback0

 ip address 5.5.5.5 255.255.255.255

 ip pim sparse-mode

!

interface Tunnel0

 ! multicast tunnel to R3

 ip unnumbered Loopback0

 ip pim sparse-mode

 tunnel source Loopback0

 tunnel destination 3.3.3.3

interface Serial0/0

! description this interface goes over frame to R3

 ip address 10.0.0.5 255.255.255.0

 ip pim nbma-mode

 ip pim sparse-mode

 encapsulation frame-relay

 frame-relay map ip 10.0.0.1 501 broadcast

 frame-relay map ip 10.0.0.3 503 broadcast

 no frame-relay inverse-arp

!

interface FastEthernet0/1

 ! description this interface goes over Ethernet to R!

 ip address 20.0.25.5 255.255.255.0

 ip pim sparse-mode

 ip multicast boundary 1 filter-autorp

 ip multicast rate-limit in 0

 duplex auto

 speed auto

!

interface Serial0/1

 no ip address

 shutdown

!

router ospf 1

 log-adjacency-changes

 network 5.5.5.5 0.0.0.0 area 0

 network 10.0.0.0 0.0.0.255 area 0

 network 20.0.25.0 0.0.0.255 area 0

 neighbor 10.0.0.1

 neighbor 10.0.0.3

!

ip pim bsr-candidate Loopback0 0

ip pim rp-candidate Loopback0

ip mroute 3.3.3.3 255.255.255.255 Tunnel0

ip mroute 203.0.0.0 255.255.0.0 Tunnel0

end

R3

interface Serial0/0

 ip address 10.0.0.3 255.255.255.0

 encapsulation frame-relay

 ip ospf priority 0

 frame-relay map ip 10.0.0.1 305

 frame-relay map ip 10.0.0.5 305 broadcast

 no frame-relay inverse-arp

!

interface FastEthernet0/0

 ip address 203.0.0.3 255.255.255.0

 ip pim sparse-mode

 duplex auto

 speed auto

interface Tunnel0

 ip unnumbered Loopback0

 ip pim sparse-mode

 tunnel source Loopback0

 tunnel destination 5.5.5.5

ip mroute 203.0.0.0 255.255.255.0 203.0.0.4

!

R4

interface FastEthernet0/0

 ip address 203.0.0.4 255.255.255.0

 ip pim sparse-mode

 duplex auto

 speed auto

________________________________

From: Chris Lewis [mailto:chrlewiscsco@gmail.com]
Sent: Sunday, June 11, 2006 10:49 AM
To: Feras Abunamous (fabunamo)
Cc: ccielab@groupstudy.com
Subject: Re: Multicast trouble shooting

For more help, please post your configs.

Chris

On 6/10/06, Feras Abunamous (fabunamo) <fabunamo@cisco.com> wrote:

YES ALL the interfaces are configured with pim spare. And I only
configured R5 as rp via bsr. I can see the rp info on R1 and R5. R3 is
pinging the group over the tunnel and does not sh the RP info. I
configured an Mroute on R5 pointing to the tunnel to R3. R4 can't ping
either.

Feras Abunamous
Systems Engineer
Data-Center Central Area
Cisco Systems, Inc.
Office: 773-695-8008
Pager: 630-336-7243
cell: 630-336-7243
Cisco Systems, CEC Home

fabunamo@cisco.com
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Chris Lewis
Sent: Saturday, June 10, 2006 4:24 AM
To: Feras Abunamous (fabunamo)
Cc: ccielab@groupstudy.com
Subject: Re: Multicast trouble shooting

The obvious answer is an error in configuration :)

What have you configured, have you got the RP as well as BSR candidate
configured? Is PIM enabled on all the right interfaces and do they show
the
expected neighbor relationships?

Chris

On 6/10/06, Feras Abunamous (fabunamo) < fabunamo@cisco.com
<mailto:fabunamo@cisco.com> > wrote:
>
> All,
>
> I hade the following scenario
> R1------ETH------R5-----Tun----R3-----ETH----R4
>
>
>
> I used bsr on R5 and igmp group join on R1. I can ping the group from
> the R3 through the tunnel but when I do sh ip pim rp on R3 it does not
> sh anything? I tried to ping from R4 and the ping always fail. I was
> wondering how come R3 can ping the group and does not sh the RP? And
why
> the ping from R4 always fail? Any help will be appreciated.
>
>



This archive was generated by hypermail 2.1.4 : Sat Jul 01 2006 - 07:57:32 ART