From: Chris Lewis (chrlewiscsco@yahoo.com)
Date: Sun Nov 13 2005 - 12:17:40 GMT-3
Choon,
Either you have an IOS bug or there is something strange in the setup you have, as this is not expected behavior. I would suggest running debug ip packet and debug ip mpacket, both in detail mode on R2 to see why it does not reply.
R2 does not need multicast routing enabled, as it is replying to a unicast source address.
I have exactly the same setup (full configs at end, note the only change to adding the ip pim dense mode on R1 ethernet interface is to add entries to the mroute table, it does not affect the ability to ping in this case, as multicast pings sends packets out all interfaces by default) and get the following results
R1(config-if)#do ping 10.1.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R1(config-if)#do ping 229.10.10.10
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 229.10.10.10, timeout is 2 seconds:
Reply to request 0 from 10.1.1.2, 1 ms
R1
Building configuration...
Current configuration : 1280 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
logging queue-limit 100
!
memory-size iomem 15
ip subnet-zero
!
no ip domain lookup
!
ip multicast-routing
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
!
no voice hpi capture buffer
no voice hpi capture destination
!
mta receive maximum-recipients 0
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
no ip http server
no ip http secure-server
ip classless
!
call rsvp-sync
!
mgcp profile default
!
dial-peer cor custom
!
line con 0
privilege level 15
line aux 0
line vty 0 4
!
end
R2
Building configuration...
Current configuration : 939 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
logging queue-limit 100
!
memory-size iomem 15
ip subnet-zero
!
no ip domain lookup
!
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
!
no voice hpi capture buffer
no voice hpi capture destination
!
mta receive maximum-recipients 0
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
ip igmp join-group 229.10.10.10
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
no ip http server
no ip http secure-server
ip classless
With this setup the show ip mroute will be empty, if I add ip pim dense to F0/0 of R1 I get the following on R1
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 229.10.10.10), 00:00:03/00:02:56, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Dense, 00:00:03/00:00:00
(*, 224.0.1.40), 00:00:05/00:02:56, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Dense, 00:00:05/00:00:00
R1(config-if)#
There is now an OIL entry for the 229.10.10.10 group and the 224.0.1.40 group is added as enabling dense mode also enables IGMP, and all IGMP hosts by default will send a report for that group (no sparse mode needed to get that to happen)
Chris
"Loi, Choon Ho" <ChoonHo.Loi@getronics.com> wrote:
here's the config:
R1:
interface FastEthernet0/0
ip address 172.16.80.1 255.255.255.0
ip igmp join-group 229.10.10.10
duplex auto
speed auto
R2:
ip multicast-routing
interface FastEthernet0/0
ip address 172.16.80.2 255.255.255.0
ip pim dense-mode
duplex auto
speed auto
here's the ping:
R2#ping 229.10.10.10 rep 10
Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 229.10.10.10, timeout is 2 seconds:
..........
R2#ping 229.10.10.10 so f0/0 rep 10
Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 229.10.10.10, timeout is 2 seconds:
Packet sent with a source address of 172.16.80.2
..........
R2#ping 172.16.80.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.80.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
---------------------------------
From: Chris Lewis [mailto:chrlewiscsco@yahoo.com]
Sent: Saturday, November 12, 2005 11:00 PM
To: Loi, Choon Ho; ccielab@groupstudy.com
Subject: Re: Router as Multicast Host
I tihnk you'll have to post your configs. ip mulicast routing is not required for R1 to respond to pings to 229.10.10.10 from R2, in my setup I can enable just a join on the interface on R1 facing R2, then R2 is able to ping 229.10.10.10, the only config on R2 is to enable multicast routing and put pim dende on the interface going towards R1
Chris
"Loi, Choon Ho" <ChoonHo.Loi@getronics.com> wrote:
For this scenario:
R1(join 229.10.10.10)-----------(pim dense)R2(pim
dense)----------------(pim dense)R3
With the setup, R2 can't ping 229.10.10.10
What is the possible solution for this, if R1 can not enable ip
multicast-routing.
Following is the debug from R2:
Nov 12 05:01:24.330: IGMP(0): Received v2 Report on FastEthernet0/0 from
172.16.80.1 for 229.10.10.10
*Nov 12 05:01:24.330: IGMP(0): Received Group record for group
229.10.10.10, mode 2 from 172.16.80.1 for 0 sources
*Nov 12 05:01:24.330: IGMP(0): Updating EXCLUDE group timer for
229.10.10.10
*Nov 12 05:01:24.330: IGMP(0): MRT Add/Update FastEthernet0/0 for
(*,229.10.10.10) by 0
Sh ip mroute from R2:
(*, 229.10.10.10), 00:05:37/stopped, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Dense, 00:05:37/00:00:00
(172.16.80.2, 229.10.10.10), 00:04:58/00:01:03, flags: PT
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
Outgoing interface list: Null
(*, 224.0.1.40), 00:06:32/00:02:21, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Dense, 00:06:32/00:00:00
This archive was generated by hypermail 2.1.4 : Thu Dec 01 2005 - 09:12:06 GMT-3