From: Dennis J. Hartmann (dennisjhartmann@hotmail.com)
Date: Thu Apr 28 2005 - 00:45:55 GMT-3
Bob is correct. I must have not been waiting long enough fo the
neighbors to form an adjacency (seems to take a long time over the NBMA
links I'm dealing with). I took out the neighbor statements pointing to the
global address and the neighbors work perfectly. Thanks Bob!
The verification below includes a 6to4 tunnel on R2 to R7. I have
included that configuration at the bottom for anyone who wants to take a
look at it. The scenario came from Net Master Class which is an excellent
product.
R3#show run int s 1/0
Building configuration...
Current configuration : 416 bytes
!
interface Serial1/0
ip address 208.28.1.2 255.255.255.248
encapsulation frame-relay
ip split-horizon
ipv6 address FEC0::154:2/125
ipv6 ospf neighbor FE80::212:7FFF:FE8D:3A80 priority 1
ipv6 ospf 100 area 0
no fair-queue
frame-relay map ipv6 FEC0::154:1 302 broadcast
frame-relay map ipv6 FE80::212:7FFF:FE8D:3A80 302 broadcast
frame-relay map ip 208.28.1.1 301 broadcast
no frame-relay inverse-arp
end
R3#show ipv6 os n
Neighbor ID Pri State Dead Time Interface ID Interface
20.1.1.1 1 FULL/BDR 00:01:49 8 Serial1/0
R3#
R2#show run int s 1/0
Building configuration...
Current configuration : 400 bytes
!
interface Serial1/0
ip address 180.40.7.65 255.255.255.224
encapsulation frame-relay
ipv6 address FEC0::154:1/125
ipv6 ospf neighbor FE80::212:7FFF:FE8D:3CA0 priority 1
ipv6 ospf 100 area 0
no fair-queue
frame-relay map ipv6 FEC0::154:2 203 broadcast
frame-relay map ip 180.40.7.66 201 broadcast
frame-relay map ipv6 FE80::212:7FFF:FE8D:3CA0 203 broadcast
no frame-relay inverse-arp
end
R2#show ipv6 os n
Neighbor ID Pri State Dead Time Interface ID Interface
7.7.7.7 1 FULL/ - 00:00:36 28 Tunnel0
30.1.1.1 1 FULL/DR 00:01:48 8 Serial1/0
R2#
R2#show run | beg Loopback601
interface Loopback601
no ip address
ipv6 address FEC0::101:1/126
ipv6 ospf network point-to-point
ipv6 ospf 100 area 0
!
interface Tunnel0
no ip address
ipv6 unnumbered Loopback601
ipv6 ospf 100 area 0
tunnel source Serial1/1
tunnel destination 185.1.1.1
tunnel mode ipv6ip
interface Serial1/1
ip address 186.1.1.2 255.255.255.252
R7#show run | beg Loopback607
interface Loopback607
no ip address
ipv6 address FEC0::105:1/126
ipv6 ospf network point-to-point
ipv6 ospf 100 area 0
!
interface Tunnel0
no ip address
ipv6 unnumbered Loopback607
ipv6 ospf 100 area 0
tunnel source Serial1/0
tunnel destination 186.1.1.2
tunnel mode ipv6ip
interface Serial1/0
ip address 185.1.1.1 255.255.255.252
encapsulation frame-relay
ipv6 address FEC0::135:2/125
ipv6 ospf 100 area 0
frame-relay map ip 185.1.1.2 701 broadcast
Sincerely,
Dennis J. Hartmann
White Pine Communications
dh8@pobox.com / 914-980-0316
CCSI#23402/CCIP/CCNP/CCDP/CCNA/CCDA
Cisco IP Voice Support & Design Specialist
Cisco Optical, VPN & IDS Specialist
MCSE
_____
From: Bob Sinclair [mailto:bsin@cox.net]
Sent: Wednesday, April 27, 2005 11:33 PM
To: Dennis J. Hartmann; ccielab@groupstudy.com
Subject: Re: IPV6 over NBMA Networks
Dennis,
I am afraid I cannot tell from your posted configs why you cannot form a
neighbor using just link-local. It works for us in Lab 2 over the ATM.
Below you see output over multipoint frame demonstrating OSPF v3 NBMA
neighbors using link-local addresses:
R1#sh ipv6 ospf nei
Neighbor ID Pri State Dead Time Interface ID Interface
172.16.102.1 1 FULL/DR 00:01:49 3 Serial0/0
172.16.106.1 1 FULL/BDR 00:00:38 4 ATM3/0
R1#sh run int s0/0
Building configuration...
Current configuration : 762 bytes
!
interface Serial0/0
ip address 172.16.123.1 255.255.255.0
ip access-group R3-http-security in
no ip unreachables
ip pim dense-mode
encapsulation frame-relay
ipv6 address FEC0::A:0:0:7B:1/125
ipv6 address FE80::2D0:58FF:FE95:C8A1 link-local
ipv6 rip FRAME-123 enable
ipv6 ospf neighbor FE80::201:42FF:FEA5:9CE1 priority 1 <<<<<<<<<<<<<<
ipv6 ospf 1 area 0
frame-relay map ipv6 FEC0::A:0:0:7B:2 102
frame-relay map ipv6 FEC0::A:0:0:7B:3 103
frame-relay map ipv6 FE80::204:C1FF:FE8E:19E0 103 broadcast
frame-relay map ipv6 FE80::201:42FF:FEA5:9CE1 102 broadcast
frame-relay map ip 172.16.123.1 102 broadcast
frame-relay map ip 172.16.123.2 102 broadcast
frame-relay map ip 172.16.123.3 103 broadcast
no frame-relay inverse-arp
frame-relay lmi-type cisco
end
R1#sh ipv6 int s0/0
Serial0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::2D0:58FF:FE95:C8A1
Global unicast address(es):
FEC0::A:0:0:7B:1, subnet is FEC0::A:0:0:7B:0/125
Joined group address(es):
FF02::1
FF02::2
FF02::5
FF02::6
FF02::9
FF02::1:FF7B:1
FF02::1:FF95:C8A1
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is not supported
ND reachable time is 30000 milliseconds
Hosts use stateless autoconfig for addresses.
R1#sh ipv6 ospf int s0/0
Serial0/0 is up, line protocol is up
Link Local Address FE80::2D0:58FF:FE95:C8A1, Interface ID 3
Area 0, Process ID 1, Instance ID 0, Router ID 172.16.123.1
Network Type NON_BROADCAST, Cost: 64 <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 172.16.102.1, local address
FE80::201:42FF:FEA5:9CE1
Backup Designated router (ID) 172.16.123.1, local address
FE80::2D0:58FF:FE95:C8A1
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:03
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 172.16.102.1 (Designated Router)
Suppress hello for 0 neighbor(s)
R1#
And for R2:
R2#sh ipv6 ospf nei
Neighbor ID Pri State Dead Time Interface ID Interface
172.16.123.1 1 FULL/BDR 00:01:37 3 Serial0/0
R2#sh run int s0/0
Building configuration...
Current configuration : 674 bytes
!
interface Serial0/0
ip address 172.16.123.2 255.255.255.0
ip pim dense-mode
encapsulation frame-relay
ip ospf priority 0
ipv6 address FEC0::A:0:0:7B:2/125
ipv6 address FE80::201:42FF:FEA5:9CE1 link-local
ipv6 rip FRAME-123 enable
ipv6 ospf neighbor FE80::2D0:58FF:FE95:C8A1 priority 1
<<<<<<<<<<<<<<<<<<<
ipv6 ospf 1 area 0
frame-relay map ipv6 FEC0::A:0:0:7B:1 201 broadcast
frame-relay map ipv6 FEC0::A:0:0:7B:3 201
frame-relay map ipv6 FE80::2D0:58FF:FE95:C8A1 201 broadcast
frame-relay map ip 172.16.123.1 201 broadcast
frame-relay map ip 172.16.123.2 201 broadcast
frame-relay map ip 172.16.123.3 201 broadcast
no frame-relay inverse-arp
frame-relay lmi-type cisco
end
R2#sh ipv6 int s0/0
Serial0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::201:42FF:FEA5:9CE1
Global unicast address(es):
FEC0::A:0:0:7B:2, subnet is FEC0::A:0:0:7B:0/125
Joined group address(es):
FF02::1
FF02::2
FF02::5
FF02::6
FF02::9
FF02::1:FF7B:2
FF02::1:FFA5:9CE1
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is not supported
ND reachable time is 30000 milliseconds
Hosts use stateless autoconfig for addresses.
R2#
R2#sh ipv6 ospf int s0/0
Serial0/0 is up, line protocol is up
Link Local Address FE80::201:42FF:FEA5:9CE1, Interface ID 3
Area 0, Process ID 1, Instance ID 0, Router ID 172.16.102.1
Network Type NON_BROADCAST, Cost: 64 <<<<<<<<<<<<<<<<<<<<<<<<
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 172.16.102.1, local address
FE80::201:42FF:FEA5:9CE1
Backup Designated router (ID) 172.16.123.1, local address
FE80::2D0:58FF:FE95:C8A1
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:02
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 3, maximum is 3
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 172.16.123.1 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
R2#
HTH,
Bob Sinclair
CCIE #10427, CCSI 30427, CISSP
www.netmasterclass.net
----- Original Message -----
From: Dennis J. Hartmann <mailto:dennisjhartmann@hotmail.com>
To: ccielab@groupstudy.com
Cc: 'Bob Sinclair' <mailto:bsin@cox.net>
Sent: Wednesday, April 27, 2005 10:01 PM
Subject: IPV6 over NBMA Networks
In the NMC solution to Lab#2, they use ipv6 ospf neighbors to the
Link-Local address of the IPv6 NBMA neighbor. I tested this and was not
able to get the neighbor adjacency up without building a neighbor statement
to both the link-local address and the Global Unicast Address. My
configuration is below if anyone wants to learn from it or possibly let me
know why I needed both the link-local and the global address.
In fairness to NMC, they were using a multipoint ATM interface and I
used a Serial frame interface. The network type was non-broadcast
though....
interface Serial1/0
ip address 180.40.7.65 255.255.255.224
encapsulation frame-relay
ipv6 address FEC0::154:1/125
ipv6 ospf neighbor FE80::212:7FFF:FE8D:3CA0 priority 1
ipv6 ospf neighbor FEC0::154:2
ipv6 ospf 100 area 0
no fair-queue
frame-relay map ipv6 FEC0::154:2 203 broadcast
frame-relay map ip 180.40.7.66 201 broadcast
frame-relay map ipv6 FE80::212:7FFF:FE8D:3CA0 203 broadcast
no frame-relay inverse-arp
interface Serial1/0
ip address 208.28.1.2 255.255.255.248
encapsulation frame-relay
ip split-horizon
ipv6 address FEC0::154:2/125
ipv6 ospf neighbor FE80::212:7FFF:FE8D:3A80 priority 1
ipv6 ospf neighbor FEC0::154:1
ipv6 ospf 100 area 0
no fair-queue
frame-relay map ipv6 FEC0::154:1 302 broadcast
frame-relay map ipv6 FE80::212:7FFF:FE8D:3A80 302 broadcast
frame-relay map ip 208.28.1.1 301 broadcast
no frame-relay inverse-arp
end
R3#show ipv6 ospf int
Serial1/0 is up, line protocol is up
Link Local Address FE80::212:7FFF:FE8D:3CA0, Interface ID 8
Area 0, Process ID 100, Instance ID 0, Router ID 30.1.1.1
Network Type NON_BROADCAST, Cost: 781
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 30.1.1.1, local address FE80::212:7FFF:FE8D:3CA0
Backup Designated router (ID) 20.1.1.1, local address
FE80::212:7FFF:FE8D:3A80
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:25
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 2, maximum is 4
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 20.1.1.1 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
R3#show ipv6 int s 1/0
Serial1/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::212:7FFF:FE8D:3CA0
Global unicast address(es):
FEC0::154:2, subnet is FEC0::154:0/125
Joined group address(es):
FF02::1
FF02::2
FF02::5
FF02::6
FF02::1:FF54:2
FF02::1:FF8D:3CA0
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is not supported
ND reachable time is 30000 milliseconds
Hosts use stateless autoconfig for addresses.
R2#show ipv6 ospf int s 1/0
Serial1/0 is up, line protocol is up
Link Local Address FE80::212:7FFF:FE8D:3A80, Interface ID 8
Area 0, Process ID 100, Instance ID 0, Router ID 20.1.1.1
Network Type NON_BROADCAST, Cost: 781
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 30.1.1.1, local address FE80::212:7FFF:FE8D:3CA0
Backup Designated router (ID) 20.1.1.1, local address
FE80::212:7FFF:FE8D:3A80
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:02
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 2, maximum is 2
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 30.1.1.1 (Designated Router)
Suppress hello for 0 neighbor(s)
R2#show ipv6 int s 1/0
Serial1/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::212:7FFF:FE8D:3A80
Global unicast address(es):
FEC0::154:1, subnet is FEC0::154:0/125
Joined group address(es):
FF02::1
FF02::2
FF02::5
FF02::6
FF02::1:FF54:1
FF02::1:FF8D:3A80
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is not supported
ND reachable time is 30000 milliseconds
Hosts use stateless autoconfig for addresses.
R2#
Sincerely,
Dennis J. Hartmann
White Pine Communications
CCSI#23402/CCIP/CCNP/CCDP/CCNA/CCDA
Cisco IP Voice Support & Design Specialist
Cisco Optical, VPN & IDS Specialist
MCSE
This archive was generated by hypermail 2.1.4 : Tue May 03 2005 - 07:55:10 GMT-3