RE: OSPF Adjancies

From: Edwards, Andrew M (andrew.m.edwards@boeing.com)
Date: Thu Feb 12 2004 - 22:00:40 GMT-3


You shouldn't need to worry about the MTU because the router will encapsulate via ethernet adding the 18 bytes so the MTU will match 1518=1518.

If you have the vlan125 helo-interval set to 1 however, the routers default OSPF helo interval should be 10 seconds so they will never form an adjacency on vlan125. Make sure to do a debug IP ospf adjacency and watch the logs for helo and dead intervals during the adjecency formation.

andy

-----Original Message-----
From: Charles T. Alexander [mailto:charles.t.alexander@verizon.net]
Sent: Thursday, February 12, 2004 2:32 PM
To: ccielab@groupstudy.com
Subject: OSPF Adjancies

I am having problems forming ospf neighbors on the catayst below for Vlan 125. I have also attached one of the routers which is trying to get adjacencies.

-----------------------------------------------------------
cat#r
Building configuration...

Current configuration : 6055 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat
!
logging buffered 10000 debugging
enable password radnor
!
username Tess privilege 15 password 0 Abbott
ip subnet-zero
ip routing
no ip domain-lookup
ip domain-name ctasys.net
!
!
!
key chain chucko3
 key 1
  key-string ctasta3
key chain chucko50
 key 1
  key-string ctasta50
key chain cta_vlanc
 key 1
  key-string cta_vlanc
spanning-tree extend system-id
system mtu 1518
!
!
!
interface Loopback0
 ip address 137.10.10.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback1
 ip address 137.10.20.1 255.255.255.0
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
!
interface FastEthernet0/1
 switchport access vlan 125
 no ip address
!
interface FastEthernet0/2
 switchport access vlan 125
 no ip address
!
interface FastEthernet0/3
 no ip address
!
interface FastEthernet0/4
 switchport access vlan 74
 no ip address
!
interface FastEthernet0/5
 switchport access vlan 50
 no ip address
 storm-control broadcast level 0.00
!
interface FastEthernet0/6
 switchport access vlan 74
 no ip address
!
interface FastEthernet0/7
 switchport access vlan 74
 no ip address
!
interface FastEthernet0/8
 switchport access vlan 98
 no ip address
!
interface FastEthernet0/9
 switchport access vlan 98
 no ip address
!
interface FastEthernet0/10
 no ip address
!
interface FastEthernet0/11
 switchport access vlan 125
 no ip address
!
interface FastEthernet0/12
 switchport access vlan 98
 no ip address
!
interface FastEthernet0/13
 switchport access vlan 192
 no ip address
!
interface FastEthernet0/14
 switchport access vlan 74
 no ip address
!
interface FastEthernet0/15
 switchport access vlan 74
 no ip address
!
interface FastEthernet0/16
 switchport access vlan 125
 no ip address
!
interface FastEthernet0/17
 switchport access vlan 200
 no ip address
 no keepalive
!
interface FastEthernet0/18
 description test port cta
 bandwidth 10000
 no ip address
 speed 10
!
interface FastEthernet0/19
 switchport access vlan 100
 no ip address
!
interface FastEthernet0/20
 no ip address
!
interface FastEthernet0/21
 no ip address
!
interface FastEthernet0/22
 no ip address
!
interface FastEthernet0/23
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,50,74,98,100,125,192,200,1002-1005
 switchport mode trunk
 no ip address
 channel-group 1 mode desirable
!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,50,74,98,100,125,192,200,1002-1005
 switchport mode trunk
 no ip address
 channel-group 1 mode desirable
!
interface GigabitEthernet0/1
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface Vlan1
 no ip address
!
interface Vlan50
 description Vlan B
 ip address 137.10.50.10 255.255.255.0
 ip rip authentication mode md5
 ip rip authentication key-chain chucko50
!
interface Vlan74
 description Vlan C
 ip address 137.10.74.10 255.255.255.192
 ip helper-address 137.10.200.1
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 cta_vlanc
!
interface Vlan125
 description Vlan A
 ip address 137.10.125.10 255.255.255.0
 ip ospf hello-interval 1
!
interface Vlan192
 description Vlan E
 ip address 192.168.30.10 255.255.255.0
 no ip unreachables
 ip rip authentication mode md5
 ip rip authentication key-chain chucko3
!
interface Vlan200
 description Vlan F
 ip address 137.10.200.10 255.255.255.192
!
router eigrp 100
 redistribute ospf 1 metric 10000 1000 255 1 1500
 redistribute rip metric 10000 1000 255 1 1500
 network 137.10.74.0 0.0.0.63
 no auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 router-id 137.10.10.1
 log-adjacency-changes detail
 timers spf 0 0
 redistribute eigrp 100 metric-type 1 subnets
 redistribute rip metric-type 1 subnets
 network 137.10.10.0 0.0.0.255 area 0
 network 137.10.125.0 0.0.0.255 area 0
 distance 171
 distance 110 0.0.0.0 255.255.255.255 2
!
router rip
 version 2
 timers basic 40 120 180 240
 redistribute eigrp 100 metric 1
 redistribute ospf 1 metric 1
 passive-interface default
 no passive-interface Vlan50
 no passive-interface Vlan192
 no passive-interface Vlan200
 network 137.10.0.0
 network 192.168.30.0
 default-information originate route-map def-to-bb3 distribute-list prefix just27 in Vlan192 distance 171 distance 169 137.10.50.10 0.0.0.0 5 distance 169 137.10.50.5 0.0.0.0 5 no auto-summary ! ip classless ip http server ip http authentication local ! ip access-list standard def-bb3 permit 137.10.50.0 0.0.0.255 permit 137.10.74.0 0.0.0.63 permit 137.10.200.0 0.0.0.63 permit 137.10.125.0 0.0.0.255 ! ! ! ip prefix-list just27 seq 5 permit 192.178.0.0/16 ge 27 ! logging 137.10.125.101 access-list 2 permit 137.10.2.0 0.0.0.255 access-list 2 permit 137.10.1.0 0.0.0.255 access-list 2 permit 137.10.25.0 0.0.0.3 access-list 2 permit 192.176.0.0 0.0.3.0 access-list 5 permit 137.10.2.0 0.0.0.255 access-list 5 permit 137.10.1.0 0.0.0.255 access-list 5 permit 137.10.5.0 0.0.0.255 access-list 5 permit 137.10.10.0 0.0.0.255 access-list 5 permit 137.10.25.0 0.0.0.3 access-list 5 permit 137.10.125.0 0.0.0.255 access-list 5 permit 137.10.45.0 0.0.0.15 access-list 5 permit 192.176.!
 0.0 0.0.3.0 access-list 5 permit 205.1.1.0 0.0.0.127 arp 137.10.50.5 00e0.1ef8.0961 ARPA route-map def-to-bb3 permit 10 match ip address def-bb3 set interface Vlan192 ! snmp-server engineID local 800000090300000BBE9D5301 snmp-server location Bryn Mawr snmp-server contact Charlie alias exec r show run alias exec c config t alias exec i show ip route alias exec bs show ip bgp summary alias exec u undebug all alias exec w write alias exec b show ip bgp alias exec s show ip int brief ! line con 0 exec-timeout 0 0 logging synchronous escape-character 27 line vty 0 4 exec-timeout 0 0 password bp login line vty 5 15 exec-timeout 0 0 password bp login ! ! monitor session 1 source vlan 125 rx monitor session 1 destination remote vlan 100 reflector-port Fa0/23 end

cat#

----------------------------------------------------------
r2#r
Building configuration...

Current configuration : 2566 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
boot system tftp r2-ios-image 137.10.74.62
logging buffered 10000 debugging
enable password radnor
!
username r5 password 0 ctasta
ip subnet-zero
no ip domain-lookup
ip host r1 137.10.125.1
!
isdn switch-type basic-ni
!
!
!
interface Loopback0
 ip address 137.10.2.2 255.255.255.0
 ip router isis
!
interface Ethernet0
 backup delay 5 60
 backup interface BRI0
 ip address 137.10.125.2 255.255.255.0
 ip ospf hello-interval 1
 ip ospf priority 0
!
interface Serial0
 ip address 137.10.100.2 255.255.255.224
 ip router isis
 encapsulation frame-relay
 frame-relay map clns 104 broadcast
 frame-relay map ip 137.10.100.2 104
 frame-relay map ip 137.10.100.4 104 broadcast
 frame-relay map ip 137.10.100.6 104 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 ip address 137.10.25.2 255.255.255.252
 encapsulation ppp
 dialer map ip 137.10.25.1 name r5 broadcast 4082222222
 dialer load-threshold 99 either
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 40811111111
 isdn spid2 40811111112
 no peer neighbor-route
 no cdp enable
 ppp authentication chap callin
 ppp multilink
 hold-queue 25 in
!
router ospf 1
 router-id 137.10.2.2
 log-adjacency-changes
 timers lsa-group-pacing 600
 redistribute connected metric 10 subnets route-map c2o redistribute isis level-2 subnets network 137.10.25.0 0.0.0.3 area 1 network 137.10.125.0 0.0.0.255 area 0 ! router isis
 redistribute ospf 1
 distance 109 137.10.1.1 0.0.0.0 2
 net 49.0102.2222.2222.2222.00
 is-type level-2-only
!
ip classless
ip http server
ip ospf name-lookup
ip pim bidir-enable
!
access-list 1 permit 137.10.2.0
access-list 1 permit 137.10.100.0 0.0.0.31
access-list 2 permit 137.10.6.0
access-list 2 permit 137.10.5.0
access-list 2 permit 137.10.45.0 0.0.0.15
access-list 2 permit 205.1.1.0 0.0.0.127
access-list 101 permit icmp any any
access-list 101 permit ip any host 137.10.125.10
access-list 101 permit tcp any any eq bgp
access-list 101 permit ospf any any
dialer-list 1 protocol ip list 101
route-map c2o permit 10
 match ip address 1
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end

r2#



This archive was generated by hypermail 2.1.4 : Fri Mar 05 2004 - 07:13:49 GMT-3