Re: Re: ospf area range

From: navaid@rogers.com
Date: Sat Aug 30 2003 - 11:27:24 GMT-3


George,
Thanks for reply. Attached are configs.
I did shut on all interfaces on R1,R2,R5 and neighbor routers. Only interfaces UP are one shown in figure.

R1-E0/0---(area 12)---E0-R2-S0.100---(area0)---S0-R5
        172.29.12.0/26 172.29.100.0/29

!##################Router1##################
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R1
!

!
!
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 172.29.12.1 255.255.255.192
 half-duplex
!
interface Ethernet0/1
 ip address 172.29.10.1 255.255.255.128
 half-duplex
!
router ospf 1
 log-adjacency-changes
 area 12 virtual-link 192.168.2.2 authentication message-digest
 area 12 virtual-link 192.168.2.2 message-digest-key 1 md5 7 01100F175804
 summary-address 172.29.10.0 255.255.255.0
 redistribute connected subnets route-map con2ospf
 network 172.29.12.0 0.0.0.255 area 12
 network 192.168.1.1 0.0.0.0 area 1
!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 10.12.1.0 mask 255.255.255.0
 network 10.12.2.0 mask 255.255.255.0
 network 10.12.3.0 mask 255.255.255.0
 neighbor 172.29.12.2 remote-as 12
 no auto-summary
!
ip classless
ip route 10.12.1.0 255.255.255.0 Null0
ip route 10.12.2.0 255.255.255.0 Null0
ip route 10.12.3.0 255.255.255.0 Null0
ip http server
!
access-list 1 permit 172.29.10.0 0.0.0.63
route-map con2ospf permit 10
 match ip address 1
 set tag 111
!
!

!##################Router2##################
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R2
!
isdn switch-type basic-ni
!
!
!
!
interface Loopback0
 ip address 192.168.2.2 255.255.255.255
!
interface Ethernet0
 ip address 172.29.12.2 255.255.255.192
 ip policy route-map tnet
!
interface Serial0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type cisco
!
interface Serial0.24 point-to-point
 ip address 172.29.24.2 255.255.255.0
 frame-relay interface-dlci 104
!
interface Serial0.100 multipoint
 ip address 172.29.100.2 255.255.255.248
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 7 00071A150754
 frame-relay map ip 172.29.100.2 105
 frame-relay map ip 172.29.100.5 105 broadcast
 frame-relay map ip 172.29.100.6 106 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 ip address 172.29.25.2 255.255.255.0
 encapsulation ppp
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 7 01100F175804
 dialer map ip 172.29.25.5 name R5 broadcast
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835860701 8358607
 isdn spid2 0835870701 8358707
 cdapi buffers regular 0
 cdapi buffers raw 0
 cdapi buffers large 0
 ppp authentication chap
!
router ospf 1
 log-adjacency-changes
 area 0 authentication message-digest
 area 0 range 172.29.100.0 255.255.255.0
 area 0 range 172.29.200.0 255.255.255.0
 area 12 range 172.29.12.0 255.255.255.0
 area 12 virtual-link 192.168.1.1 authentication message-digest
 area 12 virtual-link 192.168.1.1 message-digest-key 1 md5 7 030752180500
 redistribute rip metric 10 subnets
 network 172.29.12.0 0.0.0.255 area 12
 network 172.29.25.0 0.0.0.255 area 0
 network 172.29.100.0 0.0.0.7 area 0
 network 172.29.124.0 0.0.0.3 area 0
 network 192.168.2.2 0.0.0.0 area 2
 neighbor 172.29.100.5
 neighbor 172.29.100.6
 distance ospf intra-area 114 inter-area 112
!
router rip
 version 1
 redistribute ospf 1 metric 2 match internal external 1 external 2
 passive-interface BRI0
 passive-interface Ethernet0
 passive-interface Loopback0
 passive-interface Serial0.100
 network 172.29.0.0
 distribute-list 4 in Serial0.24
 distance 105
 no auto-summary
!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 neighbor 172.29.12.1 remote-as 12
 neighbor 172.29.100.5 remote-as 5
 neighbor 172.29.100.5 route-map r2-2-r5 out
 neighbor 172.29.100.6 remote-as 6
 neighbor 172.29.100.6 send-community
 neighbor 172.29.100.6 route-map r2-2-r6 out
 no auto-summary
!
ip kerberos source-interface any
ip classless
ip http server
!
access-list 1 permit 10.12.1.0 0.0.0.255
access-list 2 permit 172.29.24.0 0.0.0.255
access-list 2 permit 172.29.124.0 0.0.0.255
access-list 2 permit 10.12.2.0 0.0.0.255
access-list 3 permit 10.12.3.0 0.0.0.255
access-list 4 permit 172.29.25.0 0.0.0.255
access-list 101 permit tcp host 192.168.1.1 172.29.80.0 0.0.0.255 eq telnet
dialer-list 1 protocol ip permit
route-map tnet permit 10
 match ip address 1
 set ip next-hop 172.29.100.5
!
route-map tnet permit 20
!
route-map r2-2-r5 permit 10
 match ip address 1
 set as-path prepend 100
!
route-map r2-2-r5 permit 20
 match ip address 2
 set as-path prepend 100 200
!
route-map r2-2-r5 permit 30
 match ip address 3
 set metric 275
!
route-map r2-2-r5 permit 40
!
route-map r2-2-r6 deny 10
 match ip address 1
!
route-map r2-2-r6 permit 20
 match ip address 2
 set as-path prepend 1200
!
route-map r2-2-r6 permit 30
 match ip address 3
 set community no-advertise
!
route-map r2-2-r6 permit 40
!

!##################Router3##################
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R5
!
!
username R2 password 7 110A1016141D
ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
!
!
!
interface Loopback0
 ip address 192.168.5.5 255.255.255.255
!
interface Ethernet0
 ip address 10.29.200.5 255.255.255.0 secondary
 ip address 172.29.200.5 255.255.255.128
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 7 104D000A0618
 standby 1 priority 100 preempt
 standby 1 name First
 standby 1 ip 172.29.200.1
!
interface Serial0
 ip address 172.29.100.5 255.255.255.248
 encapsulation frame-relay
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 7 121A0C041104
 ip ospf priority 0
 ip ospf mtu-ignore
 frame-relay map ip 172.29.100.2 501 broadcast
 frame-relay map ip 172.29.100.5 501
 frame-relay map ip 172.29.100.6 501 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 ip address 172.29.25.5 255.255.255.0
 encapsulation ppp
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 7 1511021F0725
 ip ospf demand-circuit
 dialer map ip 172.29.25.2 name R2 broadcast 8358607
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835860801 8358608
 isdn spid2 0835870801 8358708
 cdapi buffers regular 0
 cdapi buffers raw 0
 cdapi buffers large 0
 ppp authentication chap
!
router ospf 1
 log-adjacency-changes
 area 0 authentication message-digest
 network 10.29.200.0 0.0.0.255 area 0
 network 172.29.25.0 0.0.0.255 area 0
 network 172.29.100.0 0.0.0.7 area 0
 network 172.29.200.0 0.0.0.127 area 0
 network 192.168.5.5 0.0.0.0 area 5
!
router bgp 5
 no synchronization
 bgp log-neighbor-changes
 neighbor 172.29.100.2 remote-as 12
 neighbor 172.29.200.7 remote-as 78
 neighbor 192.168.6.6 remote-as 6
 neighbor 192.168.6.6 ebgp-multihop 255
 neighbor 192.168.6.6 update-source Loopback0
 no auto-summary
!
ip kerberos source-interface any
ip classless
ip http server
!
dialer-list 1 protocol ip permit
!

>
> From: "Georg Pauwen" <pauwen@hotmail.com>
> Date: 2003/08/30 Sat AM 09:53:56 EDT
> To: navaid@rogers.com, ccielab@groupstudy.com
> Subject: Re: ospf area range
>
> Hello,
>
> can you post your configs ? I cannot reproduce the problem, I either get
> only the /26 IA route (without area range) or I get only the /24 IA route
> (with area range).
>
> Regards,
>
> Georg
>
>
> >From: navaid@rogers.com
> >Reply-To: navaid@rogers.com
> >To: ccielab@groupstudy.com
> >Subject: ospf area range
> >Date: Fri, 29 Aug 2003 12:56:16 -0400
> >
> >Question: I am using area range command on R2 to summarize 172.29.12.0/26
> >as 24-bit mask. Why I am seeing more specific route on R5 ?
> >
> >R1----(area 12)----R2----(area0)----R5
> > 172.29.12.0/26 172.29.100.0/29
> >
> >On R2 using following command:
> >area 12 range 172.29.12.0 255.255.255.0
> >
> >On R1 I am seeing following two routes:
> >O IA 172.29.12.0/24 [110/20] via 172.29.12.2, 00:04:20, Ethernet0/0
> >C 172.29.12.0/26 is directly connected, Ethernet0/0
> >
> >On R5 I am seeing following two routes:
> >O IA 172.29.12.0/26 [110/84] via 172.29.100.2, 00:05:40, Serial0
> >O IA 172.29.12.0/24 [110/74] via 172.29.100.2, 00:05:40, Serial0
> >
> >
> >_______________________________________________________________________
> >You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
> >
> >Subscription information may be found at:
> >http://www.groupstudy.com/list/CCIELab.html
>
> _________________________________________________________________
> MSN Messenger : discutez en direct avec vos amis !
> http://www.msn.fr/msger/default.asp
>
>
> _______________________________________________________________________
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>

1



This archive was generated by hypermail 2.1.4 : Tue Sep 02 2003 - 18:54:10 GMT-3