Re: bgp synchronization problem

From: benmekki kamal (benmekki_kamal@yahoo.fr)
Date: Fri Aug 15 2003 - 20:13:03 GMT-3


here is my configs
TIA
Kamal
 
R1---- RIP------R3------OSPF-----R4
R1------------- IBGP ------------R4
 
 
R1 and R4 are running BGP (AS 135) with synchroniation enabled
R1's IGP is RIP
R4'S IGP is OSPF

R1 is connected to AS 1 and learning 10.10.10.0/24 from
R4 is connected to AS 2 and learning 20.20.20.0/24 from

R3 is peforming mutuelle redistribution between RIP and OSPF
 
sh ip bgp from R1
   Network Next Hop Metric LocPrf Weight Path
*> 10.10.10.0/24 150.100.1.254 0 0 1 i
*>i20.20.20.0/24 135.1.4.4 0 100 0 2 i
R1#

R1 has synchronizated IBGP learned route 20.20.20.0
R1#sh ip route 20.20.20.0
Routing entry for 20.20.20.0/24
  Known via "rip", distance 120, metric 2
  Redistributing via rip
  Advertised by rip (self originated)
  Last update from 135.1.13.3 on Serial0, 00:00:27 ago
  Routing Descriptor Blocks:
  * 135.1.13.3, from 135.1.13.3, 00:00:27 ago, via Serial0
      Route metric is 2, traffic share count is 1
R1#
R1#sh ip bgp 20.20.20.0
BGP routing table entry for 20.20.20.0/24, version 3
Paths: (1 available, best #1)
  Advertised to non peer-group peers:
    150.100.1.254
  2, (received & used)
    135.1.4.4 (metric 2) from 135.1.4.4 (135.1.4.4)
      Origin IGP, metric 0, localpref 100, valid, internal,
synchronized, best, ref 2
R1#
 
sh ip bgp from R4
   Network Next Hop Metric LocPrf Weight Path
* i10.10.10.0/24 135.1.1.1 0 100 0 1 i
*> 20.20.20.0/24 150.100.2.254 0 0 2 i
R4#
R4 doesn't synchronize IBGP learned Route 10.10.10.0
 

R4#sh ip route 10.10.10.0
Routing entry for 10.10.10.0/24
  Known via "ospf 1", distance 110, metric 84
  Tag 1, type extern 1
  Last update from 135.1.34.3 on Serial2/0.1, 00:11:31 ago
  Routing Descriptor Blocks:
  * 135.1.34.3, from 135.1.34.3, 00:11:31 ago, via Serial2/0.1
      Route metric is 84, traffic share count is 1

R4#sh ip bgp 10.10.10.0
BGP routing table entry for 10.10.10.0/24, version 0
Paths: (1 available, no best path)
  Not advertised to any peer
  1, (received & used)
    135.1.1.1 (metric 84) from 135.1.1.1 (135.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal, not
synchronized
R4#

**************** R1 config **************
interface Loopback0
 ip address 135.1.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 150.100.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 135.1.13.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
!
router rip
 version 2
 redistribute bgp 135 metric 2
 passive-interface default
 no passive-interface Ethernet0
 no passive-interface Serial0
 network 135.1.0.0
 network 150.100.0.0
 no auto-summary
!
router bgp 135
 bgp log-neighbor-changes
 neighbor 135.1.4.4 remote-as 135
 neighbor 135.1.4.4 update-source Loopback0
 neighbor 135.1.4.4 next-hop-self
 neighbor 135.1.4.4 soft-reconfiguration inbound
 neighbor 150.100.1.254 remote-as 1
 neighbor 150.100.1.254 soft-reconfiguration inbound
 no auto-summary
!
******************** R4 config *****************
interface Loopback0
 ip address 135.1.4.4 255.255.255.0
!
!
interface Ethernet1/0
 ip address 150.100.2.4 255.255.255.0
!
interface Serial2/0.1 multipoint
 ip address 135.1.34.4 255.255.255.248
 frame-relay map ip 135.1.34.3 403 broadcast
 no frame-relay inverse-arp
!
router ospf 1
 log-adjacency-changes
 redistribute bgp 135 metric-type 1 subnets
 network 135.1.4.4 0.0.0.0 area 0
 network 135.1.34.4 0.0.0.0 area 0
 network 150.100.2.4 0.0.0.0 area 0
 neighbor 135.1.34.3
!
router bgp 135
 bgp log-neighbor-changes
 neighbor 135.1.1.1 remote-as 135
 neighbor 135.1.1.1 update-source Loopback0
 neighbor 135.1.1.1 next-hop-self
 neighbor 135.1.1.1 soft-reconfiguration inbound
 neighbor 150.100.2.254 remote-as 2
 neighbor 150.100.2.254 soft-reconfiguration inbound
 no auto-summary
!
********************* R3 config ********************
!
interface Loopback0
 ip address 135.1.3.3 255.255.255.0
!
interface Serial1/0
 ip address 135.1.34.3 255.255.255.248
 encapsulation frame-relay
 ip ospf priority 0
 serial restart-delay 0
 frame-relay map ip 135.1.34.4 304 broadcast
 no frame-relay inverse-arp
!
interface Serial1/1
 ip address 135.1.13.3 255.255.255.0
 serial restart-delay 0
 clockrate 2016000

router ospf 1
 router-id 135.1.34.3
 log-adjacency-changes
 redistribute rip metric-type 1 subnets
 network 135.1.3.3 0.0.0.0 area 0
 network 135.1.34.3 0.0.0.0 area 0
!
router rip
 version 2
 redistribute ospf 1 metric 2
 passive-interface default
 no passive-interface Serial1/1
 network 135.1.0.0
 no auto-summary
!

---------------------------------
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en frangais !
Testez le nouveau Yahoo! Mail



This archive was generated by hypermail 2.1.4 : Tue Sep 02 2003 - 18:53:59 GMT-3