RE: Gotcha on Redistribute Connected

From: Jeongwoo Park (jpark@wams.com)
Date: Wed Jul 09 2003 - 16:09:47 GMT-3


Even with metric, still not working.

router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 summary-address 170.100.20.0 255.255.255.0
 redistribute connected subnets route-map c2o
 redistribute rip subnets route-map r2o
 network 170.100.12.0 0.0.0.255 area 0
 network 170.100.124.0 0.0.0.255 area 0
 default-metric 2600

-------------------------------------------------------------------------
FIGHT BACK AGAINST SPAM!
Download Spam Inspector, the Award Winning Anti-Spam Filter
http://mail.giantcompany.com

-----Original Message-----
From: Jonathan V Hays [mailto:jhays@jtan.com]
Sent: Wednesday, July 09, 2003 12:01 PM
To: ccielab@groupstudy.com
Cc: 'Jeongwoo Park'
Subject: RE: Gotcha on Redistribute Connected

Always assign metrics when redistributing. Some redistributions won't
even work without it.

> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On
> Behalf Of Jeongwoo Park
> Sent: Wednesday, July 09, 2003 2:13 PM
> To: 'John Matijevic'; Brian Dennis; 'Badger'
> Cc: 'Ram Shummoogum'; ccielab@groupstudy.com
> Subject: RE: Gotcha on Redistribute Connected
>
>
> Here you go;
>
> R1;
> hostname r1
> !
> !
> !
> !
> !
> !
> ip subnet-zero
> no ip domain-lookup
> !
> isdn switch-type basic-ni
> !
> !
> !
> !
> !
> interface Ethernet0/0
> ip address 170.100.15.1 255.255.255.0
> !
> interface Serial0/0
> backup interface BRI0/0
> ip address 170.100.124.1 255.255.255.0
> encapsulation frame-relay
> ip ospf network point-to-multipoint
> frame-relay map ip 170.100.124.2 102 broadcast
> no frame-relay inverse-arp
> !
> interface BRI0/0
> ip address 170.100.12.1 255.255.255.240
> encapsulation ppp
> dialer map ip 170.100.12.2 broadcast 8358661
> dialer-group 1
> isdn switch-type basic-ni
> isdn spid1 0835866201 08358662
> isdn spid2 0835866401 08358664
> no peer neighbor-route
> !
> interface Ethernet0/1
> ip address 170.100.30.1 255.255.255.0
> !
> router ospf 1
> router-id 1.1.1.1
> log-adjacency-changes
> area 2 virtual-link 5.5.5.5
> network 170.100.12.0 0.0.0.255 area 0
> network 170.100.15.0 0.0.0.255 area 2
> network 170.100.30.0 0.0.0.255 area 3
> network 170.100.124.0 0.0.0.255 area 0
> !
>
> r2;
> hostname R2
> !
> !
> username all
> !
> !
> !
> !
> ip subnet-zero
> no ip domain-lookup
> !
> isdn switch-type basic-ni
> !
> !
> voice-port 1/0/0
> !
> voice-port 1/0/1
> !
> !
> !
> !
> interface Ethernet0/0
> ip address 170.100.20.2 255.255.255.248
> !
> interface Serial0/0
> no ip address
> encapsulation frame-relay
> no fair-queue
> !
> interface Serial0/0.23 point-to-point
> ip address 170.100.23.2 255.255.255.0
> frame-relay interface-dlci 203
> !
> interface Serial0/0.124 multipoint
> ip address 170.100.124.2 255.255.255.0
> ip ospf network point-to-multipoint
> frame-relay interface-dlci 201
> frame-relay interface-dlci 204
> !
> interface BRI0/0
> ip address 170.100.12.2 255.255.255.240
> encapsulation ppp
> dialer map ip 170.100.12.1 broadcast 8358662
> dialer map ip 170.100.30.1 broadcast 8358662
> dialer watch-group 1
> dialer-group 1
> isdn switch-type basic-ni
> isdn spid1 0835866101 8358661
> isdn spid2 0835866301 8358663
> no peer neighbor-route
> !
> interface Ethernet0/1
> no ip address
> shutdown
> !
> router ospf 1
> router-id 2.2.2.2
> log-adjacency-changes
> summary-address 170.100.20.0 255.255.255.0
> redistribute connected subnets route-map c2o
> redistribute rip subnets
> network 170.100.12.0 0.0.0.255 area 0
> network 170.100.124.0 0.0.0.255 area 0
> !
> router rip
> redistribute ospf 1 metric 3
> passive-interface default
> no passive-interface Serial0/0.23
> network 170.100.0.0
> !
> ip classless
> ip http server
> !
> access-list 1 permit 170.100.20.0 0.0.0.7
> access-list 2 permit 170.100.23.0 0.0.0.255
> access-list 2 permit 170.100.51.0 0.0.0.255
> dialer watch-list 1 ip 170.100.30.1 255.255.255.255
> dialer-list 1 protocol ip permit
> route-map r2o permit 10
> match ip address 2
> !
> route-map c2o permit 10
> match ip address 1
> !
>
> r3;
> hostname r3
> !
> !
> !
> !
> !
> !
> ip subnet-zero
> no ip domain-lookup
> ip host r7 2007 10.0.136.1
> ip host pix3 2008 10.0.136.1
> ip host r5 2005 10.0.136.1
> ip host r4 2004 10.0.136.1
> ip host r3 2003 10.0.136.1
> ip host r6 2006 10.0.136.1
> ip host r2 2002 10.0.136.1
> !
> !
> !
> !
> interface Loopback0
> ip address 170.100.51.3 255.255.255.0
> !
> interface Ethernet0
> ip address 10.0.136.1 255.255.255.0
> !
> interface Ethernet0.12
> !
> interface Serial0
> ip address 170.100.23.3 255.255.255.0
> encapsulation frame-relay
> no fair-queue
> frame-relay map ip 170.100.23.2 302 broadcast
> no frame-relay inverse-arp
> !
> interface Serial1
> no ip address
> shutdown
> !
> router rip
> passive-interface default
> no passive-interface Serial0
> network 170.100.0.0
> !
>
>
>
> --------------------------------------------------------------
> -----------
> FIGHT BACK AGAINST SPAM!
> Download Spam Inspector, the Award Winning Anti-Spam Filter
> http://mail.giantcompany.com
>
>
> -----Original Message-----
> From: John Matijevic [mailto:matijevi@bellsouth.net]
> Sent: Wednesday, July 09, 2003 10:26 AM
> To: Brian Dennis; 'Badger'
> Cc: 'Ram Shummoogum'; park@wams.com; ccielab@groupstudy.com
> Subject: Re: Gotcha on Redistribute Connected
>
> Jeongwoo,
> I am a little confused about which interfaces and ips are in
> what protocol
> processes. I believe this may have been mentioned earlier,
> but could you
> please post full configs so we can have a better idea of
> whats going on.
> Sincerley,
> Matijevic
> ----- Original Message -----
> From: "Brian Dennis" <brian@labforge.com>
> To: "'Badger'" <badger@pongo.org>
> Cc: "'Ram Shummoogum'" <rshummoo@ca.ibm.com>; <park@wams.com>;
> <ccielab@groupstudy.com>
> Sent: Wednesday, July 09, 2003 1:15 PM
> Subject: RE: Gotcha on Redistribute Connected
>
>
> > How could adding the RIP interfaces to the route-map that
> is used for
> > redistribute connected affect the requirements?
> >
> > Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]
> On Behalf Of
> > Badger
> > Sent: Wednesday, July 09, 2003 9:55 AM
> > To: Brian Dennis
> > Cc: 'Ram Shummoogum'; park@wams.com; ccielab@groupstudy.com
> > Subject: RE: Gotcha on Redistribute Connected
> >
> > Hi Brian,
> >
> > I tried that too, but it seems that in a lab environtment that that
> > solution
> > would violate the rule of only placing an interface under
> the routing
> > process
> > that is specified in the requirements...I grabbing straws
> here, because
> > I'm
> > afraid of losing points on the exam for doig this.
> >
> >
> >
> > Quoting Brian Dennis <brian@labforge.com>:
> >
> > > It still happens in 12.3. The solution is of course to add the
> > > interfaces that are running RIP to the route-map that is
> used for the
> > > redistribution of the connected routes.
> > >
> > > Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> > >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com
> [mailto:nobody@groupstudy.com] On Behalf
> > Of
> > > Badger
> > > Sent: Wednesday, July 09, 2003 9:14 AM
> > > To: Ram Shummoogum
> > > Cc: park@wams.com; ccielab@groupstudy.com
> > > Subject: Re: Gotcha on Redistribute Connected
> > >
> > > I posted a similar problem "Subject OSPF <-> EIGRP
> redistribution."
> > > I'm
> > > experiencing this not only with rip/ospf, but also
> ospf/eigrp. I have
> > > found a
> > > cause/reason/solution yet. I use 12.1.5(14)T and plan to
> just flash
> > > 12.2x to
> > > see if it fixes the rpoblem.
> > >
> > >
> > > Quoting Ram Shummoogum <rshummoo@ca.ibm.com>:
> > >
> > > > I don't think you are tripping. I have been observing
> this too in
> > few
> > > > ipexpert labs and I always keep any eye on this.
> > > >
> > > > RAM
> > > >
> > > >
> > > > Jeongwoo Park <jpark@wams.com>@groupstudy.com on
> 07/09/2003 11:28:26
> > > AM
> > > >
> > > > Please respond to Jeongwoo Park <jpark@wams.com>
> > > >
> > > > Sent by: nobody@groupstudy.com
> > > >
> > > >
> > > > To: lab <ccielab@groupstudy.com>
> > > > cc:
> > > > Subject: Gotcha on Redistribute Connected
> > > >
> > > >
> > > > Hi, all
> > > > Here is the layout where the "redistribute connected" got me.
> > > >
> > > > R1-----ospf------R2-lo 0
> > > > |
> > > > rip
> > > > |
> > > > R3
> > > >
> > > > What I did was that I redistributed the connected
> network (loopback
> > > > network)
> > > > into ospf with route-map only for the loopback network
> like this.
> > > > router ospf 1
> > > > router-id 2.2.2.2
> > > > log-adjacency-changes
> > > > summary-address 170.100.20.0 255.255.255.0
> > > > redistribute connected subnets route-map c2o
> > > > redistribute rip subnets
> > > > network 170.100.124.0 0.0.0.255 area 0
> > > > !
> > > > route-map c2o permit 10
> > > > match ip address 1
> > > > !
> > > > access-list 1 permit 170.100.20.0 0.0.0.7
> > > >
> > > > Now, I redistribute rip into ospf on R2.
> > > >
> > > > The problem is that R1 can't see the rip network.
> > > >
> > > > What I think is the gotcha is that when R2 redistribute
> "Connected"
> > > with
> > > > route-map, it filtered the rip network, because the rip
> network is
> > the
> > > > connected network as well from the R2's stand point.
> > > >
> > > > Am I saying right or I am tripping?
> > > >
> > > > Please let me know what I am doing wrong here.
> > > >
> > > > Thanks,
> > > >
> > > > JP
> > > >
> > > >
> > > >
> > >
> >
> ______________________________________________________________
> _________
> > > > You are subscribed to the GroupStudy.com CCIE R&S
> Discussion Group.
> > > >
> > > > Subscription information may be found at:
> > > > http://www.groupstudy.com/list/CCIELab.html
> > > >
> > > >
> > > >
> > >
> >
> ______________________________________________________________
> _________
> > > > You are subscribed to the GroupStudy.com CCIE R&S
> Discussion Group.
> > > >
> > > > Subscription information may be found at:
> > > > http://www.groupstudy.com/list/CCIELab.html
> > > >
> > >
> > >
> > >
> > > -----------------
> > > G'day
> > >
> > > -------------------------------------------------
> > > This mail sent through IMP: http://horde.org/imp/
> > >
> > >
> > >
> >
> ______________________________________________________________
> _________
> > > You are subscribed to the GroupStudy.com CCIE R&S
> Discussion Group.
> > >
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
> > >
> > >
> > >
> >
> >
> >
> > -----------------
> > G'day
> >
> > -------------------------------------------------
> > This mail sent through IMP: http://horde.org/imp/
> >
> >
> >
> ______________________________________________________________
> _________
> > You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> >
> ______________________________________________________________
> _________
> > You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
>
> ______________________________________________________________
> _________
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
> ______________________________________________________________
> _________
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Wed Aug 06 2003 - 06:52:31 GMT-3