From: Richard L. Pickard (nettable_walker@comcast.net)
Date: Sat Jul 05 2003 - 13:53:17 GMT-3
FiestaHere is what I have:
R_25 has an ethernet interface 11.11.11.1
R_25 is BGP AS 100 & is peering with router Expresso BGP AS 150
Expresso is also running EIGRP & is connected to R_2
R_2 is only running EIGRP
My goal is for R_2 to be able to reach the 11.11.11.x network
Since the middle router (Expresso) can ping 11.11.11.1 I am guessing I have
my route map/redistribution statements wrong on Expresso.
hostname R_25
!
interface Loopback0
description eigrp loopback
ip address 10.100.100.1 255.255.255.0
!
interface Loopback100
description BGP loopback
ip address 10.10.100.1 255.255.255.0
!
interface Serial0/1
ip address 172.16.1.2 255.255.255.252
!
interface Serial0/2
ip address 172.16.2.2 255.255.255.252
!
interface Ethernet3/0
ip address 11.11.11.1 255.255.255.0
ip accounting output-packets
full-duplex
router eigrp 10
network 10.0.0.0
network 11.0.0.0
no auto-summary
eigrp router-id 10.100.100.1
!
router bgp 100
synchronization
bgp router-id 10.10.100.1
bgp log-neighbor-changes
redistribute connected
neighbor 172.16.1.1 remote-as 150
neighbor 172.16.2.1 remote-as 175
no auto-summary
R_25#sh ip bgp
BGP table version is 24, local router ID is 10.10.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.10.100.0/24 0.0.0.0 0 32768 ?
*> 10.10.150.0/24 172.16.1.1 0 0 150 ?
*> 10.10.175.0/24 172.16.2.1 0 0 175 ?
* 10.10.200.0/24 172.16.2.1 0 175 200 ?
*> 172.16.1.1 0 150 200 ?
*> 10.100.100.0/24 0.0.0.0 0 32768 ?
*> 10.100.150.0/24 172.16.1.1 0 0 150 ?
* 10.100.200.0/24 172.16.2.1 0 175 200 ?
*> 172.16.1.1 0 150 200 ?
*> 10.111.1.0/24 172.16.2.1 0 0 175 ?
* 10.121.150.0/24 172.16.2.1 0 175 200 ?
*> 172.16.1.1 0 150 200 ?
*> 10.150.150.0/24 172.16.1.1 0 0 150 ?
*> 11.11.11.0/24 0.0.0.0 0 32768 ?
*> 12.10.1.0/30 172.16.1.1 0 0 150 ?
*> 12.10.2.0/30 172.16.1.1 0 0 150 ?
*> 111.111.111.0/24 172.16.1.1 0 0 150 ?
Network Next Hop Metric LocPrf Weight Path
* 172.16.0.0/30 172.16.2.1 0 175 200 ?
*> 172.16.1.1 0 0 150 ?
* 172.16.1.0/30 172.16.1.1 0 0 150 ?
*> 0.0.0.0 0 32768 ?
* 172.16.2.0/30 172.16.2.1 0 0 175 ?
*> 0.0.0.0 0 32768 ?
*> 172.16.3.0/30 172.16.2.1 0 0 175 ?
* 172.16.1.1 0 150 200 ?
R_25#
============================================================================
======
hostname Expresso__
!
interface Loopback0
description eigrp loopback
ip address 10.100.150.1 255.255.255.0
!
interface Loopback150
description BGP loopback
ip address 10.10.150.1 255.255.255.0
!
interface Loopback151
ip address 10.150.150.1 255.255.255.0
!
!
interface Ethernet0/0
ip address 111.111.111.11 255.255.255.0
ip accounting output-packets
full-duplex
ipx accounting
no keepalive
!
interface Serial0/0
ip address 172.16.0.1 255.255.255.252
ip accounting output-packets
clockrate 128000
!
interface Serial0/1
ip address 172.16.1.1 255.255.255.252
ip accounting output-packets
clockrate 128000
!
interface Serial1/0
ip address 12.10.1.1 255.255.255.252
ip accounting output-packets
clockrate 128000
!
interface Serial1/1
ip address 12.10.2.1 255.255.255.252
ip accounting output-packets
clockrate 128000
router eigrp 10
network 10.0.0.0
network 12.0.0.0
network 111.0.0.0
no auto-summary
eigrp router-id 10.100.150.1
!
router bgp 150
synchronization
bgp router-id 10.10.150.1
bgp log-neighbor-changes
redistribute connected
redistribute eigrp 10 metric 10 route-map Athens
neighbor 172.16.0.2 remote-as 200
neighbor 172.16.1.2 remote-as 100
no auto-summary
logging 11.11.11.11
access-list 11 permit 11.11.11.11
access-list 11 permit 11.11.11.1
!
route-map Athens permit 10
match ip address 11
Expresso__#ping 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Expresso__#sh ip bgp
BGP table version is 23, local router ID is 10.10.150.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.10.100.0/24 172.16.1.2 0 0 100 ?
*> 10.10.150.0/24 0.0.0.0 0 32768 ?
* 10.10.175.0/24 172.16.0.2 0 200 175 ?
*> 172.16.1.2 0 100 175 ?
*> 10.10.200.0/24 172.16.0.2 0 0 200 ?
*> 10.100.100.0/24 172.16.1.2 0 0 100 ?
*> 10.100.150.0/24 0.0.0.0 0 32768 ?
*> 10.100.200.0/24 172.16.0.2 0 0 200 ?
* 10.111.1.0/24 172.16.0.2 0 200 175 ?
*> 172.16.1.2 0 100 175 ?
*> 10.121.150.0/24 172.16.0.2 0 0 200 ?
*> 10.150.150.0/24 0.0.0.0 0 32768 ?
*> 11.11.11.0/24 172.16.1.2 0 0 100 ?
*> 12.10.1.0/30 0.0.0.0 0 32768 ?
*> 12.10.2.0/30 0.0.0.0 0 32768 ?
*> 111.111.111.0/24 0.0.0.0 0 32768 ?
*> 172.16.0.0/30 0.0.0.0 0 32768 ?
Network Next Hop Metric LocPrf Weight Path
* 172.16.0.2 0 0 200 ?
* 172.16.1.0/30 172.16.1.2 0 0 100 ?
*> 0.0.0.0 0 32768 ?
* 172.16.2.0/30 172.16.0.2 0 200 175 ?
*> 172.16.1.2 0 0 100 ?
* 172.16.3.0/30 172.16.1.2 0 100 175 ?
*> 172.16.0.2 0 0 200 ?
Expresso__#
============================================================================
=========================
!
hostname R_2
!
interface Loopback0
ip address 165.4.2.2 255.255.255.0
!
interface Loopback121
description EIGRP router ID
ip address 12.1.1.2 255.255.255.0
!
interface Serial1/0
ip address 12.10.1.2 255.255.255.252
ip accounting output-packets
!
interface Serial1/1
ip address 12.10.2.2 255.255.255.252
ip accounting output-packets
!
router eigrp 10
network 12.0.0.0
no auto-summary
eigrp router-id 12.1.1.2
!
logging 11.11.11.11
R_2#sh ip route eigrp
111.0.0.0/24 is subnetted, 1 subnets
D 111.111.111.0 [90/20514560] via 12.10.2.1, 01:38:06, Serial1/1
[90/20514560] via 12.10.1.1, 01:38:06, Serial1/0
10.0.0.0/24 is subnetted, 3 subnets
D 10.150.150.0 [90/20640000] via 12.10.2.1, 01:38:06, Serial1/1
[90/20640000] via 12.10.1.1, 01:38:06, Serial1/0
D 10.10.150.0 [90/20640000] via 12.10.2.1, 01:38:06, Serial1/1
[90/20640000] via 12.10.1.1, 01:38:06, Serial1/0
D 10.100.150.0 [90/20640000] via 12.10.2.1, 01:38:06, Serial1/1
[90/20640000] via 12.10.1.1, 01:38:06, Serial1/0
R_2#ping 11.11.11.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R_2#
[GroupStudy removed an attachment of type image/jpeg which had a name of Fiesta Bkgrd.jpg]
This archive was generated by hypermail 2.1.4 : Wed Aug 06 2003 - 06:52:24 GMT-3