RE: bgp confederation peer,

From: Jung, Jin (jin.jung@lmco.com)
Date: Thu Jun 19 2003 - 23:55:29 GMT-3


Hi John,,

After looking at your full config,,

You need ebgp-multihop command between r2 and r3,,

Since r1 is the hub router,

R2 and r3 are not directly connected, it has to go thru r1, 2 hops.

I did not test this, but give it a try.

Jin jung...

-----Original Message-----
From: John Matijevic [mailto:matijevi@bellsouth.net]
Sent: Thursday, June 19, 2003 10:10 PM
To: David Cho; ccielab@groupstudy.com
Subject: Re: bgp confederation peer,

OK Here are full configs, I am still having trouble with R3 peering with R2
in a confederation. Thanks again, Matijevic r1#c Building configuration...

Current configuration : 2158 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
service udp-small-servers
service tcp-small-servers
!
hostname r1
!
logging rate-limit console 10 except errors
!
username r4 password 7 13061E010803
clock summer-time est recurring
ip subnet-zero
no ip finger
ip tcp synwait-time 5
no ip domain-lookup
!
frame-relay de-list 1 protocol ip list 25
isdn switch-type basic-ni
cns event-service server
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Ethernet0
 ip address 186.1.1.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0
 ip address 153.1.200.1 255.255.255.0
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 no fair-queue
 frame-relay map ip 153.1.200.2 102 broadcast
 frame-relay map ip 153.1.200.3 103 broadcast
 frame-relay map ip 153.1.200.4 104 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 ip address 153.1.61.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface BRI0
 ip address 153.1.111.133 255.255.255.252
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 shutdown
 dialer map ip 153.1.111.134 name r4 broadcast 4930624 dialer-group 1 isdn
switch-type basic-ni ! router bgp 1000 bgp log-neighbor-changes bgp
confederation identifier 1 bgp confederation peers 1001 network 1.1.1.0
mask 255.255.255.0 neighbor 153.1.200.2 remote-as 10 neighbor 153.1.200.2
send-community neighbor 153.1.200.4 remote-as 1001 neighbor 153.1.200.4
next-hop-self neighbor 153.1.200.4 send-community ! ip kerberos
source-interface any ip classless no ip http server ip as-path access-list 1
permit ^100_[0-9]*$ ! dialer-list 1 protocol ip permit ! alias exec i show
ip route alias exec c show running-config alias exec b show ip int brief
alias exec o show ip ospf alias exec t config t alias exec srb show run |
begin ! line con 0 password 7 070C285F4D06 logging synchronous login
transport input none line aux 0 transport input all line vty 0 4 password
7 13061E010803 login ! end

r1#
comm-server#2
[Resuming connection 2 to r2 ... ]

r2#c
Building configuration...

Current configuration : 1742 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
!
username jill password 0 cisco
username r6 password 0 cisco
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
cns event-service server
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 10.1.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 153.1.200.2 255.255.255.0
 encapsulation frame-relay
 no fair-queue
 frame-relay map ip 153.1.200.1 201 broadcast
 frame-relay map ip 153.1.200.3 201 broadcast
 frame-relay map ip 153.1.200.4 201 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial0/1
 ip address 153.1.25.18 255.255.255.0
!
router bgp 2000
 bgp log-neighbor-changes
 bgp confederation identifier 10
 bgp confederation peers 2001
 network 2.2.2.0 mask 255.255.255.0
 neighbor 153.1.200.1 remote-as 1
 neighbor 153.1.200.1 send-community
 neighbor 153.1.200.3 remote-as 2001
 neighbor 153.1.200.3 next-hop-self
 neighbor 153.1.200.3 send-community
!
ip local pool mypool 153.1.111.134
ip classless
no ip http server
!
!
map-class dialer dial1
 dialer callback-server username
access-list 101 permit icmp any any
dialer-list 1 protocol ip list 101
!
!
alias exec i show ip route
alias exec c show running-config
alias exec o show ip ospf
alias exec t config term
alias exec b show ip int brief
alias exec srb show run | begin
!
line con 0
 password cisco
 logging synchronous
 login
line aux 0
 password cisco
 login
line vty 0 4
 login
!
end

r2#
comm-server#3
[Resuming connection 3 to r3 ... ]

r3#c
Building configuration...

Current configuration : 1610 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r3
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
!
!
key chain ccie
 key 1
  key-string cisco
cns event-service server
!
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0
 ip address 153.1.43.33 255.255.255.128
!
interface Serial0
 ip address 153.1.200.3 255.255.255.0
 encapsulation frame-relay
 no ip mroute-cache
 no fair-queue
 frame-relay map ip 153.1.200.1 301 broadcast
 frame-relay map ip 153.1.200.2 301 broadcast
 frame-relay map ip 153.1.200.4 301 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 ip address 153.1.53.67 255.255.255.128
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-point
!
router bgp 2001
 bgp log-neighbor-changes
 bgp confederation identifier 10
 bgp confederation peers 2000
 network 3.3.3.0 mask 255.255.255.0
 neighbor 153.1.200.2 remote-as 2000
 neighbor 153.1.200.2 send-community
!
ip kerberos source-interface any
ip classless
ip http server
!
!
alias exec b show ip int brief
alias exec o show ip ospf
alias exec t config term
alias exec srb show run | begin
alias exec sri show run | include
alias exec i show ip route
alias exec c show running-config
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 length 42
 transport input none
line aux 0
 privilege level 15
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
 length 42
!
end

r3#
comm-server#4
[Resuming connection 4 to r4 ... ]

r4#c
Building configuration...

Current configuration : 2370 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
logging rate-limit console 10 except errors
!
username admin password 0 cisco
username guest password 0 cisco
username guest autocommand menu guestmenu
username r1 password 0 cisco
ip subnet-zero
no ip finger
ip tcp synwait-time 5
no ip domain-lookup
!
isdn switch-type basic-ni
cns event-service server
!
!
!
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0
 ip address 153.1.43.44 255.255.255.128
!
interface Serial0
 ip address 153.1.200.4 255.255.255.0
 encapsulation frame-relay
 no fair-queue
 frame-relay map ip 153.1.200.1 401 broadcast
 frame-relay map ip 153.1.200.2 401 broadcast
 frame-relay map ip 153.1.200.3 401 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial1
 no ip address
!
interface BRI0
 ip address 153.1.111.134 255.255.255.252
 encapsulation ppp
 ip ospf authentication-key cisco
 ip ospf message-digest-key 1 md5 cisco
 ip ospf cost 9999
 ip ospf demand-circuit
 shutdown
 dialer map ip 153.1.111.133 name r1 broadcast 4930622 dialer-group 1 isdn
switch-type basic-ni isdn spid1 81049306240101 4930624 isdn spid2
81049306250101 4930625 ppp authentication chap ! router bgp 1001 bgp
log-neighbor-changes bgp confederation identifier 1 bgp confederation
peers 1000 network 4.4.4.0 mask 255.255.255.0 neighbor 153.1.200.1
remote-as 1000 neighbor 153.1.200.1 send-community ! ip kerberos
source-interface any ip classless no ip http server ! access-list 8 permit
100.100.8.0 0.0.0.255 dialer-list 1 protocol ip permit ! menu guestmenu text
1 look at the IP interfaces menu guestmenu command 1 show ip interface menu
guestmenu text 2 look at router version info menu guestmenu command 2 show
version menu guestmenu text 3 quit menu guestmenu command 3 quit route-map
noeight deny 10 match ip address 8 ! route-map noeight permit 20 ! ! alias
exec i show ip route alias exec c show running-config alias exec b show ip
int brief alias exec o show ip ospf alias exec t config term alias exec srb
show run | begin alias exec sri show run | include ! line con 0 password
cisco logging synchronous login transport input none line aux 0 line vty
0 4 password cisco login ! end

r4#

----- Original Message -----
From: "David Cho" <David.Cho@interealty.com>
To: "'John Matijevic'" <matijevi@bellsouth.net>; <ccielab@groupstudy.com>
Sent: Thursday, June 19, 2003 9:39 PM
Subject: RE: bgp confederation peer,

> John,
>
> Can you post full configs?
>
> -----Original Message-----
> From: John Matijevic [mailto:matijevi@bellsouth.net]
> Sent: Thursday, June 19, 2003 9:31 PM
> To: David Cho; ccielab@groupstudy.com
> Subject: Re: bgp confederation peer,
>
>
> David,
> Thanks for the response, I can ping between r2 and r3 they are
> directly connected to each other. There is no igp from what I am
> testing right now. Sincerely, Matijevic
>
> ----- Original Message -----
> From: David Cho <mailto:David.Cho@interealty.com>
> To: 'John Matijevic' <mailto:matijevi@bellsouth.net> ;
> ccielab@groupstudy.com <mailto:ccielab@groupstudy.com>
> Sent: Thursday, June 19, 2003 9:27 PM
> Subject: RE: bgp confederation peer,
>
>
> John,
>
> I suggest to check the neighbor addresses between r2 and r3. Is it
directly
> connected? Otherwise, you need update-s interface and ebgp-multi
> commands assuming all your IGPs are fine. David
>
> -----Original Message-----
> From: John Matijevic [ mailto:matijevi@bellsouth.net
> <mailto:matijevi@bellsouth.net> ]
> Sent: Thursday, June 19, 2003 9:17 PM
> To: ccielab@groupstudy.com <mailto:ccielab@groupstudy.com>
> Subject: bgp confederation peer,
>
>
> Hello Team,
> I am configuration confederations running BGP, I can successfully
establish
> a
> peer with R1 and R4, However, I am having trouble establishing a peer
> with R2 and R3, when I look at the sh ip bgp summ, on R3 I see an
> opensent, when I look on R2, I see an openconfirm, and thats where it
> seems to be stuck.
Here
>
> are the configs for R2 and R3, everything looks ok, but who knows
> after studying for 12 hours I may have mistyped something, but I did
> redo the config. and it came up again any Help will be greatly
> appreciated.!!! r2#srb r b router bgp 2000
> bgp log-neighbor-changes
> bgp confederation identifier 10
> bgp confederation peers 2001
> network 2.2.2.0 mask 255.255.255.0
> neighbor 153.1.200.1 remote-as 1
> neighbor 153.1.200.1 send-community
> neighbor 153.1.200.3 remote-as 2001
> neighbor 153.1.200.3 next-hop-self
> neighbor 153.1.200.3 send-community
> !
> ip local pool mypool 153.1.111.134
> ip classless
> no ip http server
> !
> !
> map-class dialer dial1
> dialer callback-server username
> access-list 101 permit icmp any any
> dialer-list 1 protocol ip list 101
> !
> !
> alias exec i show ip route
>
> r2#
> comm-server#3
> [Resuming connection 3 to r3 ... ]
>
> r3#srb r b
> router bgp 2001
> bgp log-neighbor-changes
> bgp confederation identifier 10
> bgp confederation peers 2000
> network 3.3.3.0 mask 255.255.255.0
> neighbor 153.1.200.2 remote-as 2000
> neighbor 153.1.200.2 send-community
> !
> ip kerberos source-interface any
> ip classless
> ip http server
> !
> !
> alias exec b show ip int brief
> alias exec o show ip ospf
> alias exec t config term
> alias exec srb show run | begin
> alias exec sri show run | include
> alias exec i show ip route
> alias exec c show running-config
> !
> line con 0
> exec-timeout 0 0
> privilege level 15
> logging synchronous
> length 42
> transport input none
> line aux 0
> privilege level 15
> line vty 0 4
> exec-timeout 0 0
> privilege level 15
> logging synchronous
> no login
> length 42
> !
> end
>
> r3#
>
> Thanks again,
> Matijevic
>
>
> ______________________________________________________________________
> _
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
> <http://www.groupstudy.com/list/CCIELab.html>
>
>
> ______________________________________________________________________
> _
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Fri Jul 04 2003 - 11:11:02 GMT-3