From: Jeongwoo Park (jpark@wams.com)
Date: Sun Apr 06 2003 - 19:07:37 GMT-3
Thank you all.
I believe this is all about "ping script" or " Autograder"
These tools are designed to ping all the interface including itself and its
spoke routers.
Meanwhile, I asked once in this thread and didn't get this clear.
I am having a converting problem.
R2 -- Hub
R3 -- Spoke
R4 -- Spoke
R2:
interface Serial0/0.234 multipoint
ip address 120.20.234.2 255.255.255.224
ip ospf network point-to-multipoint
frame-relay interface-dlci 203
frame-relay interface-dlci 204
R3:
interface Serial1/0.234 point-to-point
ip address 120.20.234.3 255.255.255.224
ip ospf hello-interval 30
frame-relay interface-dlci 302
R4:
interface Serial1/0
ip address 120.20.234.4 255.255.255.224
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 120.20.234.2 402 broadcast
frame-relay map ip 120.20.234.3 402 broadcast
frame-relay map ip 120.20.234.4 402 broadcast
no frame-relay inverse-arp
Whit this config, I can't ping R4 from R3 and vice versa
However, if I change R2's config to;
interface Serial0/0.234 multipoint
ip address 120.20.234.2 255.255.255.224
ip ospf network point-to-multipoint
frame-relay interface-dlci 203
frame-relay interface-dlci 204
Then I can have R3 and R4 ping each other.
What am I missing?
Thanks guys,
JP
-----Original Message-----
From: DougAtHome [mailto:dcalton@fuse.net]
Sent: Sunday, April 06, 2003 6:09 AM
To: Brian Dennis; 'OhioHondo'; 'ccielab'
Subject: Re: Frame map ip
Thanks - that all makes sense. Broadcast back to the hub for routing
protocol traffic, no broadcast to the other spoke, where we are just
providing spoke to spoke connectivity. With this discussion, I am surprized
that the examples and labs don't generally bring this issue forward, since -
as you say - you are wasting a lot of broadcasts for no purpose.
----- Original Message -----
From: "Brian Dennis" <brian@labforge.com>
To: "'OhioHondo'" <ohiohondo@columbus.rr.com>; "'DougAtHome'"
<dcalton@fuse.net>; "'ccielab'" <ccielab@groupstudy.com>
Sent: Sunday, April 06, 2003 1:47 AM
Subject: RE: Frame map ip
> Why send two broadcast packets when you only need to send one?
>
> What if you have 50 spokes, would you map broadcast for each spoke
> from each spoke? If RIP had 70 networks to advertise, the spoke router
> needs to send 3 packets to the hub. But if you have the 50 other
> mappings with the broadcast keyword you would send 150 packets
> unnecessarily every 30 seconds.
>
> Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> Director of CCIE Training and Development - IPexpert, Inc.
> Mailto: brian@ipexpert.net
> Toll Free: 866.225.8064
> Outside U.S. & Canada: 312.321.6924
>
> -----Original Message-----
> From: OhioHondo [mailto:ohiohondo@columbus.rr.com]
> Sent: Saturday, April 05, 2003 8:33 PM
> To: Brian Dennis; 'DougAtHome'; 'ccielab'
> Subject: RE: Frame map ip
>
> It processes them and puts the best routes in the IP routing table.
> Since both of the RIP updates are from the same router, the RIP
> updates should be
> the same. I don't see a problem with that. As far as RIP is concerned,
> it
> received 2 updates from a neighboring router -- it just didn't wait the
> full
> period between updates.
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> Brian Dennis
> Sent: Saturday, April 05, 2003 9:35 PM
> To: 'DougAtHome'; 'ccielab'
> Subject: RE: Frame map ip
>
>
> Let's same we have this config on a spoke router. One mapping to the
> hub and the other to a second spoke run RIP as the routing protocol.
>
> !
> interface Serial1/0
> ip address 120.20.234.4 255.255.255.224
> encapsulation frame-relay
> frame-relay map ip 120.20.234.2 402 broadcast
> frame-relay map ip 120.20.234.3 402 broadcast
> !
> router rip
> network 120.0.0.0
> !
>
> When RIP has an update to send out the S1/0 interface it sends two of
> them because of the two mappings with the broadcast keyword. Now when
> the hub gets the two broadcast packets what does the hub do with them?
>
> Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> Director of CCIE Training and Development - IPexpert, Inc.
> Mailto: brian@ipexpert.net
> Toll Free: 866.225.8064
> Outside U.S. & Canada: 312.321.6924
>
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> Of DougAtHome
> Sent: Saturday, April 05, 2003 3:23 PM
> To: ccielab
> Subject: Re: Frame map ip
>
> This all surprizes me. Firstly, I would presume that Jeongwoo's
> configuration would NOT work, and that broadcast is required for these
> components. In my labs, after a reboot, the config would definitely
> fail
> without the broadcast - if not immediately, then definitely after
> clearing inarp.
> Secondly, I have never seen samples where spoke to spoke maps eliminated
> the
> "broadcast" keyword. My understanding is that the broadcast first
> allows
> broadcast messages to be sent across the frame network. Secondly, where
> necessary, the router emulates broadcast behavior by sending out
> duplicate
> messages out all dcli's referenced to that subinterface.
> I don't know if I will have time to lab this out (my first attempt for
> the
> lab is now 3 weeks away), but would be interested in some
> clarification/explanation. Thanks!
>
> -----Original Message-----
> From: Jeongwoo Park [mailto:jpark@wams.com]
> Sent: Saturday, April 05, 2003 4:51 PM
> To: 'ccielab@groupstudy.com'
> Cc: 'Brian Dennis'
> Subject: RE: Frame map ip
>
>
> Thanks a lot for clarifying this.
>
> Now I am converting this;
> R2:Hub router
> interface Serial0/0.234 multipoint
> ip address 120.20.234.2 255.255.255.224
> ip ospf network point-to-multipoint
> frame-relay map ip 120.20.234.3 203 broadcast
> frame-relay map ip 120.20.234.4 204 broadcast
>
> To;
> R2
> its answer;
> interface Serial0/0.234 multipoint
> ip address 120.20.234.2 255.255.255.224
> ip ospf network point-to-multipoint
> frame-relay interface-dlci 203
> frame-relay interface-dlci 204
>
> I am not getting different result.
> R2#frame map
> Serial0/0.234 (up): ip 120.20.234.4 dlci 204(0xCC,0x30C0), dynamic,
> broadcast,, status defined, active R2#
>
> I get only one map result. Shouldn't I get two of this?
>
> R4:Spoke Router
> interface Serial1/0
> ip address 120.20.234.4 255.255.255.224
> encapsulation frame-relay
> ip ospf network point-to-multipoint
> frame-relay map ip 120.20.234.2 402 broadcast
> frame-relay map ip 120.20.234.3 402 broadcast
>
> R3:Spoke Router
> interface Serial1/0.234 point-to-point
> ip address 120.20.234.3 255.255.255.224
> ip ospf hello-interval 30
> frame-relay interface-dlci 302
>
>
>
> -----Original Message-----
> From: Brian Dennis [mailto:brian@labforge.com]
> Sent: Saturday, April 05, 2003 12:36 PM
> To: 'Jeongwoo Park'; ccielab@groupstudy.com
> Subject: RE: Frame map ip
>
>
> Maybe there was a requirement to enable the router to ping itself.
>
> As a side note the broadcast keyword isn't needed and is actually
> causing duplicate broadcast packets to be sent to "120.20.234.3". When
> spokes map to
> other spokes the broadcast keyword is useless because to hub will absorb
> the
> broadcast.
>
> Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> Director of CCIE Training and Development - IPexpert, Inc.
> Mailto: brian@ipexpert.net
> Toll Free: 866.225.8064
> Outside U.S. & Canada: 312.321.6924
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> Of Jeongwoo Park
> Sent: Saturday, April 05, 2003 11:48 AM
> To: 'ccielab@groupstudy.com'
> Subject: Frame map ip
>
> Hi all.
> I am doing ccie practice lab scinerio. I found a interesting answer
> about frame relay map.
>
> its answer;
> interface Serial0/0.234 multipoint
> ip address 120.20.234.2 255.255.255.224
> ip ospf network point-to-multipoint
> frame-relay map ip 120.20.234.2 203 broadcast
> frame-relay map ip 120.20.234.3 203 broadcast
> frame-relay map ip 120.20.234.4 204 broadcast
>
> As you can see, why would you want to have map frame to your own
> interface ip address? Can anyone of you explain this?
>
> Thanks a lot,
>
> JP
This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:35:47 GMT-3