Redistribution problem

From: KHAN, IFTIKHAR A (IKHAN@scana.com)
Date: Thu Dec 12 2002 - 22:42:53 GMT-3


I have following scenario

     L0 ---- R1 s0-------------s0 R2 E0---------
     L1 ------|

Here are my configs

!
hostname R1
!
enable password ccie
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 155.100.16.129 255.255.255.128
!
interface Loopback1
 ip address 155.100.17.1 255.255.255.0
!
interface Ethernet0
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface Serial0
 ip address 155.100.4.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 no fair-queue
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
router ospf 1
 log-adjacency-changes
 redistribute igrp 100 subnets
 network 155.100.17.0 0.0.0.255 area 0
!
router igrp 100
 redistribute connected
 redistribute static
 redistribute ospf 1
 network 155.100.0.0
 default-metric 10000 1000 255 1 1500
!

on R2

interface Loopback0
 ip address 10.1.1.1 255.0.0.0
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 ip address 155.100.4.2 255.255.255.0
 no fair-queue
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
router igrp 100
 network 10.0.0.0
 network 155.100.0.0
!

some how R2 is not able to see 155.100.16.128 subnet from R1 I am not sure
why OSPF is not redistributing this subnet into IGRP

R2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     155.100.0.0/24 is subnetted, 2 subnets
I 155.100.17.0 [100/8976] via 155.100.4.1, 00:00:51, Serial0
C 155.100.4.0 is directly connected, Serial0
     172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, Ethernet0
C 10.0.0.0/8 is directly connected, Loopback0

any ideas

thanks
Iftikhar
.



This archive was generated by hypermail 2.1.4 : Fri Jan 17 2003 - 17:21:44 GMT-3