Redist Problem ospf igrp rip

From: Charles T. Alexander (ctalex405@yahoo.com)
Date: Sat Nov 30 2002 - 18:02:12 GMT-3


r2 &
r3---x.25--r4--ethernet--r5
ospf ospf igrp
          igrp rip

r5 can ping r4, r3, r2
r4 can ping r2, r3, r5
r2&r3 can ping r4
r3&r2 can't ping r5

I think I am missing some concept.

Below are the configs for r3,r4,r5

r3#r
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r3
!
logging buffered 10000 debugging
enable password radnor
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
lane client flush
cns event-service server
!
!
!
!
!
interface Loopback0
 ip address 135.1.13.3 255.255.255.0
 ip ospf network point-to-point
!
interface Tunnel0
 ip address 135.1.101.3 255.255.255.0
 tunnel source 135.1.20.3
 tunnel destination 135.1.20.2
!
interface BRI0/0
 no ip address
 shutdown
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface TokenRing0/0
 ip address 135.1.3.3 255.255.255.240
 ring-speed 16
!
interface Serial1/0
 bandwidth 64
 ip address 135.1.20.3 255.255.252.0
 encapsulation x25
 ip ospf network point-to-multipoint
 x25 address 3333
 x25 map ip 135.1.20.2 2222 broadcast
 x25 map ip 135.1.20.4 4444 broadcast
!
interface Serial1/1
 no ip address
 shutdown
 clockrate 2015232
!
interface Serial1/2
 no ip address
 shutdown
 clockrate 2015232
!
interface Serial1/3
 no ip address
 shutdown
!
router ospf 11
 area 0 range 135.1.3.0 255.255.255.0
 network 135.1.3.0 0.0.0.15 area 0
 network 135.1.13.0 0.0.0.255 area 0
 network 135.1.20.0 0.0.3.255 area 4
 network 135.1.101.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 escape-character 27
line aux 0
line vty 0 4
 password bp
 login
!
end

-------------------
r4#r
Building configuration...

Current configuration : 1297 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
logging buffered 10000 debugging
enable password radnor
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 135.1.14.4 255.255.255.0
!
interface Ethernet0
 bandwidth 1500
 ip address 135.1.1.4 255.255.255.0
!
interface Serial0
 bandwidth 64
 ip address 135.1.20.4 255.255.252.0
 encapsulation x25
 ip ospf network point-to-multipoint
 x25 address 4444
 x25 map ip 135.1.20.3 3333 broadcast
 x25 map ip 135.1.20.2 2222 broadcast
!
interface Serial1
 no ip address
 shutdown
!
interface TokenRing0
 no ip address
 shutdown
!
router ospf 11
 log-adjacency-changes
 summary-address 135.1.20.0 255.255.255.0
 redistribute igrp 11 subnets
 network 135.1.20.0 0.0.3.255 area 4
!
router igrp 11
 redistribute ospf 11
 passive-interface Serial0
 network 135.1.0.0
 default-metric 64 10 254 1 1500
!
ip classless
ip http server
ip pim bidir-enable
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line aux 0
line vty 0 4
 password bp
 login
!
end

r4
---------------------------------------------------
r5#r
Building configuration...

Current configuration : 1231 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
logging buffered 10000 debugging
enable password radnor
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 135.1.15.5 255.255.255.0
!
interface Loopback1
 ip address 12.1.1.1 255.255.255.0
!
interface Ethernet0
 ip address 135.1.1.5 255.255.255.0
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 no ip address
 shutdown
!
router rip
 redistribute igrp 11
 passive-interface Ethernet0
 passive-interface Loopback0
 network 12.0.0.0
 default-metric 1
!
router igrp 11
 redistribute rip
 passive-interface Loopback1
 network 135.1.0.0
 default-metric 64 10 254 1 1500
 distribute-list 1 out
!
ip classless
ip http server
ip pim bidir-enable
!
access-list 1 permit 135.1.15.0 0.0.0.255
access-list 1 permit 12.0.0.0 0.255.255.255
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line 1 8
 flush-at-activation
line aux 0
line vty 0 4
 password bp
 login
!
end



This archive was generated by hypermail 2.1.4 : Tue Dec 03 2002 - 07:23:13 GMT-3