RE: BGP update-source

From: Jason Sinclair (sinclairj@xxxxxxxxxxxxxxx)
Date: Thu May 02 2002 - 21:44:06 GMT-3


   
Peter,

When you use the update source command the router uses that as the interface
the remote router needs to peer with. What you are doing wrong is that you
need to change on router B the neighbor statement to the IP address of the
router A's loopback NOT it's serial interface. You will also need a route to
the loopback. What you are doing is telling router A to use 40.40.40.4 as
its update source and then trying to peer with 10.1.1.4. This will not work.
I have put the configs as they need to be below. If you do a debug ip bgp
with your config you will see the errors.

Router A
interface Loopback0
ip address 40.40.40.4 255.255.255.0
no ip directed-broadcast

interface Serial0
ip address 10.1.1.4 255.255.255.0
no ip directed-broadcast

ip route 10.10.10.1 255.255.255.0 10.1.1.1
router bgp 50
neighbor 10.10.10.1 remote-as 50
neighbor 10.10.10.1 update-source Loopback0
no auto-summary

Router B
interface Loopback0
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast

interface Serial0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast

ip route 40.40.40.4 255.255.255.0 10.1.1.4

router bgp 50
neighbor 40.40.40.4 remote-as 50
neighbor 40.40.40.4 update-source Loopback0
no auto-summary

Regards,

Jason Sinclair CCIE #9100
Manager, Network Control Centre
POWERTEL
Ground Level, 55 Clarence Street,
SYDNEY NSW 2000
AUSTRALIA
office: + 61 2 8264 3820
mobile: + 61 416 105 858
* sinclairj@powertel.com.au

                -----Original Message-----
                From: peter brown [mailto:pita40@hotmail.com]
                Sent: Friday, 3 May 2002 10:38
                To: sinclairj@powertel.com.au
                Subject: RE: BGP update-source

                The config is attached below. The update-source is just
suppode to tell your
                nei that the loop is used for update and not the physical
int. Check my
                config below.

>From: Jason Sinclair <sinclairj@powertel.com.au>
>To: 'peter brown' <pita40@hotmail.com>,
ccielab@groupstudy.com
>Subject: RE: BGP update-source
>Date: Fri, 3 May 2002 10:32:47 +1000
>
>Peter,
>
>Are you changing your remote peer statement to the loopback
IP address when
>you use the loops as the update source?
>
>Regards,
>
>Jason Sinclair CCIE #9100
>Manager, Network Control Centre
>POWERTEL
>Ground Level, 55 Clarence Street,
>SYDNEY NSW 2000
>AUSTRALIA
>office: + 61 2 8264 3820
>mobile: + 61 416 105 858
>* sinclairj@powertel.com.au
>
>
>
>
> -----Original Message-----
> From: peter brown
[mailto:pita40@hotmail.com]
> Sent: Friday, 3 May 2002 10:01
> To: ccielab@groupstudy.com
> Subject: BGP update-source
>
> Hello,
>
> I notice that when I use nei x.x.x.x
update-source lo0 on
>both side of ibgp
> nei that are directly connected they loose
tcp connection
>with each other.
> When I remove update-source statement from
one nei and use
>the physical int.
> they are able to establish tcp connection.
Why is this the
>case. Are you
> only suppose to use it only on side between
two nei. Below
>is the config.
>
> Router A
> interface Loopback0
> ip address 40.40.40.4 255.255.255.0
> no ip directed-broadcast
>
> interface Serial0
> ip address 10.1.1.4 255.255.255.0
> no ip directed-broadcast
>
> router bgp 50
> neighbor 10.1.1.1 remote-as 50
> neighbor 10.1.1.1 update-source Loopback0
> no auto-summary
>
>
> Router Binterface Loopback0
> ip address 10.10.10.1 255.255.255.0
> no ip directed-broadcast
>
> interface Serial0
> ip address 10.1.1.1 255.255.255.0
> no ip directed-broadcast
>
> router bgp 50
> neighbor 10.1.1.4 remote-as 50
> neighbor 10.1.1.4 update-source Loopback0
> no auto-summary
> no ip mroute-cache
>
>
>
>
>
>
>
>
        



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:49 GMT-3