Re: BGP Configuration Question (Very Long)

From: Gregg Malcolm (greggm@xxxxxxxxxxxxx)
Date: Thu Apr 11 2002 - 02:41:59 GMT-3


   
Here they are. You'll notice that they also run OSPF, but I've tried to
clean up admin dist problems where I had them :

r6#wrt

!
interface Ethernet0
 ip address 150.20.50.6 255.255.255.192
 no ip route-cache
 ip ospf authentication message-digest
 ip ospf authentication-key cisco
 no ip mroute-cache
 ipx network 50
 ipx nlsp enable
 ipx nlsp rip off
 ipx nlsp sap off
!
interface Serial0
 ip address 150.20.100.6 255.255.255.224
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0
 ipx network 100
 ipx output-network-filter 801
 no fair-queue
 clockrate 2000000
 dce-terminal-timing-enable
 frame-relay map ipx 100.0010.7b7f.5b9a 601 broadcast
 frame-relay map ipx 100.0060.476c.3e3c 601 broadcast
 frame-relay map ip 150.20.100.2 601 broadcast
 frame-relay map ip 150.20.100.4 601 broadcast
 frame-relay map ip 150.20.100.5 601 broadcast
 frame-relay map ipx 100.0000.0c87.05ca 601 broadcast
 frame-relay lmi-type ansi

!
interface Serial1
 ip address 150.20.69.6 255.255.255.0
 ipx network 69
 ipx hello-interval eigrp 1 10
 clockrate 2000000
 dce-terminal-timing-enable
!
router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
 area 1 virtual-link 2.2.2.2 authentication message-digest
authentication-key co
 network 150.20.50.0 0.0.0.63 area 0
 network 150.20.69.0 0.0.0.255 area 5
 network 150.20.100.0 0.0.0.31 area 1
!
router bgp 65256
 no synchronization
 bgp always-compare-med
 bgp log-neighbor-changes
 bgp confederation identifier 2456
 bgp confederation peers 65255
 bgp deterministic-med
 network 150.20.50.0 mask 255.255.255.192
 redistribute connected route-map conn
 neighbor 150.20.50.5 remote-as 65256
 neighbor 150.20.50.5 ebgp-multihop 4
 neighbor 150.20.50.7 remote-as 79
 neighbor 150.20.100.2 remote-as 65255
 no auto-summary

Gateway of last resort is not set

     150.10.0.0/32 is subnetted, 1 subnets
C 150.10.6.6 is directly connected, Loopback0
     150.20.0.0/16 is variably subnetted, 12 subnets, 3 masks
B 150.20.10.0/24 [200/0] via 150.20.50.5, 02:38:28
O IA 150.20.12.0/24 [110/128] via 150.20.100.2, 02:38:49, Serial0
B 150.20.20.0/24 [200/0] via 150.20.50.5, 02:38:27
B 150.20.40.0/24 [200/0] via 150.20.50.5, 02:38:27
C 150.20.50.0/26 is directly connected, Ethernet0
C 150.20.60.0/24 is directly connected, Loopback60
B 150.20.70.0/24 [20/0] via 150.20.50.7, 01:01:27
C 150.20.69.0/24 is directly connected, Serial1
O IA 150.20.78.0/24 [110/74] via 150.20.50.7, 02:38:49, Ethernet0
B 150.20.80.0/24 [20/0] via 150.20.50.7, 01:01:57
B 150.20.90.0/24 [20/0] via 150.20.50.7, 01:01:59
C 150.20.100.0/27 is directly connected, Serial0

r6#sb
BGP table version is 40, local router ID is 150.20.60.6
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*>i150.20.10.0/24 150.20.50.5 0 100 0 (65255) 1 ?
* 150.20.12.1 1000 100 0 (65255) 1 ?
*>i150.20.20.0/24 150.20.50.5 0 100 0 (65255) ?
*>i150.20.40.0/24 150.20.50.5 0 100 0 (65255) ?
* 150.20.50.0/26 150.20.50.7 0 0 79 i
* i 150.20.50.5 0 100 0 ?
*> 0.0.0.0 0 32768 i
*> 150.20.60.0/24 0.0.0.0 0 32768 ?
* i150.20.70.0/24 150.20.50.5 0 100 0 79 ?
*> 150.20.50.7 0 0 79 ?
*> 150.20.80.0/24 150.20.50.7 0 79 8 ?
* i 150.20.50.5 100 0 79 8 ?
* i150.20.90.0/24 150.20.50.5 100 0 79 ?
*> 150.20.50.7 0 79 ?

R7

User Access Verification

Password:
r7#wrt

!
hostname r7
!
!
interface Loopback70
 ip address 150.20.70.7 255.255.255.0
!
interface Loopback77
 ip address 150.50.77.7 255.255.255.128
!
interface Ethernet0
 ip address 150.20.50.7 255.255.255.192
 no ip mroute-cache
 no ip route-cache
 ip ospf authentication-key cisco
 ip ospf priority 0
 ipx network 50
 ipx nlsp enable
 ipx nlsp rip off
 ipx nlsp sap off
!
interface Ethernet1
 ip address 192.168.0.250 255.255.255.0
 bridge-group 1
!

interface Serial3
 ip address 150.20.78.7 255.255.255.0
 no ip mroute-cache
 no ip route-cache
 ipx network 78

!
router ospf 1
 network 150.20.50.0 0.0.0.63 area 0
 network 150.20.78.0 0.0.0.255 area 4
 distance 220 0.0.0.0 255.255.255.255 77
 area 0 authentication message-digest
!
router bgp 79
 no synchronization
 bgp always-compare-med
 network 150.20.50.0 mask 255.255.255.192
 redistribute connected route-map conn
 neighbor 150.20.50.5 remote-as 2456
 neighbor 150.20.50.5 route-map SET_LOCAL in
 neighbor 150.20.50.6 remote-as 2456
 neighbor 150.20.69.9 remote-as 79
 neighbor 150.20.69.9 ebgp-multihop 5
 neighbor 150.20.69.9 next-hop-self
 neighbor 150.20.78.8 remote-as 8
 no auto-summary
!
ip host r5 150.20.50.5
ip host r6 150.20.50.6
ip host r8 150.20.78.8
access-list 7 permit 150.20.70.0 0.0.0.255
access-list 10 permit 150.20.10.0 0.0.0.255
access-list 77 permit any
smt-queue-threshold 0
route-map conn permit 10
 match ip address 7
!
route-map SET_LOCAL permit 10
 match ip address 10
 set local-preference 777
!
route-map SET_LOCAL permit 20
!

Gateway of last resort is not set

C 192.168.0.0 is directly connected, Ethernet1
     150.20.0.0 is variably subnetted, 12 subnets, 3 masks
B 150.20.10.0 255.255.255.0 [20/0] via 150.20.50.5, 01:06:22
O IA 150.20.12.0 255.255.255.0
           [220/138] via 150.20.50.6, 02:43:21, Ethernet0
           [220/138] via 150.20.50.5, 02:43:21, Ethernet0
B 150.20.20.0 255.255.255.0 [20/0] via 150.20.50.5, 01:06:22
B 150.20.40.0 255.255.255.0 [20/0] via 150.20.50.5, 01:06:22
C 150.20.50.0 255.255.255.192 is directly connected, Ethernet0
B 150.20.60.0 255.255.255.0 [20/0] via 150.20.50.6, 01:06:22
C 150.20.70.0 255.255.255.0 is directly connected, Loopback70
O IA 150.20.69.0 255.255.255.0
           [220/74] via 150.20.50.6, 02:43:21, Ethernet0
C 150.20.78.0 255.255.255.0 is directly connected, Serial3
B 150.20.80.0 255.255.255.0 [20/0] via 150.20.78.8, 01:06:21
B 150.20.90.0 255.255.255.0 [200/0] via 150.20.69.9, 01:06:31
O IA 150.20.100.0 255.255.255.224
           [220/74] via 150.20.50.5, 02:43:22, Ethernet0
           [220/74] via 150.20.50.6, 02:43:22, Ethernet0
     150.10.0.0 255.255.255.255 is subnetted, 1 subnets
C 150.10.7.7 is directly connected, Loopback0
     150.50.0.0 255.255.255.128 is subnetted, 1 subnets
C 150.50.77.0 is directly connected, Loopback77

r7#sb
BGP table version is 10, local router ID is 150.50.77.7
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*> 150.20.10.0/24 150.20.50.5 777 0 2456 1 ?
* 150.20.50.5 0 2456 1 ?
*> 150.20.20.0/24 150.20.50.5 777 0 2456 ?
* 150.20.50.5 0 2456 ?
*> 150.20.40.0/24 150.20.50.5 777 0 2456 ?
* 150.20.50.5 0 2456 ?
* 150.20.50.0/26 150.20.50.5 0 777 0 2456 ?
* 150.20.50.6 0 0 2456 i
*> 0.0.0.0 0 32768 i
*> 150.20.60.0/24 150.20.50.6 777 0 2456 ?
* 150.20.50.6 0 0 2456 ?
*> 150.20.70.0/24 0.0.0.0 0 32768 ?
*> 150.20.80.0/24 150.20.78.8 0 0 8 ?
*>i150.20.90.0/24 150.20.69.9 0 100 0 ?

R9

!
interface Ethernet0
 ip address 150.50.6.209 255.255.255.128
 media-type 10BaseT
 bridge-group 4
 bridge-group 4 spanning-disabled
!
interface Serial0
 no ip address
 no fair-queue
!
interface Serial1
 ip address 150.20.69.9 255.255.255.0
 ipx input-sap-filter 1001
 ipx network 69
 ipx hello-interval eigrp 1 10
!
interface TokenRing0
 ip address 150.20.90.9 255.255.255.0
 ipx network 90
 ring-speed 16
 multiring all
 source-bridge 2 1 15
!
interface BVI4
 no ip address
!
router ospf 1
 log-adjacency-changes
 network 150.20.69.0 0.0.0.255 area 5
 distance 220 0.0.0.0 255.255.255.255 22
!

!
router bgp 79
 no synchronization
 bgp log-neighbor-changes
 redistribute connected route-map conn
 neighbor 150.20.50.7 remote-as 79
 neighbor 150.20.50.7 ebgp-multihop 5
 no auto-summary
!
ip classless
no ip http server
!

access-list 22 permit any
access-list 1001 deny FFFFFFFF 4 R2
access-list 1001 permit FFFFFFFF 0
!
!
ipx router eigrp 1
 network 69

route-map conn permit 10
 match ip address 1
!
route-map test permit 10
!

Gateway of last resort is not set

     150.10.0.0/32 is subnetted, 1 subnets
C 150.10.9.9 is directly connected, Loopback0
     150.20.0.0/16 is variably subnetted, 12 subnets, 3 masks
B 150.20.10.0/24 [200/0] via 150.20.50.7, 00:00:46
O IA 150.20.12.0/24 [220/192] via 150.20.69.6, 02:44:02, Serial1
B 150.20.20.0/24 [200/0] via 150.20.50.7, 00:00:46
B 150.20.40.0/24 [200/0] via 150.20.50.7, 00:00:46
B 150.20.50.0/26 [200/0] via 150.20.50.7, 00:00:46
B 150.20.60.0/24 [200/0] via 150.20.50.7, 00:00:46
B 150.20.70.0/24 [200/0] via 150.20.50.7, 00:00:46
C 150.20.69.0/24 is directly connected, Serial1
O IA 150.20.78.0/24 [220/138] via 150.20.69.6, 02:44:32, Serial1
B 150.20.80.0/24 [200/0] via 150.20.50.7, 00:00:46
C 150.20.90.0/24 is directly connected, TokenRing0
O IA 150.20.100.0/27 [220/128] via 150.20.69.6, 02:44:23, Serial1

r9#sb
BGP table version is 1150, local router ID is 150.10.9.9
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
* i150.20.10.0/24 150.20.50.7 777 0 2456 1 ?
* i150.20.20.0/24 150.20.50.7 777 0 2456 ?
* i150.20.40.0/24 150.20.50.7 777 0 2456 ?
* i150.20.50.0/26 150.20.50.7 0 100 0 i
* i150.20.60.0/24 150.20.50.7 777 0 2456 ?
* i150.20.70.0/24 150.20.50.7 0 100 0 ?
* i150.20.80.0/24 150.20.50.7 0 100 0 8 ?
*> 150.20.90.0/24 0.0.0.0 0 32768 ?

----- Original Message -----
From: "Manny Gonzalez" <manny@nyp.org>
To: "Gregg Malcolm" <greggm@sbcglobal.net>
Cc: <ccielab@groupstudy.com>
Sent: Wednesday, April 10, 2002 10:18 PM
Subject: Re: BGP Configuration Question

> Where is the connected network entry for R7?
>
> Can you furnish complete routing tables/configs? Understand that iBGP
> behaves like a Distance Vector protocol...
>



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:05 GMT-3