ospf into igrp another router in scenario

From: jim.phillipo@xxxxxxxxxxxx
Date: Fri Feb 22 2002 - 16:06:26 GMT-3


   
This router is connected to rtr6 via ethernet.
rtr14-E0---->E0rtr6S0------>S0rtr8

It has a 10.1.11.x/24 interface on it.

This is not showing up on rtr6 as /24 ? Just the /32 routes ?

!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname rtr14
!
enable password cisco
!
!
!
!
!
ip subnet-zero
!
cns event-service server
!
!
!
!
!
voice-port 3/0/0
!
voice-port 3/0/1
!
voice-port 3/1/0
!
voice-port 3/1/1
!
!
!
!
interface Loopback0
 ip address 15.15.14.14 255.255.255.0
 ip router isis
!
interface Ethernet0/0
 ip address 10.1.5.4 255.255.255.248
 ip irdp
 ip irdp preference 1000
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial0/0.1 multipoint
 ip address 10.1.11.14 255.255.255.0
 ip ospf network point-to-multipoint
 frame-relay interface-dlci 101
 frame-relay interface-dlci 102
!
interface Serial0/0.2 point-to-point
 ip address 10.1.12.193 255.255.255.240
 ip router isis
 frame-relay interface-dlci 100
!
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ATM2/0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
router ospf 1
 log-adjacency-changes
 redistribute connected metric 100 subnets
 redistribute isis
 network 10.1.5.4 0.0.0.0 area 10
 network 10.1.11.14 0.0.0.0 area 0
!
router isis
 redistribute ospf 1 metric 32
 net 49.0001.0000.0000.0014.00
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

rtr14#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O IA 200.200.200.0/24 [110/112] via 10.1.11.1, 00:47:25, Serial0/0.1
     10.0.0.0/8 is variably subnetted, 5 subnets, 4 masks
C 10.1.11.0/24 is directly connected, Serial0/0.1
O E2 10.1.10.0/24 [110/20] via 10.1.5.2, 00:47:25, Ethernet0/0
O 10.1.11.1/32 [110/48] via 10.1.11.1, 01:32:52, Serial0/0.1
C 10.1.5.0/29 is directly connected, Ethernet0/0
C 10.1.12.192/28 is directly connected, Serial0/0.2
     15.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O 15.15.6.6/32 [110/11] via 10.1.5.2, 00:47:26, Ethernet0/0
O 15.15.9.9/32 [110/11] via 10.1.5.3, 00:47:26, Ethernet0/0
O 15.15.4.4/32 [110/11] via 10.1.5.1, 00:47:26, Ethernet0/0
O IA 15.15.2.2/32 [110/113] via 10.1.11.1, 00:47:26, Serial0/0.1
O 15.15.1.1/32 [110/49] via 10.1.11.1, 01:32:53, Serial0/0.1
i L1 15.15.5.0/24 [115/20] via 10.1.12.194, Serial0/0.2
C 15.15.14.0/24 is directly connected, Loopback0
rtr14#

tr8#sho run
Building configuration...

Current configuration : 741 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname rtr8
!
enable password cisco
!
!
!
!
!
ip subnet-zero
!
cns event-service server
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 15.15.8.8 255.255.255.0
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Serial0/0
 ip address 10.1.10.8 255.255.255.0
 clockrate 2000000
!
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface ATM2/0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
router igrp 1
 network 10.0.0.0
 network 15.0.0.0
!
ip classless
ip default-network 200.200.200.0
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

rtr8#sho ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M
- mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA -
OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
external type 2
       E1 - OSPF external type 1, E2 - OSPF external
type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static
route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.1.10.6 to network
200.200.200.0

I* 200.200.200.0/24 [100/6982] via 10.1.10.6,
00:01:03, Serial0/0
     10.0.0.0/24 is subnetted, 1 subnets
C 10.1.10.0 is directly connected, Serial0/0
     15.0.0.0/24 is subnetted, 1 subnets
C 15.15.8.0 is directly connected, Loopback0
rtr8#

hostname rtr6
!
enable password cisco
!
!
interface Loopback0
 ip address 15.15.6.6 255.255.255.0
!
interface Ethernet0
 ip address 10.1.5.2 255.255.255.248
 ip irdp
 ip irdp preference 500
!
interface Serial0
 ip address 10.1.10.6 255.255.255.0
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router ospf 1
 redistribute igrp 1 metric 20 subnets
 network 15.15.6.6 0.0.0.0 area 10
 network 10.1.5.2 0.0.0.0 area 10
!
router igrp 1
 redistribute ospf 1 metric 10000 100 255 1 1500
 network 10.0.0.0
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

rtr6#sho ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M
- mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA -
OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
external type 2
       E1 - OSPF external type 1, E2 - OSPF external
type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 5 subnets, 4
masks
O IA 10.1.11.1/32 [110/58] via 10.1.5.4, 00:02:30,
Ethernet0
C 10.1.10.0/24 is directly connected, Serial0
O IA 10.1.11.14/32 [110/10] via 10.1.5.4, 00:02:30,
Ethernet0
C 10.1.5.0/29 is directly connected, Ethernet0
O E2 10.1.12.192/28 [110/100] via 10.1.5.4,
00:02:30, Ethernet0
     15.0.0.0/8 is variably subnetted, 6 subnets, 2
masks
O IA 15.15.2.2/32 [110/123] via 10.1.5.4, 00:02:30,
Ethernet0
O IA 15.15.1.1/32 [110/59] via 10.1.5.4, 00:02:30,
Ethernet0
O 15.15.9.9/32 [110/11] via 10.1.5.3, 00:02:30,
Ethernet0
O 15.15.4.4/32 [110/11] via 10.1.5.1, 00:02:31,
Ethernet0
C 15.15.6.0/24 is directly connected, Loopback0
O E2 15.15.14.0/24 [110/100] via 10.1.5.4,
00:02:31, Ethernet0
O IA 200.200.200.0/24 [110/122] via 10.1.5.4,
00:02:31, Ethernet0
rtr6#



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:30 GMT-3