RE: Dialer Watch

From: Jeremy Laurenson \(Cisco\) (jlaurens@xxxxxxxxx)
Date: Sat Feb 16 2002 - 19:08:32 GMT-3


   
R3 dials R5 on route to 222.222.222.5 going away

jlaurensR3#wr t
Building configuration...

Current configuration : 3184 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname jlaurensR3
!
enable secret 5 $1$tVeb$SdBkOiRwR.IOvdml6idoT0
!
username EAST password 0 cisco
username all
username jlaurensR5 password 0 cisco
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
!
!
!
!
interface Loopback22
 ip address 222.222.222.3 255.255.255.255
!
interface Ethernet0
 ip address 192.168.201.3 255.255.254.0
 ip ospf priority 0
 media-type 10BaseT
!
interface Ethernet1
 no ip address
 shutdown
 media-type 10BaseT
!
interface Serial0
 ip address 172.16.34.3 255.255.255.192
 encapsulation ppp
 no fair-queue
 ppp authentication chap
 ppp chap hostname HQ
 ppp chap refuse
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 56259272540101 5927254
 isdn spid2 56259272550101 5927255
 ppp authentication chap
!
interface BRI1
 no ip address
 shutdown
 isdn switch-type basic-ni
!
interface BRI2
 no ip address
 shutdown
 isdn switch-type basic-ni
!
interface BRI3
 no ip address
 shutdown
 isdn switch-type basic-ni
!
interface BRI4
 no ip address
 shutdown
 isdn switch-type basic-ni
!
interface BRI5
 no ip address
 shutdown
 isdn switch-type basic-ni
!
interface BRI6
 no ip address
 shutdown
 isdn switch-type basic-ni
!
interface BRI7
 no ip address
 shutdown
 isdn switch-type basic-ni
!
interface Dialer0
 ip address 172.16.35.3 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 30
 dialer string 5625927256
 dialer caller 5625927256
 dialer watch-group 1
 dialer-group 1
 ppp authentication chap
!
router eigrp 1
 redistribute ospf 1 route-map ONLYDEFAULT
 network 172.16.35.0 0.0.0.255
 default-metric 512 1000 255 128 1500
 distance eigrp 111 111
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 log-adjacency-changes
 redistribute rip metric-type 1 subnets route-map RIP-TO-OSPF
 redistribute eigrp 1 subnets route-map FROMBACKUP
 network 192.168.201.3 0.0.0.0 area 236
 network 222.222.222.3 0.0.0.0 area 236
!
router rip
 redistribute ospf 1 metric 3
 passive-interface BRI0
 passive-interface Dialer0
 passive-interface Ethernet0
 passive-interface Serial1
 network 172.16.0.0
 distribute-list 1 out Serial0
 no auto-summary
!
ip classless
no ip http server
!
access-list 1 deny 172.16.34.0 0.0.0.255
access-list 1 permit any
access-list 2 permit any
access-list 10 permit 0.0.0.0
access-list 20 permit 222.222.222.0 0.0.0.255
access-list 20 permit 172.16.35.0 0.0.0.255
access-list 100 deny eigrp any any
access-list 100 permit ip any any
dialer watch-list 1 ip 222.222.222.5 255.255.255.255
dialer-list 1 protocol ip list 100
route-map FROMBACKUP permit 10
 match ip address 20
!
route-map OSPF-TO-RIP permit 10
 match ip address 1
!
route-map RIP-TO-OSPF permit 10
 match ip address 2
!
route-map ONLYDEFAULT permit 10
 match ip address 10
!
!
alias exec ship show ip route
alias exec clip clear ip route *
alias exec ospfn show ip ospf neigh
alias exec ipin show ip int brief
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

jlaurensR5#wr t
Building configuration...

Current configuration : 1720 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname jlaurensR5
!
enable secret 5 $1$ABmB$qaU36lXE/1E6nWmruMKOt1
!
username jlaurensR3 password 0 cisco
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
!
!
!
interface Loopback22
 ip address 222.222.222.5 255.255.255.255
!
interface Ethernet0/0
 no ip address
!
interface Serial0/0
 ip address 172.16.125.5 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 frame-relay map ip 172.16.125.1 101 broadcast
 frame-relay map ip 172.16.125.2 101 broadcast
 frame-relay lmi-type cisco
!
interface BRI0/0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 56259272560101 5927256
 isdn spid2 56259272570101 5927257
 ppp authentication chap
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Dialer0
 ip address 172.16.35.5 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer remote-name jlaurensR3
 dialer-group 1
 ppp authentication chap
!
router eigrp 1
 network 172.16.35.0 0.0.0.255
 network 222.222.222.5 0.0.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 log-adjacency-changes
 network 172.16.125.5 0.0.0.0 area 0
 network 222.222.222.5 0.0.0.0 area 0
!
ip classless
ip http server
!
access-list 100 deny eigrp any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
!
!
alias exec ship show ip route
alias exec clip clear ip route *
alias exec ospfn show ip ospf neigh
alias exec ipin show ip int brief
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
RSiddappa@NECBNS.com
Sent: Saturday, February 16, 2002 1:48 PM
To: jlaurens@cisco.com; ssowell@gate.net; Guy.Lupi@eurekaggn.com;
ccielab@groupstudy.com
Subject: RE: Dialer Watch

I beg to see the config pls.

I am working on my 12.0(8).

R.

-----Original Message-----
From: Jeremy Laurenson (Cisco) [mailto:jlaurens@cisco.com]
Sent: Saturday, February 16, 2002 3:40 PM
To: Siddappa, Rajeev; ssowell@gate.net; Guy.Lupi@eurekaggn.com;
ccielab@groupstudy.com
Subject: RE: Dialer Watch

I beg to differ - I have dialer-watch running on dialer profiles in my lab
here. IOS12.1.11

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
RSiddappa@NECBNS.com
Sent: Saturday, February 16, 2002 11:03 AM
To: ssowell@gate.net; Guy.Lupi@eurekaggn.com; ccielab@groupstudy.com
Subject: RE: Dialer Watch

And it is not possible to use Dialer Wacth on Dialer profile, but u can use
dialer rotary group to configure the Dialer watch if u do not want to
configure some thing on the physical interface.

R.

-----Original Message-----
From: Steven M. Sowell [mailto:ssowell@gate.net]
Sent: Friday, February 15, 2002 4:21 PM
To: Lupi, Guy; Ccielab@Groupstudy. Com
Subject: RE: Dialer Watch

With legacy DDR, you need to ensure that you add an additional dialer-map
statement with an IP address that matches one of your watched networks. For
instance....

interface BRI0/0
 ip address 10.1.220.18 255.255.255.252
 dialer map ip 10.1.220.17 name R2 broadcast 5551110
 dialer watch-group 1
 dialer map ip 10.1.195.1 name R2 broadcast 5551110

dialer watch-list 1 ip 10.1.195.1 255.255.255.255

Notice above that I have my "real" dialer map to the peer BRI IP address,
and I've added another dialer map that matches EXACTLY one of the watched
routes. Dialer profiles do not have this requirement (because you use
"dialer string" instead of "dialer map")

Steven Sowell
CCIE#7317

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Lupi, Guy
Sent: Friday, February 15, 2002 2:39 PM
To: 'ccielab@groupstudy.com'
Subject: Dialer Watch

I am using dialer watch with EIGRP. I have the standard deny eigrp any any,
then permit ip any any in the access list that the dialer list references.
Without a floating static route, I can only get it to come up when I attempt
to ping the far side of the ISDN connection, with a floating static I can
get it to come up with any IP, as it is supposed to. My question is, is
there any way to get the backup to come up without using the floating
static? I don't think there is, but if anyone could help me out here that
would be great, thanks.



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:25 GMT-3