Re: Simulate NetBEUI traffic

From: CHRIS HUGO (chrishugo@xxxxxxxxx)
Date: Thu Feb 14 2002 - 11:31:22 GMT-3


   
 I tried the configuration and I still couldn't pass any traffic. I did make mi
nor config changes to match the book. Let me know if this should be changed.
I also checked my dlsw peering:

r2# sh dlsw peer
Peers: state pkts_rx pkts_tx type drops ckts TCP uptim
e
 TCP 135.2.15.81 CONNECT 87 164 conf 0 0 0 00:43:4
8
 TCP 135.2.15.85 CONNECT 86 162 conf 0 0 0 00:43:2
8
 TCP 135.2.15.73 CONNECT 10 10 conf 0 0 0 00:03:5
0

For now I have this topology:
(tr)r1(eth)--------(eth)Ra(serial)------(serial)Rb(eth)---------(eth)r2(tr)
I have posted the running-configs bellow
r1#sh ru
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
!
ip subnet-zero
!
!
!
source-bridge ring-group 100
dlsw local-peer peer-id 135.2.15.73
dlsw remote-peer 0 tcp 135.2.15.85
dlsw remote-peer 0 tcp 135.2.15.81
dlsw remote-peer 0 tcp 135.2.15.77
!
!
dspu pu HOST rmac 5555.5555.5555 rsap 4 lsap 4
!
interface Loopback0
 ip address 135.2.10.1 255.255.255.0
 no ip directed-broadcast
 ip ospf interface-retry 0
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 ip ospf interface-retry 0

!
interface Serial0
 ip address 135.2.15.34 255.255.255.224
 no ip directed-broadcast
 encapsulation ppp
 ip ospf interface-retry 0
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 mac-address 6666.6666.6666
 ip address 135.2.15.73 255.255.255.224
 no ip directed-broadcast
 ip ospf interface-retry 0
 ring-speed 16
 source-bridge 50 1 100
 dspu enable-pu lsap 4
 dspu start HOST
!
router ospf 100
 network 135.2.0.0 0.0.255.255 area 0
!
ip classless
!
!
bridge 1 protocol ieee
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

routera#sh ru
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname routera
!
!
ip subnet-zero
!
!
!
source-bridge ring-group 100
dlsw local-peer peer-id 135.2.15.85
dlsw remote-peer 0 tcp 135.2.15.73
dlsw remote-peer 0 tcp 135.2.15.81
dlsw remote-peer 0 tcp 135.2.15.77
dlsw bridge-group 1
!
!
interface Ethernet0
 ip address 135.2.15.85 255.255.255.252
 no ip directed-broadcast
 ip ospf interface-retry 0
 bridge-group 1
!
interface Serial0
 ip address 135.2.15.35 255.255.255.224
 no ip directed-broadcast
 encapsulation ppp
 ip ospf interface-retry 0
 no ip mroute-cache
 no fair-queue
 clockrate 64000
!
interface Serial1
 ip address 135.2.15.65 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 ip ospf interface-retry 0
 clockrate 64000
!
interface Serial2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial3
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 100
 network 135.2.0.0 0.0.255.255 area 0
!
ip classless
!
!
bridge 1 protocol ieee
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

routerb# sh ru
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname routerb
!
!
ip subnet-zero
!
!
!
source-bridge ring-group 100
dlsw local-peer peer-id 135.2.15.81
dlsw remote-peer 0 tcp 135.2.15.73
dlsw remote-peer 0 tcp 135.2.15.85
dlsw remote-peer 0 tcp 135.2.15.77
dlsw bridge-group 1
!
!
interface Ethernet0
 ip address 135.2.15.81 255.255.255.252
 no ip directed-broadcast
 ip ospf interface-retry 0
 bridge-group 1
!
interface Serial0
 ip address 135.2.15.69 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 ip ospf interface-retry 0
 no ip mroute-cache
 no fair-queue
!
interface Serial1
 ip address 135.2.15.66 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 ip ospf interface-retry 0
!
interface BRI0
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 100
 network 135.2.0.0 0.0.255.255 area 0
!
ip classless
!
!
bridge 1 protocol ieee
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

r2#sh
01:22:50: %SYS-5-CONFIG_I: Configured from console by consoleru
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
!
ip subnet-zero
!
!
!
source-bridge ring-group 100
dlsw local-peer peer-id 135.2.15.77
dlsw remote-peer 0 tcp 135.2.15.81
dlsw remote-peer 0 tcp 135.2.15.85
dlsw remote-peer 0 tcp 135.2.15.73
!
!
dspu host HOST xid-snd 0d0d50d0 rmac 6666.6666.6666 rsap 4 lsap 4
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 ip ospf interface-retry 0
 !
interface Serial0
 ip address 135.2.15.70 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 ip ospf interface-retry 0
 no ip mroute-cache
 no fair-queue
 clockrate 64000
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 mac-address 5555.5555.5555
 ip address 135.2.15.77 255.255.255.252
 no ip directed-broadcast
 ip ospf interface-retry 0
 ring-speed 16
 source-bridge 50 1 100
 dspu enable-host lsap 4
 dspu start HOST
!
router ospf 100
 network 135.2.0.0 0.0.255.255 area 0
!
ip classless
!
!
bridge 1 protocol ieee
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

  Ahmed Mamoor Amimi <mamoor@ieee.org> wrote: yeap this is the same... just mak
e the PU (client) R1 and the HOST (server)
R2 ..... point both of them to there
mac address by using rmac command and also to local and remote SAP (that
should be the same on both sides).
I have told that this will also do on ethernet.

-Mamoor

----- Original Message -----
From: CHRIS HUGO
To: Ahmed Mamoor Amimi
Cc:
Sent: Thursday, February 14, 2002 10:02 AM
Subject: Re: Simulate NetBEUI traffic

> Hello Ahmed,
> Can your simulation also work with this type of topology?
> --(tr)r1(eth)--------(eth)Ra(serial)------(serial)Rb(eth)---------(eth)r2(
tr)--
> thank you,
> chris hugo
> Ahmed Mamoor Amimi wrote: sorry the diagram was.....
>
> r1---(tr)-----Ra------Rb-----(tr)-----r2
>
> Ra and Rb are the dlsw routers
>
> -Mamoor
>
> ----- Original Message -----
> From: CHRIS HUGO
> To:
> Sent: Thursday, February 14, 2002 7:56 AM
> Subject: Simulate NetBEUI traffic
>
>
> > Hi folks,
> >
> > I was wondering if their is a way I can simulate NetBEUI traffic of any
> type of not routable traffic across a DLSW link. I am going thru Chapter
24
> of the Cisco CCIE Lab Study Guide by Hutnik & Sterlee and would love to
> actually see traffic traverse these links. I have no way to attach the
> workstations since this is a online rack that I am using through the
> internet. This traffic doesn't have to be NetBEUI specific traffic but I
do
> want to test the scenarios with some type of non-routable traffic.
> >
> > Thank You in Advance,
> >
> > chris hugo
> >
> >
> >
> > ---------------------------------
> > Do You Yahoo!?
> > Send FREE Valentine eCards with Yahoo! Greetings!



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:22 GMT-3