From: Stephen C. Feldberg (scfeldberg@xxxxxxxxxxx)
Date: Mon Jan 07 2002 - 19:12:42 GMT-3
I am having a problem understanding you diagram where you have for example
> |172.16.1.0-15
> 172.168.x.x LAN|----------
Is this a /28 subnet of 172.168.0.0?
Remember that you are dealing with redistribution into a classful (RIPv1)
protocol, which requires special considerations. These commands may have
been entered into your router's config
> Router Rip
> Network 172.168.1.0
but if you view the running-config, you will see
> Router Rip
> Network 172.168.0.0
as RIP will only understand classful networks. The one caveat to this is a
RIP router that has an interface in a classless network. While RIP will not
understand VLSM, it will be able to receive advertisements accross that
interface of other subnets of the same classful network with the same length
subnet mask. For example, if you had
router1(e0)-----------(e0)router2
hostname router1
!
interface loopback0
ip address 172.168.2.1 255.255.255.0
!
interface e0
ip address 172.168.1.1 255.255.255.0
!
router rip
network 172.168.0.0
hostname router2
!
interface e0
ip address 172.168.1.2 255.255.255.0
!
router rip
network 172.168.0.0
In this scenario, router2 would receive the update for the 172.168.2.0
network from router1.
Getting back to your problem, the thing that stands out right away is the
access-list 100 you are using for redistribution is off
> Access-list 100 permit IP 172.16.1.27 0.0.0.15 any
> Access-list 100 permit IP 172.16.1.17 0.0.0.15 any
try using a standard access-list
access-list 1 permit 172.16.1.0
or an extended one in this format
access-list 101 permit ip host 172.16.1.0 host 255.255.255.0
where the second host entry matches the subnet mask of the route that you
are trying to redistribute.
Steve
----- Original Message -----
From: "Elias Udechime" <euchime@yahoo.com>
To: <ccielab@groupstudy.com>
Sent: Monday, January 07, 2002 4:25 PM
Subject: Simple OSPF Redistribution to RIP
> Hi all,
>
> I ran into this problem trying to redistribute OSPF
> into RIPv1
>
> Topology:
> | | Vlans
> | Rip OSPF
> |172.16.1.0-15
> 172.168.x.x LAN|----------Router1---------|172.16.1
> -31
> | |172.16.1.-63
> Also 10.1.1.1
>
>
> There are many VLANs. I only want two VLANs to be
> redistributed into RIP.
>
> I have tried access-list, distribute-list and
> redistributed into Rip, this does not work. Could some
> shade more light--light.
>
> Sample config:
>
> Router ospf 10
> network 172.16.1.0 0.0.0.255 area 0
> network 10.0.0.0 0.0.255.255 area 0
>
> Router Rip
> Network 172.168.1.0
> Redistribute OSPF 10 metric 2
> distribute-list 100 in
>
> Access-list 100 permit IP 172.16.1.27 0.0.0.15 any
> Access-list 100 permit IP 172.16.1.17 0.0.0.15 any
>
> These are only two IP in two different VLANs I want to
> redistribute into RIP environment.
>
>
> Elias
>
>
>
>
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:56:19 GMT-3