CCbootcamp lab 8A.

From: DAN DORTON (DHSTS68@xxxxxxxxxxxxxxx)
Date: Mon Dec 03 2001 - 13:35:15 GMT-3


   
Anyone successfully get the OSPF demand circuit working here? I have
tried everything, but I am still processing 224.0.0.5's across the BRI
in both directions.

I finally gave up & looked at the configs that CC sent, but they match
mine almost perfectly!

What the????

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r6
!
!
username r5 password 0 cisco
ip subnet-zero
no ip domain-lookup
!
ip ssh time-out 120
ip ssh authentication-retries 3
isdn switch-type basic-ni
!
!
!
!
interface Loopback0
 ip address 137.20.60.1 255.255.240.0
!
interface Ethernet0
 ip address 137.20.64.6 255.255.240.0
 ip ospf priority 255
 standby ip 137.20.64.8
 standby timers 5 10
 standby authentication cisco
!
interface Serial0
 ip address 137.20.86.1 255.255.255.0
 clockrate 2000000
!
interface BRI0
 bandwidth 64
 ip address 137.20.224.6 255.255.240.0
 encapsulation ppp
 ip ospf network point-to-point
 ip ospf demand-circuit
 dialer map ip 137.20.224.5 name r5 broadcast 18008358662
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866101 8358661
 isdn spid2 0835866301 8358663
 no cdp enable
 ppp authentication chap
!
router ospf 1
 log-adjacency-changes
 redistribute connected metric 20 subnets route-map filtercon
 redistribute bgp 2 metric 20 subnets route-map bgp2ospf
 network 137.20.48.0 0.0.15.255 area 0
 network 137.20.64.0 0.0.15.255 area 0
 network 137.20.224.0 0.0.15.255 area 0
!
router bgp 2
 bgp log-neighbor-changes
 network 137.20.86.0 mask 255.255.255.0
 redistribute ospf 1 route-map ospf2bgp
 neighbor 137.20.25.2 remote-as 2
 neighbor 137.20.25.2 update-source Loopback0
 neighbor 137.20.86.2 remote-as 1
 neighbor 137.20.86.2 default-originate
 no auto-summary
!
ip classless
no ip http server
ip pim bidir-enable
!
access-list 1 permit 137.20.86.0 0.0.0.255
access-list 10 permit 172.168.70.0 0.0.0.255
access-list 10 permit 137.20.10.0 0.0.0.255
access-list 10 permit 160.0.0.0 0.255.255.255
access-list 20 permit 137.20.224.0 0.0.0.255
access-list 30 permit 137.20.81.0 0.0.0.255
access-list 30 permit 137.20.82.0 0.0.0.255
access-list 40 permit any
dialer-list 1 protocol ip permit
route-map ospf2bgp deny 10
 match ip address 20
!
route-map ospf2bgp permit 20
 match route-type internal
!
route-map ospf2bgp deny 30
 match ip address 10
!
route-map ospf2bgp permit 40
 match route-type external
!
route-map bgp2ospf deny 10
 match ip address 30
!
route-map bgp2ospf permit 20
 match ip address 40
!
route-map filtercon permit 10
 match ip address 1
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 exec-timeout 0 0
 login
!
end

r6#sh ip ospf int bri 0
BRI0 is up, line protocol is up (spoofing)
  Internet Address 137.20.224.6/20, Area 0
  Process ID 1, Router ID 137.20.60.1, Network Type POINT_TO_POINT,
Cost: 1562
  Configured as demand circuit.
  Run as demand circuit.
  DoNotAge LSA allowed.
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:01
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 2
  Last flood scan time is 0 msec, maximum is 8 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 137.20.240.1 (Hello suppressed)
  Suppress hello for 1 neighbor(s)

r6#sh ip ospf ne

Neighbor ID Pri State Dead Time Address
Interface
137.20.240.1 1 FULL/ - - 137.20.224.5 BRI0
137.20.240.1 1 FULL/BDR 00:00:39 137.20.64.5
Ethernet0

version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
!
username r6 password 0 cisco
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-ni
!
!
!
 !
 !
!
process-max-time 200
!
interface Loopback0
 ip address 137.20.240.1 255.255.240.0
!
interface BRI0/0
 ip address 137.20.224.5 255.255.240.0
 encapsulation ppp
ip ospf demand-circuit
 bandwidth 64
 dialer map ip 137.20.224.6 name r6 broadcast 18008358661
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866201 8358662
 isdn spid2 0835866401 8358664
 no cdp enable
 ppp authentication chap
 hold-queue 75 in
!
interface Ethernet0/0
 ip address 137.20.64.5 255.255.240.0
 no ip redirects
 standby timers 5 10
 standby priority 200
 standby preempt
 standby authentication cisco
 standby ip 137.20.64.8
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 keepalive 15
 no fair-queue
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial0/0.1 multipoint
 ip address 137.20.100.34 255.255.255.224
 ip ospf network point-to-multipoint
 frame-relay map ip 137.20.100.33 501 broadcast
 frame-relay map ip 137.20.100.34 501 broadcast
 frame-relay map ip 137.20.100.35 503 broadcast
 no frame-relay inverse-arp
!
interface Serial0/0.2 point-to-point
 ip address 137.20.200.17 255.255.255.240
 frame-relay interface-dlci 504
!
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface Serial0/1
 ip address 137.20.25.1 255.255.255.0
 clockrate 2000000
!
router ospf 1
 redistribute igrp 1 metric 100 metric-type 1 subnets route-map
igrp2ospf
 network 137.20.25.0 0.0.0.255 area 2
 network 137.20.64.0 0.0.15.255 area 0
 network 137.20.100.32 0.0.0.31 area 1
 network 137.20.224.0 0.0.15.255 area 0
 network 137.20.240.0 0.0.15.255 area 0
 area 1 virtual-link 200.200.100.1
 area 1 virtual-link 137.20.33.33
!
router igrp 1
 redistribute ospf 1 metric 1544 20000 255 1 1500
 passive-interface BRI0/0
 passive-interface Ethernet0/0
 passive-interface Serial0/0.1
 passive-interface Serial0/1
 network 137.20.0.0
!
ip classless
ip route 137.20.81.0 255.255.255.0 137.20.60.1
ip route 137.20.82.0 255.255.255.0 137.20.60.1
!
access-list 1 permit 137.20.100.32 0.0.0.31
access-list 1 permit 137.20.240.0 0.0.0.255
access-list 1 permit 137.20.64.0 0.0.0.255
access-list 1 permit 137.20.224.0 0.0.0.255
access-list 2 permit any
dialer-list 1 protocol ip permit
route-map igrp2ospf deny 10
 match ip address 1
!
route-map igrp2ospf permit 20
 match ip address 2
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 login
!
no scheduler allocate
end

r5#sh ip ospf int bri 0/0
BRI0/0 is up, line protocol is up (spoofing)
  Internet Address 137.20.224.5/20, Area 0
  Process ID 1, Router ID 137.20.240.1, Network Type POINT_TO_POINT,
Cost: 1562
  Run as demand circuit.
  DoNotAge LSA allowed.
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 137.20.60.1 (Hello suppressed)
  Suppress hello for 1 neighbor(s)

r5#sh ip ospf ne

Neighbor ID Pri State Dead Time Address
Interface
137.20.60.1 1 FULL/ - 00:00:39 137.20.224.6
BRI0/0
137.20.60.1 255 FULL/DR 00:00:35 137.20.64.6
Ethernet0/0
200.200.100.1 1 FULL/ - 00:01:59 137.20.100.33
Serial0/0.1
137.20.33.33 1 FULL/ - 00:01:55 137.20.100.35
Serial0/0.1
137.20.25.2 1 FULL/ - 00:00:38 137.20.25.2
Serial0/1

Thanks much!

Dan



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:36 GMT-3