From: Lupi, Guy (Guy.Lupi@xxxxxxxxxxxxx)
Date: Wed Nov 28 2001 - 18:26:04 GMT-3
I don't have a local peer option, the only peer option is the remote peer,
according to cco one of the remote peer statements should be an ip of the
local router, and one should be the ip of the actual remote peer. When I do
a source-bridge ? I get the following:
R4(config)#source-bridge ?
connection-timeout Connection timeout
cos-enable Prioritize traffic by Class of Service
enable-80d5 Convert TR LLC2 frames to Ethernet type 80d5
frames
explorer-dup-ARE-filter Enable filtering of duplicate all-routes
explorers
explorer-fastswitch Enable local explorer fastswitching
explorer-maxrate Maximum SRB local explorer data rate in bytes/sec
explorerQ-depth Maximum SRB explorer queue depth per interface
fst-peername Fast Sequence Transport local interface address
keepalive Enable RSRB remote peer keepalive
largest-frame Largest frame size to use in a ring-group
passthrough Do not local-ack frames to the specified ring
ping Establish srb pings
proxy-netbios-only Proxy explorers only for NetBIOS
qllc-local-ack Locally terminate QLLC sessions
remote-peer Specify a remote peer for remote SRB
ring-group Define a ring group
sap-80d5 Translate specified SAP frames to 80d5 frames
sdllc-local-ack Locally terminate SDLC sessions
tcp-queue-max Maximum TCP queue size for SRB
transparent Bridging between a transparent and a source-route
bridge
-----Original Message-----
From: Brion Washington
To: Lupi, Guy; ccielab@groupstudy.com
Sent: 11/28/2001 4:17 PM
Subject: RE: Source Route Bridging
Your config is wrong. You need to change source-bridge remote-peer 12
tcp
130.13.5.4 on R4 to source-bridge local-peer peer-id 130.13.5.4, and
change
R3 source-bridge remote-peer 12 tcp 130.13.1.1 to source-bridge
local-peer
peer-id 130.13.1.1
So basically you are using two remote-peer statements. You can forgo the
remote-peer one one side if you use Promiscuous at the end of the
local-peer
statement.
This should get you working fast.
Brion
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Lupi, Guy
Sent: Wednesday, November 28, 2001 1:44 PM
To: 'ccielab@groupstudy.com'
Subject: Source Route Bridging
Ok, I started out with this elaborate set up, 6 routers, source route
and
remote source route bridging, first time trying it. I steadily removed
routers until I am down to 2 and I still can't get it to work!!! I have
2
routers, each with one token ring interface and one serial interface,
the
serial interfaces connect the 2 routers. I looked on CCO, verified that
everything looks correct, yet I can never get the 2 remote peers to go
into
an open state. Below are the configs, an extended ping to show
connectivity, and the output of a show source from each router. I would
really appreciate it if someone could take a look and let me know what I
am
doing wrong, thanks.
R4#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
!
ip subnet-zero
!
!
!
source-bridge ring-group 12
source-bridge remote-peer 12 tcp 130.13.5.4
source-bridge remote-peer 12 tcp 130.13.1.1
!
!
interface Serial0
ip address 4.4.4.4 255.255.255.0
no ip directed-broadcast
ip ospf interface-retry 0
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface TokenRing0
ip address 130.13.5.4 255.255.255.0
no ip directed-broadcast
ip ospf interface-retry 0
ring-speed 16
multiring ip
source-bridge 2 1 12
source-bridge spanning
!
interface BRI0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 100
network 4.4.4.0 0.0.0.255 area 0
network 130.13.5.0 0.0.0.255 area 0
!
ip classless
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
R4#
R4#ping
Protocol [ip]:
Target IP address: 130.13.1.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 130.13.5.4
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 130.13.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms
R4#
R4#sh source
Local Interfaces: receive transmit
srn bn trn r p s n max hops cnt cnt
drops
To0 2 2 12 * b 7 7 7 0 0
0
Global RSRB Parameters:
TCP Queue Length maximum: 100
Ring Group 12:
This TCP peer: 130.13.5.4
Maximum output TCP queue length, per peer: 100
Peers: state bg lv pkts_rx pkts_tx expl_gn
drops
TCP
TCP 130.13.5.4 - 3 0 0 0
0
0
TCP 130.13.1.1 closed 3 0 0 0
0
0
Rings:
bn: 2 rn: 2 local ma: 4008.de5c.a38a TokenRing0 fwd:
0
Explorers: ------- input ------- ------- output -------
spanning all-rings total spanning all-rings
total
To0 0 0 0 0 0
0
Explorer fastswitching enabled
Local switched: 0 flushed 0 max Bps 38400
rings inputs bursts throttles output
drops
To0 0 0 0
0
R4#
R3#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
ip subnet-zero
!
!
!
source-bridge ring-group 12
source-bridge remote-peer 12 tcp 130.13.1.1
source-bridge remote-peer 12 tcp 130.13.5.4
!
!
interface Serial0
ip address 4.4.4.5 255.255.255.0
no ip directed-broadcast
ip ospf interface-retry 0
no ip mroute-cache
no fair-queue
clockrate 1300000
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface TokenRing0
ip address 130.13.1.1 255.255.255.0
no ip directed-broadcast
ip ospf interface-retry 0
ring-speed 16
multiring ip
source-bridge 1 1 12
source-bridge spanning
!
interface BRI0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 100
network 4.4.4.0 0.0.0.255 area 0
network 130.13.1.0 0.0.0.255 area 0
!
ip classless
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
R3#
R3#ping
Protocol [ip]:
Target IP address: 130.13.5.4
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 130.13.1.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 130.13.5.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/9/28 ms
R3#
R3#sh sour
Local Interfaces: receive transmit
srn bn trn r p s n max hops cnt cnt
drops
To0 1 1 12 * f 7 7 7 0 0
0
Global RSRB Parameters:
TCP Queue Length maximum: 100
Ring Group 12:
This TCP peer: 130.13.1.1
Maximum output TCP queue length, per peer: 100
Peers: state bg lv pkts_rx pkts_tx expl_gn
drops
TCP
TCP 130.13.1.1 - 3 0 0 0
0
0
TCP 130.13.5.4 closed 3 0 0 0
0
0
Rings:
bn: 1 rn: 1 local ma: 4008.de6c.6382 TokenRing0 fwd:
0
Explorers: ------- input ------- ------- output -------
spanning all-rings total spanning all-rings
total
To0 0 0 0 0 0
0
Explorer fastswitching enabled
Local switched: 0 flushed 0 max Bps 38400
rings inputs bursts throttles output
drops
To0 0 0 0
0
R3#
This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:24 GMT-3