RE: BGP advertise-map

From: Jon Carmichael (jonc@xxxxxxxxxxx)
Date: Sat Aug 11 2001 - 10:56:54 GMT-3


   
I got it working fine except that I'm using a different approach. I have a
router internal to my AS, running OSPF only with eight loopbacks injecting
these as OSPF routes, (192.168.192.0 thru 192.168.199.0), --these eight
loopbacks are also used so simulate different sets of things I can
aggregate. Then on a border router, redistributes those OSPF routes to a
next-door AS. --That alone is simple enough. The main difference between
my configuration is that you're using the BGP network command where I'm
using redistribution, --so my origin in "incomplete."

Then I step into my OSPF only router and do a shutdown on one of the
loopbacks (the one identified with a route-map called NOTHERE), --and watch
another four disappear (identified with the other route-map called ADVTHIS).
Configs of the border AS follows...

!
router bgp 43
 timers bgp 3 9
 redistribute ospf 1
 neighbor EXT peer-group
 neighbor EXT ebgp-multihop 2
 neighbor EXT update-source Loopback0
 neighbor EXT advertise-map ADVTHIS non-exist-map NOTHERE
 neighbor 172.18.100.1 remote-as 18
 neighbor 172.18.100.1 peer-group EXT
 neighbor 172.19.100.1 remote-as 19
 neighbor 172.19.100.1 peer-group EXT
 neighbor 172.20.101.1 remote-as 43
 neighbor 172.20.101.1 update-source Loopback0
 neighbor 172.20.101.1 route-reflector-client
 neighbor 172.20.104.1 remote-as 44
 neighbor 172.20.104.1 peer-group EXT
 neighbor 172.20.105.1 remote-as 42
 neighbor 172.20.105.1 peer-group EXT
 no auto-summary
!
ip classless
ip route 172.18.100.1 255.255.255.255 192.168.255.13
ip route 172.18.100.1 255.255.255.255 192.168.255.17
ip route 172.19.100.1 255.255.255.255 192.168.255.33
ip route 172.19.100.1 255.255.255.255 192.168.255.9
!
access-list 66 permit 192.168.196.0 0.0.3.255
access-list 67 permit 192.168.192.0 0.0.0.255
route-map NOTHERE permit 10
 match ip address 67
!
route-map ADVTHIS permit 10
 match ip address 66
!

JONC

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Dan Pontrelli
Sent: Sunday, July 29, 2001 10:23 PM
To: ccielab@groupstudy.com
Subject: BGP advertise-map

I've looked at this on CCO and in the archives. It doesn't seem complicated
and I don't see what I'm doing differently, but I just can't get this to
work.

I have the following peering setup:

     AS1 AS2
R1-S0-172.16.0.2------------------S0-172.16.0.1-R2

R1 has the following routes in it's BGP table (all injected by R1 with the
"network" command under the BGP configuration):

2.0.0.0 /8 (a static route to null0 on R1)
3.0.0.0/8 (a static route to null0 on R1)
100.1.0.0/16 (100.1.0.1/16 on Serial1 of R1)
200.200.200.0/24 (200.200.200.1 on Loopback of R1)

R2 is receiving all 4 routes "before" I set up conditional advertising on
R1.
Then I set up an advertise-map on R1 so that in the absence of 100.1.0.0/16
it will advertise the other 3 routes to R2.
Once I do this, R1 is only advertising the 100.1.0.0/16 prefix (the desired
behavior so far).
Then I shut down Serial1 on R1. 100.1.0.0/16 disappears from the BGP tables
and R1 now only has the other 3 routes in its table but does not advertise
them to R2 as it should.

These are my configs:

R1

interface Loopback3
 ip address 200.200.200.1 255.255.255.0

interface Serial0
 ip address 172.16.0.2 255.255.0.0
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 ip address 100.1.0.1 255.255.0.0
 dialer dtr

router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 2.0.0.0
 network 3.0.0.0
 network 100.1.0.0 mask 255.255.0.0
 network 200.200.200.0
 neighbor 172.16.0.1 remote-as 2
 neighbor 172.16.0.1 advertise-map map1-name non-exist-map map2-name
 no auto-summary

access-list 2 permit 100.1.0.0 0.0.255.255
access-list 9 permit 200.200.200.0 0.0.0.255
access-list 9 permit 2.0.0.0 1.255.255.255

route-map map2-name permit 10
 match ip address 2
!
route-map map1-name permit 10
 match ip address 9

R2

interface Serial0
 ip address 172.16.0.1 255.255.0.0
 no ip directed-broadcast
 no fair-queue

router bgp 2
 no synchronization
 neighbor 172.16.0.2 remote-as 1
 no auto-summary

Any help/insight is appreciated.

-DP
**Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:31:49 GMT-3