EIGRP - summary address within process domain

From: Darek Kuzma (darekk@xxxxxxxxxxxxx)
Date: Tue Apr 10 2001 - 22:43:04 GMT-3


   
Hi,
I'm playing with EIGRP redistribution between two domains and with
address summarization.
I have two concerns.

1. Doyle on page 726 says:

... You might expect this route to be suppressed by the summary address
of 192.168.0.0/16. However,
192.168.4.0/24 is internal to EIGRP 2 process domain; the summarization
applies only to routes being redistributed into the process domain...

I'm trying to reproduce this behavior but it doesn't work this way for
me! When I create summary within domain the more specific routes get
suppressed.
I use IOS 12.0.16
Any ideas?

2. Admin Distance table specifies AD of summary EIGRP route = 5
How can I observe it in routing table ??? All summary routes show AD=90
beyond the point where they got summarized and like:
10.10.248.0/21 is a summary, 00:21:22, Null on the router which
summarizes

Here are configs and outputs for 1):

!
version 12.0
service exec-callback
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 5
!
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
 ip address 10.10.100.5 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 10.10.40.5 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 10.10.50.5 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
!
interface Serial1
 ip address 10.10.25.5 255.255.255.0
 no ip directed-broadcast
!
interface BRI0
ip address 10.10.251.5 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
!
interface Async1
 ip address 10.10.252.5 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 ppp authentication chap
!
router eigrp 2
 network 10.0.0.0
!
ip classless
!

alias exec ct config t
alias exec sb sh ip interface brief
alias exec sr sh runn
alias exec sip sh ip route
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
 autoselect ppp
 login local
 modem InOut
 modem autoconfigure discovery
 transport input all
 stopbits 1
 speed 38400
 flowcontrol hardware
line vty 0 4
 password msoft
 login
!
end

5#
5#sip
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
D EX 10.10.2.0/24 [170/2707456] via 10.10.40.7, 00:34:53, Ethernet0
D 10.10.21.0/24 [90/2221056] via 10.10.40.7, 00:34:53, Ethernet0
C 10.10.40.0/24 is directly connected, Ethernet0
D 10.10.60.0/24 [90/2195456] via 10.10.40.7, 00:34:53, Ethernet0
C 10.10.100.0/24 is directly connected, Loopback0
D EX 10.10.244.0/24 [170/2323456] via 10.10.40.7, 00:34:53, Ethernet0

D EX 10.10.248.0/21 [170/2611200] via 10.10.40.7, 00:34:53, Ethernet0

C 10.10.251.0/24 is directly connected, BRI0
C 10.10.252.0/24 is directly connected, Async1
D 11.0.0.0/8 [90/2195456] via 10.10.40.7, 00:34:53, Ethernet0
<----- this should not suppress more specific routes

5#
5#sip 11.0.0.0 255.0.0.0 long
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

D 11.0.0.0/8 [90/2195456] via 10.10.40.7, 00:35:15, Ethernet0
5#sip 11.0.0.0 255.0.0.0 long
Routing entry for 11.0.0.0/8
  Known via "eigrp 2", distance 90, metric 2195456, type internal
  Redistributing via eigrp 2
  Last update from 10.10.40.7 on Ethernet0, 00:35:30 ago
  Routing Descriptor Blocks:
  * 10.10.40.7, from 10.10.40.7, 00:35:30 ago, via Ethernet0
      Route metric is 2195456, traffic share count is 1
      Total delay is 21000 microseconds, minimum bandwidth is 1544 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 7
!
!
ip subnet-zero
no ip domain-lookup
!
!
interface Ethernet0
 ip address 10.10.40.7 255.255.255.0
 no ip directed-broadcast
 ip summary-address eigrp 2 11.0.0.0 255.0.0.0
!
interface Serial0
 ip address 11.11.1.1 255.255.255.252
 no ip directed-broadcast
!
interface Serial1
 ip address 10.10.60.7 255.255.255.0
 no ip directed-broadcast
 ip summary-address eigrp 1 11.0.0.0 255.0.0.0
 ip summary-address eigrp 1 10.10.248.0 255.255.248.0
!
router eigrp 1
 redistribute eigrp 2 metric 1000 100 1 127 1500
 passive-interface Ethernet0
 passive-interface Serial0
 network 10.0.0.0
!
router eigrp 2
 redistribute eigrp 1
 passive-interface Serial1
 network 10.0.0.0
 network 11.0.0.0
 no auto-summary
!
ip classless
!
alias exec ct config t
alias exec sb sh ip interface brief
alias exec sr sh runn
alias exec sip sh ip route
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password msoft
 login
!
end

7#sip
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
D 10.10.2.0/24 [90/2681856] via 10.10.60.1, 00:50:06, Serial1
D 10.10.21.0/24 [90/2195456] via 11.11.1.2, 00:42:52, Serial0
C 10.10.40.0/24 is directly connected, Ethernet0
C 10.10.60.0/24 is directly connected, Serial1
D 10.10.100.0/24 [90/409600] via 10.10.40.5, 00:42:52, Ethernet0
D 10.10.244.0/24 [90/2297856] via 10.10.60.1, 00:50:06, Serial1
D 10.10.248.0/21 is a summary, 00:42:52, Null0
D 10.10.251.0/24 [90/40537600] via 10.10.40.5, 00:42:52, Ethernet0

D 10.10.252.0/24 [90/287030016] via 10.10.40.5, 00:42:52,
Ethernet0
     11.0.0.0/8 is variably subnetted, 5 subnets, 5 masks
C 11.11.1.0/30 is directly connected, Serial0
D 11.11.8.0/22 [90/2297856] via 11.11.1.2, 00:42:52, Serial0
D 11.0.0.0/8 is a summary, 00:47:15, Null0
D 11.11.32.0/19 [90/2297856] via 11.11.1.2, 00:42:52, Serial0
D 11.11.128.0/17 [90/2297856] via 11.11.1.2, 00:42:52, Serial0

Current configuration:
!
version 12.0
service udp-small-servers
service tcp-small-servers
!
hostname 6
!
enable secret 5 $1$sw7Q$4pDpTNi/0ELjj99wu19fE/
!
ip subnet-zero
no ip domain-lookup
ipx routing 0060.5cf4.7f88
!
!
!
interface Loopback111
 ip address 11.11.10.1 255.255.252.0
 no ip directed-broadcast
 !
interface Loopback112
 ip address 11.11.50.1 255.255.224.0
 no ip directed-broadcast
!
interface Loopback113
 ip address 11.11.128.1 255.255.128.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 10.10.21.6 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface Serial0
 ip address 11.11.1.2 255.255.255.252
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 service-module 56k clock source internal
!
interface Serial1
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
!
router eigrp 2
 network 10.0.0.0
 network 11.0.0.0
 no auto-summary
!
ip classless
!
!
!
!
snmp-server community private RW
snmp-server system-shutdown
snmp-server enable traps snmp
snmp-server enable traps isdn call-information
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps bgp
snmp-server enable traps frame-relay
snmp-server enable traps rtr
snmp-server host 10.10.201.200 traps version 2c private
snmp-server host 10.10.203.202 traps private
alias exec ct config t
alias exec sb sh ip interface brief
alias exec sr sh runn
alias exec sip sh ip route
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
 transport input all
line vty 0 4
 password msoft
 login
!
end

6#sip
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
D EX 10.10.2.0/24 [170/3193856] via 11.11.1.1, 00:40:46, Serial0
C 10.10.21.0/24 is directly connected, Ethernet0
D 10.10.40.0/24 [90/2195456] via 11.11.1.1, 00:40:46, Serial0
D 10.10.60.0/24 [90/2681856] via 11.11.1.1, 00:40:46, Serial0
D 10.10.100.0/24 [90/2323456] via 11.11.1.1, 00:40:46, Serial0
D EX 10.10.244.0/24 [170/2809856] via 11.11.1.1, 00:40:46, Serial0
D EX 10.10.248.0/21 [170/3097600] via 11.11.1.1, 00:40:46, Serial0
D 10.10.251.0/24 [90/41049600] via 11.11.1.1, 00:40:46, Serial0
D 10.10.252.0/24 [90/287542016] via 11.11.1.1, 00:40:46, Serial0
     11.0.0.0/8 is variably subnetted, 4 subnets, 4 masks
C 11.11.1.0/30 is directly connected, Serial0
C 11.11.8.0/22 is directly connected, Loopback111
C 11.11.32.0/19 is directly connected, Loopback112
C 11.11.128.0/17 is directly connected, Loopback113



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:43 GMT-3