From: Darek Kuzma (darekk@xxxxxxxxxxxxx)
Date: Wed Apr 11 2001 - 12:27:21 GMT-3
Guys,
Actually I connected 4 routers. 3 of them are in EIGRP domain 2 (R5, R6,R7) an
d
two of them in EIGRP domain 1 (R7,R1)
Here is the physical layout:
__ ----> (E0) R5
(E0)<---
R1 (S0) <----> (S1) R7
(S0)<----------- > (S0) R6
R7 is performing summarization and redistribution between two EIGRP domains:
interface Ethernet0
> ip address 10.10.40.7 255.255.255.0
> no ip directed-broadcast
> ip summary-address eigrp 2 11.0.0.0 255.0.0.0
> !
> interface Serial0
> ip address 11.11.1.1 255.255.255.252
> no ip directed-broadcast
> !
> interface Serial1
> ip address 10.10.60.7 255.255.255.0
> no ip directed-broadcast
> ip summary-address eigrp 1 11.0.0.0 255.0.0.0
> ip summary-address eigrp 1 10.10.248.0 255.255.248.0
> !
> router eigrp 1
> redistribute eigrp 2 metric 1000 100 1 127 1500
> passive-interface Ethernet0
> passive-interface Serial0
> network 10.0.0.0
> !
> router eigrp 2
> redistribute eigrp 1
> passive-interface Serial1
> network 10.0.0.0
> network 11.0.0.0
> no auto-summary
xander wrote:
> Hello Darek,
>
> I didn't cacth it. Where is the redistribution in your configs?
> Where is the other eigrp process? Please clarify me.
>
> If you do NOT avoid to using 'auto-summary' in your eigrp domain,
> summarization will be proceeded only for external networks which
> received by this router. Otherwise, you need to switch off
> summarization and do it on some interfaces with 'ip summary-address
> eigrp...'. It is more preferable method of using EIGRP as IGP in your
> network, because BGP does not allow summarizated routes being
> redistributed to it without explicit 'network ...' parameter.
>
> DK> Hi,
> DK> I'm playing with EIGRP redistribution between two domains and with
> DK> address summarization.
> DK> I have two concerns.
>
> DK> 1. Doyle on page 726 says:
>
> DK> ... You might expect this route to be suppressed by the summary address
> DK> of 192.168.0.0/16. However,
> DK> 192.168.4.0/24 is internal to EIGRP 2 process domain; the summarization
> DK> applies only to routes being redistributed into the process domain...
>
> DK> I'm trying to reproduce this behavior but it doesn't work this way for
> DK> me! When I create summary within domain the more specific routes get
> DK> suppressed.
> DK> I use IOS 12.0.16
> DK> Any ideas?
>
> DK> 2. Admin Distance table specifies AD of summary EIGRP route = 5
> DK> How can I observe it in routing table ??? All summary routes show AD=90
> DK> beyond the point where they got summarized and like:
> DK> 10.10.248.0/21 is a summary, 00:21:22, Null on the router which
> DK> summarizes
>
> DK> Here are configs and outputs for 1):
>
> DK> !
> DK> version 12.0
> DK> service exec-callback
> DK> service timestamps debug uptime
> DK> service timestamps log uptime
> DK> no service password-encryption
> DK> !
> DK> hostname 5
> DK> !
> DK> ip subnet-zero
> DK> no ip domain-lookup
> DK> !
> DK> interface Loopback0
> DK> ip address 10.10.100.5 255.255.255.0
> DK> no ip directed-broadcast
> DK> !
> DK> interface Ethernet0
> DK> ip address 10.10.40.5 255.255.255.0
> DK> no ip directed-broadcast
> DK> !
> DK> interface Serial0
> DK> ip address 10.10.50.5 255.255.255.0
> DK> no ip directed-broadcast
> DK> no ip mroute-cache
> DK> !
> DK> interface Serial1
> DK> ip address 10.10.25.5 255.255.255.0
> DK> no ip directed-broadcast
> DK> !
> DK> interface BRI0
> DK> ip address 10.10.251.5 255.255.255.0
> DK> no ip directed-broadcast
> DK> encapsulation ppp
> DK> !
> DK> interface Async1
> DK> ip address 10.10.252.5 255.255.255.0
> DK> no ip directed-broadcast
> DK> encapsulation ppp
> DK> ppp authentication chap
> DK> !
> DK> router eigrp 2
> DK> network 10.0.0.0
> DK> !
> DK> ip classless
> DK> !
>
> DK> alias exec ct config t
> DK> alias exec sb sh ip interface brief
> DK> alias exec sr sh runn
> DK> alias exec sip sh ip route
> DK> !
> DK> line con 0
> DK> exec-timeout 0 0
> DK> transport input none
> DK> line aux 0
> DK> autoselect ppp
> DK> login local
> DK> modem InOut
> DK> modem autoconfigure discovery
> DK> transport input all
> DK> stopbits 1
> DK> speed 38400
> DK> flowcontrol hardware
> DK> line vty 0 4
> DK> password msoft
> DK> login
> DK> !
> DK> end
>
> DK> 5#
> DK> 5#sip
> DK> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
>
> DK> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> DK> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> DK> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> DK> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
> DK> default
> DK> U - per-user static route, o - ODR
>
> DK> Gateway of last resort is not set
>
> DK> 10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
> DK> D EX 10.10.2.0/24 [170/2707456] via 10.10.40.7, 00:34:53, Ethernet0
> DK> D 10.10.21.0/24 [90/2221056] via 10.10.40.7, 00:34:53, Ethernet0
> DK> C 10.10.40.0/24 is directly connected, Ethernet0
> DK> D 10.10.60.0/24 [90/2195456] via 10.10.40.7, 00:34:53, Ethernet0
> DK> C 10.10.100.0/24 is directly connected, Loopback0
> DK> D EX 10.10.244.0/24 [170/2323456] via 10.10.40.7, 00:34:53, Ethernet0
>
> DK> D EX 10.10.248.0/21 [170/2611200] via 10.10.40.7, 00:34:53, Ethernet0
>
> DK> C 10.10.251.0/24 is directly connected, BRI0
> DK> C 10.10.252.0/24 is directly connected, Async1
> DK> D 11.0.0.0/8 [90/2195456] via 10.10.40.7, 00:34:53, Ethernet0
> DK> <----- this should not suppress more specific routes
>
> DK> 5#
> DK> 5#sip 11.0.0.0 255.0.0.0 long
> DK> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
>
> DK> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> DK> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> DK> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> DK> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
> DK> default
> DK> U - per-user static route, o - ODR
>
> DK> Gateway of last resort is not set
>
> DK> D 11.0.0.0/8 [90/2195456] via 10.10.40.7, 00:35:15, Ethernet0
> DK> 5#sip 11.0.0.0 255.0.0.0 long
> DK> Routing entry for 11.0.0.0/8
> DK> Known via "eigrp 2", distance 90, metric 2195456, type internal
> DK> Redistributing via eigrp 2
> DK> Last update from 10.10.40.7 on Ethernet0, 00:35:30 ago
> DK> Routing Descriptor Blocks:
> DK> * 10.10.40.7, from 10.10.40.7, 00:35:30 ago, via Ethernet0
> DK> Route metric is 2195456, traffic share count is 1
> DK> Total delay is 21000 microseconds, minimum bandwidth is 1544 Kbit
> DK> Reliability 255/255, minimum MTU 1500 bytes
> DK> Loading 1/255, Hops 1
>
> DK> Current configuration:
> DK> !
> DK> version 12.0
> DK> service timestamps debug uptime
> DK> service timestamps log uptime
> DK> no service password-encryption
> DK> !
> DK> hostname 7
> DK> !
> DK> !
> DK> ip subnet-zero
> DK> no ip domain-lookup
> DK> !
> DK> !
> DK> interface Ethernet0
> DK> ip address 10.10.40.7 255.255.255.0
> DK> no ip directed-broadcast
> DK> ip summary-address eigrp 2 11.0.0.0 255.0.0.0
> DK> !
> DK> interface Serial0
> DK> ip address 11.11.1.1 255.255.255.252
> DK> no ip directed-broadcast
> DK> !
> DK> interface Serial1
> DK> ip address 10.10.60.7 255.255.255.0
> DK> no ip directed-broadcast
> DK> ip summary-address eigrp 1 11.0.0.0 255.0.0.0
> DK> ip summary-address eigrp 1 10.10.248.0 255.255.248.0
> DK> !
> DK> router eigrp 1
> DK> redistribute eigrp 2 metric 1000 100 1 127 1500
> DK> passive-interface Ethernet0
> DK> passive-interface Serial0
> DK> network 10.0.0.0
> DK> !
> DK> router eigrp 2
> DK> redistribute eigrp 1
> DK> passive-interface Serial1
> DK> network 10.0.0.0
> DK> network 11.0.0.0
> DK> no auto-summary
> DK> !
> DK> ip classless
> DK> !
> DK> alias exec ct config t
> DK> alias exec sb sh ip interface brief
> DK> alias exec sr sh runn
> DK> alias exec sip sh ip route
> DK> !
> DK> line con 0
> DK> exec-timeout 0 0
> DK> transport input none
> DK> line aux 0
> DK> line vty 0 4
> DK> password msoft
> DK> login
> DK> !
> DK> end
>
> DK> 7#sip
> DK> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
>
> DK> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> DK> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> DK> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> DK> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
> DK> default
> DK> U - per-user static route, o - ODR
>
> DK> Gateway of last resort is not set
>
> DK> 10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
> DK> D 10.10.2.0/24 [90/2681856] via 10.10.60.1, 00:50:06, Serial1
> DK> D 10.10.21.0/24 [90/2195456] via 11.11.1.2, 00:42:52, Serial0
> DK> C 10.10.40.0/24 is directly connected, Ethernet0
> DK> C 10.10.60.0/24 is directly connected, Serial1
> DK> D 10.10.100.0/24 [90/409600] via 10.10.40.5, 00:42:52, Ethernet0
> DK> D 10.10.244.0/24 [90/2297856] via 10.10.60.1, 00:50:06, Serial1
> DK> D 10.10.248.0/21 is a summary, 00:42:52, Null0
> DK> D 10.10.251.0/24 [90/40537600] via 10.10.40.5, 00:42:52, Ethernet0
>
> DK> D 10.10.252.0/24 [90/287030016] via 10.10.40.5, 00:42:52,
> DK> Ethernet0
> DK> 11.0.0.0/8 is variably subnetted, 5 subnets, 5 masks
> DK> C 11.11.1.0/30 is directly connected, Serial0
> DK> D 11.11.8.0/22 [90/2297856] via 11.11.1.2, 00:42:52, Serial0
> DK> D 11.0.0.0/8 is a summary, 00:47:15, Null0
> DK> D 11.11.32.0/19 [90/2297856] via 11.11.1.2, 00:42:52, Serial0
> DK> D 11.11.128.0/17 [90/2297856] via 11.11.1.2, 00:42:52, Serial0
>
> DK> Current configuration:
> DK> !
> DK> version 12.0
> DK> service udp-small-servers
> DK> service tcp-small-servers
> DK> !
> DK> hostname 6
> DK> !
> DK> enable secret 5 $1$sw7Q$4pDpTNi/0ELjj99wu19fE/
> DK> !
> DK> ip subnet-zero
> DK> no ip domain-lookup
> DK> ipx routing 0060.5cf4.7f88
> DK> !
> DK> !
> DK> !
> DK> interface Loopback111
> DK> ip address 11.11.10.1 255.255.252.0
> DK> no ip directed-broadcast
> DK> !
> DK> interface Loopback112
> DK> ip address 11.11.50.1 255.255.224.0
> DK> no ip directed-broadcast
> DK> !
> DK> interface Loopback113
> DK> ip address 11.11.128.1 255.255.128.0
> DK> no ip directed-broadcast
> DK> !
> DK> interface Ethernet0
> DK> ip address 10.10.21.6 255.255.255.0
> DK> no ip directed-broadcast
> DK> no ip route-cache
> DK> no ip mroute-cache
> DK> !
> DK> interface Serial0
> DK> ip address 11.11.1.2 255.255.255.252
> DK> no ip directed-broadcast
> DK> no ip route-cache
> DK> no ip mroute-cache
> DK> service-module 56k clock source internal
> DK> !
> DK> interface Serial1
> DK> no ip address
> DK> no ip directed-broadcast
> DK> no ip route-cache
> DK> no ip mroute-cache
> DK> shutdown
> DK> !
> DK> router eigrp 2
> DK> network 10.0.0.0
> DK> network 11.0.0.0
> DK> no auto-summary
> DK> !
> DK> ip classless
> DK> !
> DK> !
> DK> !
> DK> !
> DK> snmp-server community private RW
> DK> snmp-server system-shutdown
> DK> snmp-server enable traps snmp
> DK> snmp-server enable traps isdn call-information
> DK> snmp-server enable traps config
> DK> snmp-server enable traps entity
> DK> snmp-server enable traps bgp
> DK> snmp-server enable traps frame-relay
> DK> snmp-server enable traps rtr
> DK> snmp-server host 10.10.201.200 traps version 2c private
> DK> snmp-server host 10.10.203.202 traps private
> DK> alias exec ct config t
> DK> alias exec sb sh ip interface brief
> DK> alias exec sr sh runn
> DK> alias exec sip sh ip route
> DK> !
> DK> line con 0
> DK> exec-timeout 0 0
> DK> transport input none
> DK> line aux 0
> DK> transport input all
> DK> line vty 0 4
> DK> password msoft
> DK> login
> DK> !
> DK> end
>
> DK> 6#sip
> DK> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
>
> DK> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> DK> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> DK> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> DK> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
> DK> default
> DK> U - per-user static route, o - ODR
>
> DK> Gateway of last resort is not set
>
> DK> 10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
> DK> D EX 10.10.2.0/24 [170/3193856] via 11.11.1.1, 00:40:46, Serial0
> DK> C 10.10.21.0/24 is directly connected, Ethernet0
> DK> D 10.10.40.0/24 [90/2195456] via 11.11.1.1, 00:40:46, Serial0
> DK> D 10.10.60.0/24 [90/2681856] via 11.11.1.1, 00:40:46, Serial0
> DK> D 10.10.100.0/24 [90/2323456] via 11.11.1.1, 00:40:46, Serial0
> DK> D EX 10.10.244.0/24 [170/2809856] via 11.11.1.1, 00:40:46, Serial0
> DK> D EX 10.10.248.0/21 [170/3097600] via 11.11.1.1, 00:40:46, Serial0
> DK> D 10.10.251.0/24 [90/41049600] via 11.11.1.1, 00:40:46, Serial0
> DK> D 10.10.252.0/24 [90/287542016] via 11.11.1.1, 00:40:46, Serial0
> DK> 11.0.0.0/8 is variably subnetted, 4 subnets, 4 masks
> DK> C 11.11.1.0/30 is directly connected, Serial0
> DK> C 11.11.8.0/22 is directly connected, Loopback111
> DK> C 11.11.32.0/19 is directly connected, Loopback112
> DK> C 11.11.128.0/17 is directly connected, Loopback113
> --
> WBW, xander
> mailto:xander@adt.ru
> CCNA, CCNP+VoiceAccess, CCIE very soon :-)
>
> ...
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:44 GMT-3