From: Al Banks (abanks@xxxxxxxxxxxxxx)
Date: Tue Oct 24 2000 - 11:01:40 GMT-3
OSPF, over frame - one spoke and the hub form the neighbor relationship, no
problem. The other spoke doesn't - they stay in attempt/drother and
init/drother. All interfaces have "ip ospf network non-broadcast"
configured, all are pingable, and I've got the appropriate neighbor
statements.
>From the states, it looks like the hub (the one in attempt) is sending
hellos, but not getting any. The spoke (init) is getting hellos, but
doesn't see itself. The router ID on all of these is the serial interface
address (199.16.236.R#)
Any ideas why this is happening, or do I just need to go get some more sleep
and less coffee?
I've attached the configs - R3 is the hub, R6 is the misbehaving one, and R2
is the good one.
Thanks!
-Al
sh run
Building configuration...
Current configuration : 2301 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
boot system flash slot0:c7200-a3js56i-mz.121-4.bin
enable secret 5 $1$E.KE$6HTWyW5cw52bRNLIXTqvb1
enable password cisco
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
appletalk routing eigrp 3
ipx routing 0003.0003.0003
--More-- !
!
cns event-service server
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.34.3 255.255.255.0
half-duplex
!
interface FastEthernet1/0
ip address 172.16.30.3 255.255.255.0
half-duplex
appletalk cable-range 30-30 30.3
appletalk zone R3-30
ipx network 30
!
interface FastEthernet2/0
ip address 172.16.31.3 255.255.255.0
half-duplex
appletalk cable-range 31-31 31.3
--More-- appletalk zone R3-31
ipx network 31
!
interface Serial3/0
no ip address
encapsulation frame-relay
ip ospf network non-broadcast
no frame-relay inverse-arp
!
interface Serial3/0.35 point-to-point
ip address 172.16.35.3 255.255.255.0
frame-relay interface-dlci 301
!
interface Serial3/0.236 multipoint
ip address 199.16.236.3 255.255.255.0
no ip split-horizon
ip ospf network non-broadcast
appletalk cable-range 236-236 236.3
appletalk zone WAN
appletalk protocol eigrp
no appletalk protocol rtmp
ipx network 236
frame-relay map ip 199.16.236.2 302 broadcast
--More-- frame-relay map ip 199.16.236.6 304 broadcast
frame-relay map ipx 236.0003.a029.a000 302 broadcast
frame-relay map appletalk 236.2 302 broadcast
!
interface Serial3/1
no ip address
shutdown
!
interface Serial3/2
no ip address
shutdown
!
interface Serial3/3
no ip address
shutdown
!
!
router ospf 99
log-adjacency-changes
network 172.16.30.0 0.0.0.255 area 3
network 172.16.31.0 0.0.0.255 area 3
network 199.16.236.0 0.0.0.255 area 0
neighbor 199.16.236.6
--More-- neighbor 199.16.236.2
!
router igrp 99
redistribute connected
redistribute bgp 99 metric 1500 0 255 1 1500
network 172.16.0.0
!
router bgp 99
bgp log-neighbor-changes
neighbor 172.16.34.4 remote-as 40
neighbor 172.16.34.4 default-originate
!
ip classless
ip default-network 40.0.0.0
no ip http server
!
!
!
!
!
!
!
!
--More-- !
!
!
!
ipx router eigrp 99
network 236
!
!
ipx router rip
no network 236
!
!
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
login
!
--More-- end
R3#õ
R6-TermServer#sh run
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R6-TermServer
!
enable secret 5 $1$Cnob$FSdoRLVKT9yEwKPvAGaHV/
!
!
!
!
!
ip subnet-zero
ip host R1 2001 192.168.70.100
ip host R2 2002 192.168.70.100
ip host R3 2003 192.168.70.100
ip host R4 2004 192.168.70.100
ip host R5 2005 192.168.70.100
ip host R6 2006 192.168.70.100
--More-- ip host R7 2007 192.168.70.100
ip host Cat 2008 192.168.70.100
!
!
!
!
interface Ethernet0
ip address 192.168.70.100 255.255.255.0
ip access-group 100 in
!
interface Serial0
ip address 199.16.236.6 255.255.255.0
encapsulation frame-relay
ip ospf network non-broadcast
no ip mroute-cache
frame-relay map ip 199.16.236.2 402 broadcast
frame-relay map ip 199.16.236.3 402 broadcast
no frame-relay inverse-arp
!
interface Serial1
ip address 172.16.26.6 255.255.255.0
ip ospf network non-broadcast
!
--More-- router ospf 99
log-adjacency-changes
passive-interface Ethernet0
network 172.16.26.0 0.0.0.255 area 0
network 172.16.60.0 0.0.0.255 area 6
network 172.16.61.0 0.0.0.255 area 6
network 199.16.236.0 0.0.0.255 area 0
neighbor 199.16.236.3 priority 1
neighbor 172.16.26.2 priority 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.70.1
no ip http server
!
access-list 100 permit ip any host 192.168.70.100
!
line con 0
exec-timeout 0 0
transport input none
line 1 8
transport input all
line aux 0
line vty 0 4
--More-- exec-timeout 0 0
password 7 00071A150754
login
!
end
R6-TermServer# 2
[Resuming connection 2 to r2 ... ]
R2#sh run
Building configuration...
Current configuration : 2090 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
boot system flash slot0:c7200-a3js56i-mz.121-4.bin
enable secret 5 $1$CvTw$8Hw3qASGzUuqKqfCkO3rX.
enable password cisco
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
appletalk routing eigrp 2
ipx routing 0003.a029.a000
--More-- !
!
cns event-service server
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.12.2 255.255.255.0
half-duplex
appletalk cable-range 12-12 12.2
appletalk zone R1-R2
appletalk protocol eigrp
no appletalk protocol rtmp
ipx network 12
!
interface FastEthernet1/0
ip address 172.16.20.2 255.255.255.0
half-duplex
appletalk cable-range 20-20 20.2
appletalk zone R2-20
ipx network 20
--More-- !
interface FastEthernet2/0
ip address 172.16.21.2 255.255.255.0
half-duplex
appletalk cable-range 21-21 21.2
appletalk zone R2-21
ipx network 22
!
interface Serial3/0
ip address 199.16.236.2 255.255.255.0
encapsulation frame-relay
ip ospf network non-broadcast
ip ospf priority 0
appletalk cable-range 236-236 236.2
appletalk zone WAN
appletalk protocol eigrp
no appletalk protocol rtmp
ipx network 236
frame-relay map ipx 236.0003.0003.0003 203 broadcast
frame-relay map ip 199.16.236.3 203 broadcast
frame-relay map appletalk 236.3 203 broadcast
no frame-relay inverse-arp
!
--More-- interface Serial3/1
no ip address
shutdown
!
interface Serial3/2
no ip address
shutdown
!
interface Serial3/3
ip address 172.16.26.2 255.255.255.0
ip ospf network non-broadcast
clockrate 56000
!
!
router ospf 99
log-adjacency-changes
area 12 virtual-link 172.16.12.1
network 172.16.12.0 0.0.0.255 area 12
network 172.16.20.0 0.0.0.255 area 2
network 172.16.21.0 0.0.0.255 area 0
network 172.16.26.0 0.0.0.255 area 0
network 199.16.236.0 0.0.0.255 area 0
neighbor 172.16.26.6 priority 1
--More-- !
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
!
!
!
ipx router eigrp 99
network 236
!
!
ipx router rip
no network 236
!
!
--More-- !
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
login
!
end
R2#
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:29 GMT-3