DLSw+ over ISDN

From: Clifton Stewart (cliftonlstewart@xxxxxxxx)
Date: Mon Aug 28 2000 - 17:43:57 GMT-3


   
Does anyone know why the remote peer address can't be the bri interface?
Meaning if I set my remote-peer statements to the bri interfaces on each
side I loose my circuits. Although I can ping both sides no capabilities
exchanges occur. My initial thought is because of the icanreach
mac-address which points to the token-ring interfaces. Is this the best
method to use when implementing DDR with DLSw+? Thanks.

Clifton Stewart-CCNA, CCIE Candidate

=====================
CONFIGS
=====================

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname R2504a
!
!
username R2504b password 0 cisco
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-ni1
source-bridge ring-group 99
dlsw local-peer peer-id 10.11.1.4 promiscuous
dlsw remote-peer 0 tcp 10.11.1.5 keepalive 0 timeout 90<---Would peer to
10.11.6.2
dlsw icanreach mac-address 0007.789d.ec82 mask 0000.0000.0000
dlsw prom-peer-defaults cost 2
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 no ip address
 shutdown
!
interface TokenRing0
 ip address 10.11.1.4 255.255.255.0
 ring-speed 16
 source-bridge 25 1 99
 source-bridge spanning
!
interface BRI0
 ip address 10.11.6.1 255.255.255.0
 encapsulation ppp
 isdn spid1 0835866101 8358661
 isdn spid2 0835866301 8358663
 dialer map llc2 name R2504b broadcast 8358662
 dialer map ip 10.11.6.2 name R2504b broadcast 8358662
 dialer hold-queue 75
 dialer-group 1
 ppp authentication chap
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!
no ip classless
ip route 0.0.0.0 0.0.0.0 10.11.1.5
ip route 10.11.6.0 255.255.255.0 10.11.6.2
!
dialer-list 1 protocol ip list 103
!
line con 0
line aux 0
line vty 0 4
 no exec
 login
!
end

R2504a#

==========================================>
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2504b
!
!
username R2504a password 0 cisco
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-ni
!
source-bridge ring-group 99
dlsw local-peer peer-id 10.11.1.5 promiscuous
dlsw remote-peer 0 tcp 10.11.1.4 keepalive 0 timeout 90<--- Would peer
to 10.11.6.1
!
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 ip address 10.11.1.5 255.255.255.0
 no ip directed-broadcast
 ip ospf interface-retry 0
 ring-speed 16
 source-bridge 25 1 99
 source-bridge spanning
!
interface BRI0
 ip address 10.11.6.2 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 ip ospf interface-retry 0
 dialer map llc2 name R2504a broadcast
 dialer map ip 10.11.6.1 name R2504a broadcast
 dialer hold-queue 75
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866201 8358662
 isdn spid2 0835866401 8358664
 ppp authentication chap
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.11.1.4
ip route 10.11.1.0 255.255.255.0 10.11.6.1
!
dialer-list 1 protocol ip list 103
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 no exec
 login
!
end

R2504b#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:31 GMT-3