Callback is Killing me.

From: Kevin Gannon (kevin@xxxxxxxxxxx)
Date: Tue Apr 04 2000 - 16:35:58 GMT-3


   
I am trying to do simple ISDN callback and I get the following message on
the server
side (config attached):

BRI0:1: No callback configured for user r5.
BRI0:1: disconnecting call

However I have a dialer map-class to do callback using the username and I
have a
vlaid username on the server of:

username r5-callback callback-dialstring 4197038 password 0 cisco

The server sees the callback request drops the line in 1 second and never
calls
back (I checked this with a debug dialer and isdn q931).

I believe I have the same config as the samples on CCO, I would love to
see anyones working configs for this. One of our CCIE's tell me that there
is loads of bugs with this one and has ended up getting special code
versions
for doing this and CLI callabck :(.

Regards,
Kevin
r5#wr t
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r5
!
!
username r privilege 15 password 0 r
username ccie password 0 cisco
username r6 password 0 cisco
username r6-callback callback-dialstring 4197040 password 0 cisco
username r5 callback-dialstring 4197040
ip subnet-zero
no ip domain-lookup
appletalk routing
ipx routing 0007.0d5a.37f7
isdn switch-type basic-net3
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial0
 description Maps to S3 on FR-SW
 no ip address
 encapsulation frame-relay
 no fair-queue
 frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
!
interface Serial1
 no ip address
 shutdown
 ipx network 99
!
interface TokenRing0
 no ip address
 ip mobile arp
 appletalk cable-range 100-100 100.1
 appletalk zone r5-to
 ipx network 400
 ring-speed 4
!
interface BRI0
 ip address 10.10.10.1 255.255.255.0
 encapsulation ppp
 ip ospf demand-circuit
 shutdown
 appletalk cable-range 1-1 1.1
 appletalk zone link
 ipx network 100
 no ipx route-cache
 ipx watchdog-spoof
 ipx spx-spoof
 isdn answer1 4197038
 dialer map appletalk 1.2 name r6 4197040
 dialer map ipx 100.0007.789d.f6b4 name r5 broadcast 4197040
 dialer map ip 10.10.10.2 name r6 4197040
 dialer-group 1
 ppp callback request
 ppp authentication chap
!
router ospf 100
 passive-interface BRI0
 network 10.10.10.0 0.0.0.255 area 0
 network 1.1.1.0 0.0.0.255 area 4
!
ip mobile-host 172.20.1.45 172.20.2.1
ip classless
access-list 600 permit other-access broadcast-deny
!
!
!
ipx router rip
 no network 100
!
!
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol appletalk list 600
dialer-list 1 protocol ipx permit
privilege interface level 6 ip address
privilege interface level 6 ip
privilege configure level 6 interface
privilege exec level 0 write terminal
privilege exec level 0 write
privilege exec level 0 traceroute
privilege exec level 0 ping
privilege exec level 1 enable
privilege exec level 6 configure terminal
privilege exec level 6 configure
privilege exec level 0 show running-config
privilege exec level 0 show
privilege exec level 6 no
!
line con 0
 login local
line aux 0
line vty 0 4
 login local
!
end
r6#term len 0
r6#wr t
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r6
!
!
username r privilege 15 password 0 r
username r5-callback callback-dialstring 4197038 password 0 cisco
username r5 password 0 cisco
ip subnet-zero
no ip domain-lookup
appletalk routing
ipx routing 0007.789d.f6b4
isdn switch-type basic-net3
!
interface Loopback0
 ip address 20.20.20.2 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 shutdown
 frame-relay lmi-type cisco
!
interface Serial1
 no ip address
 ipx network 99
 clockrate 64000
!
interface TokenRing0
 no ip address
 appletalk cable-range 200-200 200.1
 appletalk zone r6-to0
 ipx network 300
 ring-speed 4
!
interface BRI0
 ip address 10.10.10.2 255.255.255.0
 encapsulation ppp
 appletalk cable-range 1-1 1.2
 appletalk zone link
 ipx network 100
 no ipx route-cache
 ipx watchdog-spoof
 ipx spx-spoof
 isdn answer1 4197040
 dialer callback-secure
 dialer enable-timeout 1
 dialer map appletalk 1.1 name r5 4197038
 dialer map ipx 100.0007.0d5a.37f7 name r5 broadcast 4197038
 dialer map ip 10.10.10.1 name r5 class callback 4197038
 dialer map ip 10.10.10.2 class callback
 dialer-group 1
 ppp callback accept
 ppp authentication chap
!
router ospf 100
 passive-interface BRI0
 network 10.10.10.0 0.0.0.255 area 0
 network 20.20.20.0 0.0.0.255 area 3
!
ip classless
!
map-class dialer callback
 dialer callback-server username
 dialer fast-idle 1
access-list 600 permit other-access broadcast-deny
!
!
ipx route 400 100.0007.0d5a.37f7 floating-static
!
ipx router rip
 no network 100
!
!
ipx sap 4 SERV4 100.0007.0d5a.37f7 15 1
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol appletalk list 600
dialer-list 1 protocol ipx permit
!
line con 0
 login local
line aux 0
line vty 0 4
 login local
!
end

r6#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:23:12 GMT-3