From: charles (mfortune@xxxxxxxx)
Date: Thu Apr 06 2000 - 03:48:46 GMT-3
r3 [c2500-js-l_112-19a]
username r5 password sanjose
!
interface BRI0
ip address 132.7.35.1 255.255.255.0
encapsulation ppp
isdn spid1 xxxxxxxxxx0101
isdn spid2 xxxxxxxxxx0101
dialer idle-timeout 360
dialer map ip 132.7.35.2 name r5 class callback broadcast xxxxxxxxxx
dialer-group 1
ppp callback accept
ppp authentication chap
!
map-class dialer callback
dialer callback-server username
!
dialer-list 1 prot ip list 1
acl 1 permit whatever
r5 [c2500-js-l_112-19a]
!
username r3 password sanjose
!
interface BRI0
ip address 132.7.35.2 255.255.255.0
encapsulation ppp
isdn spid1 xxxxxxxxxx0101
isdn spid2 xxxxxxxxxx0101
dialer idle-timeout 360
dialer map ip 132.7.35.1 name r3 class callback broadcast xxxxxxxxxx
dialer-group 1
ppp callback request
ppp authentication chap
!
!
map-class dialer callback
!
dialer-list 1 prot ip list 1
acl 1 permit whatever
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Joel W. Ekis
Sent: Tuesday, April 04, 2000 2:43 PM
To: Kevin Gannon; Ccielab@Groupstudy.Com
Subject: Re: Callback is Killing me.
Here's a simple Callback example with debugs. Note, I also changed the ppp
hostname for fun...
Bottom calls Top, authenticates, disconnects, then Top calls Bottom back.
hostname bottom
username new password 0 cisco
isdn switch-type basic-ni
!
interface Loopback0
ip address 172.16.10.1 255.255.255.0
!
interface Serial0
ip address 172.16.1.1 255.255.255.0
no ip mroute-cache
no fair-queue
!
interface BRI0
ip address 192.168.1.1 255.255.255.0
encapsulation ppp
dialer map ip 192.168.1.2 name new broadcast 83558662
dialer-group 1
isdn switch-type basic-ni
isdn spid1 0835866101
isdn spid2 0835866301
ppp callback request
ppp authentication chap
hold-queue 75 in
!
router eigrp 1
network 172.16.0.0
!
ip classless
!
dialer-list 1 protocol ip permit
hostname top
username bottom password 0 cisco
isdn switch-type basic-ni
!
interface Loopback0
ip address 172.16.20.1 255.255.255.0
!
interface Serial0
ip address 172.16.1.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
clockrate 2000000
!
interface BRI0
ip address 192.168.1.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer enable-timeout 2
dialer map ip 192.168.1.1 name bottom class jwe broadcast 8358661
dialer-group 1
isdn switch-type basic-ni
isdn spid1 0835866201
isdn spid2 0835866401
ppp callback accept
ppp authentication chap
ppp chap hostname new
!
router eigrp 1
network 172.16.0.0
!
ip classless
!
map-class dialer jwe
dialer callback-server username
dialer-list 1 protocol ip permit
01:03:04: BR0:1 PPP: Treating connection as a callout
01:03:04: BR0:1 PPP: Phase is ESTABLISHING, Active Open
01:03:04: BR0:1 LCP: O CONFREQ [Closed] id 5 len 18
01:03:04: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
01:03:04: BR0:1 LCP: MagicNumber 0xE0586998 (0x0506E0586998)
01:03:04: BR0:1 LCP: Callback 0 (0x0D0300)
01:03:04: BR0:1 LCP: I CONFREQ [REQsent] id 5 len 15
01:03:04: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
01:03:04: BR0:1 LCP: MagicNumber 0xE0584515 (0x0506E0584515)
01:03:04: BR0:1 LCP: O CONFACK [REQsent] id 5 len 15
01:03:04: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
01:03:04: BR0:1 LCP: MagicNumber 0xE0584515 (0x0506E0584515)
01:03:04: BR0:1 LCP: I CONFACK [ACKsent] id 5 len 18
01:03:04: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
01:03:04: BR0:1 LCP: MagicNumber 0xE0586998 (0x0506E0586998)
01:03:04: BR0:1 LCP: Callback 0 (0x0D0300)
01:03:04: BR0:1 LCP: State is Open
01:03:04: BR0:1 MCB: Initialize
01:03:04: BR0:1 PPP: Phase is AUTHENTICATING, by both
01:03:04: BR0:1 CHAP: O CHALLENGE id 5 len 27 from "bottom"
01:03:04: BR0:1 CHAP: I CHALLENGE id 5 len 24 from "new"
01:03:04: BR0:1 CHAP: O RESPONSE id 5 len 27 from "bottom"
01:03:04: BR0:1 CHAP: I SUCCESS id 5 len 4
01:03:04: BR0:1 CHAP: I RESPONSE id 5 len 24 from "new"
01:03:04: BR0:1 CHAP: O SUCCESS id 5 len 4
01:03:04: BR0:1 PPP: Phase is UP
01:03:04: BR0:1 IPCP: O CONFREQ [Closed] id 5 len 10
01:03:04: BR0:1 IPCP: Address 192.168.1.1 (0x0306C0A80101)
01:03:04: BR0:1 CDPCP: O CONFREQ [Closed] id 5 len 4
01:03:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed
state
to up
01:03:05: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from 8358662
new,
call lasted 1 seconds
01:03:05: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
01:03:05: BR0:1 IPCP: State is Closed
01:03:05: BR0:1 CDPCP: State is Closed
01:03:05: BR0:1 PPP: Phase is TERMINATING
01:03:05: BR0:1 LCP: State is Closed
01:03:05: BR0:1 PPP: Phase is DOWN
01:03:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed
state
to down
01:03:06: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
01:03:06: BR0:1 PPP: Treating connection as a callin
01:03:06: BR0:1 PPP: Phase is ESTABLISHING, Passive Open
01:03:06: BR0:1 LCP: State is Listen
01:03:07: BR0:1 LCP: I CONFREQ [Listen] id 6 len 15
01:03:07: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
01:03:07: BR0:1 LCP: MagicNumber 0xE0584FCB (0x0506E0584FCB)
01:03:07: BR0:1 LCP: O CONFREQ [Listen] id 6 len 15
01:03:07: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
01:03:07: BR0:1 LCP: MagicNumber 0xE058746F (0x0506E058746F)
01:03:07: BR0:1 LCP: O CONFACK [Listen] id 6 len 15
01:03:07: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
01:03:07: BR0:1 LCP: MagicNumber 0xE0584FCB (0x0506E0584FCB)
01:03:07: BR0:1 LCP: I CONFACK [ACKsent] id 6 len 15
01:03:07: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
01:03:07: BR0:1 LCP: MagicNumber 0xE058746F (0x0506E058746F)
01:03:07: BR0:1 LCP: State is Open
01:03:07: BR0:1 MCB: Initialize
01:03:07: BR0:1 PPP: Phase is AUTHENTICATING, by both
01:03:07: BR0:1 CHAP: O CHALLENGE id 6 len 27 from "bottom"
01:03:07: BR0:1 CHAP: I CHALLENGE id 6 len 24 from "new"
01:03:07: BR0:1 CHAP: Waiting for peer to authenticate first
01:03:07: BR0:1 CHAP: I RESPONSE id 6 len 24 from "new"
01:03:07: BR0:1 CHAP: O SUCCESS id 6 len 4
01:03:07: BR0:1 CHAP: Processing saved Challenge, id 6
01:03:07: BR0:1 CHAP: O RESPONSE id 6 len 27 from "bottom"
01:03:07: BR0:1 CHAP: I SUCCESS id 6 len 4
01:03:07: BR0:1 PPP: Phase is UP
01:03:07: BR0:1 IPCP: O CONFREQ [Closed] id 6 len 10
01:03:07: BR0:1 IPCP: Address 192.168.1.1 (0x0306C0A80101)
01:03:07: BR0:1 CDPCP: O CONFREQ [Closed] id 6 len 4
01:03:07: BR0:1 IPCP: I CONFREQ [REQsent] id 4 len 10
01:03:07: BR0:1 IPCP: Address 192.168.1.2 (0x0306C0A80102)
01:03:07: BR0:1 IPCP: O CONFACK [REQsent] id 4 len 10
01:03:07: BR0:1 IPCP: Address 192.168.1.2 (0x0306C0A80102)
01:03:07: BR0:1 CDPCP: I CONFREQ [REQsent] id 4 len 4
01:03:07: BR0:1 CDPCP: O CONFACK [REQsent] id 4 len 4
01:03:07: BR0:1 IPCP: I CONFACK [ACKsent] id 6 len 10
01:03:07: BR0:1 IPCP: Address 192.168.1.1 (0x0306C0A80101)
01:03:07: BR0:1 IPCP: State is Open
01:03:07: BR0:1 CDPCP: I CONFACK [ACKsent] id 6 len 4
01:03:07: BR0:1 CDPCP: State is Open
01:03:07: BR0 IPCP: Install route to 192.168.1.2
01:03:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed
state
to up
01:03:12: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 83558662 new
Joel
At 08:35 PM 4/4/2000 +0100, Kevin Gannon wrote:
>I am trying to do simple ISDN callback and I get the following message on
>the server
>side (config attached):
>
>BRI0:1: No callback configured for user r5.
>BRI0:1: disconnecting call
>
>However I have a dialer map-class to do callback using the username and I
>have a
>vlaid username on the server of:
>
>username r5-callback callback-dialstring 4197038 password 0 cisco
>
>The server sees the callback request drops the line in 1 second and never
>calls
>back (I checked this with a debug dialer and isdn q931).
>
>I believe I have the same config as the samples on CCO, I would love to
>see anyones working configs for this. One of our CCIE's tell me that there
>is loads of bugs with this one and has ended up getting special code
>versions
>for doing this and CLI callabck :(.
>
>Regards,
>Kevin
>
>
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:23:13 GMT-3