Try using multiple ospf process9s on R2 and redistribute from process 1 to
process 2 with metric-type 2 and R3 will see the new metric-type 2, if the
goal is to provide E2 rip routes to R3.
I lab9d this up and it works.
(rip R4)(rip-ospf1 R1)(R2 OSPF19area0' & OSPF29area19)(R3 OSPF2
area 1)
________________
Hostname R4
!
interface Loopback0
ip address 40.40.0.1 255.255.255.0
!
interface Loopback1
ip address 40.40.1.1 255.255.255.0
!
interface Loopback2
ip address 40.40.2.1 255.255.255.0
!
interface Loopback3
ip address 40.40.3.1 255.255.255.0
!
interface Loopback4
ip address 40.40.4.1 255.255.255.0
!
interface Loopback5
ip address 40.40.5.1 255.255.255.0
!
!
interface FastEthernet0/0
ip address 14.14.14.2 255.255.255.0
duplex auto
speed auto
!
!
router rip
version 2
network 14.0.0.0
network 40.0.0.0
no auto-summary
!
hostname R1
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 14.14.14.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
redistribute rip metric-type 1 subnets tag 120
network 12.12.12.1 0.0.0.0 area 0
!
router rip
version 2
passive-interface default
no passive-interface FastEthernet0/1
network 14.0.0.0
no auto-summary
!
________________________________________
hostname R2
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 12.12.12.2 0.0.0.0 area 0
!
router ospf 2
router-id 2.2.2.3
log-adjacency-changes
redistribute ospf 1 subnets
network 23.23.23.2 0.0.0.0 area 1
!
!
R2#sh ip route | b Gateway
Gateway of last resort is not set
23.0.0.0/24 is subnetted, 1 subnets
C 23.23.23.0 is directly connected, FastEthernet0/1
40.0.0.0/24 is subnetted, 6 subnets
O E1 40.40.0.0 [110/21] via 12.12.12.1, 00:19:52, FastEthernet0/0
O E1 40.40.1.0 [110/21] via 12.12.12.1, 00:19:52, FastEthernet0/0
O E1 40.40.2.0 [110/21] via 12.12.12.1, 00:19:52, FastEthernet0/0
O E1 40.40.3.0 [110/21] via 12.12.12.1, 00:19:52, FastEthernet0/0
O E1 40.40.4.0 [110/21] via 12.12.12.1, 00:19:52, FastEthernet0/0
O E1 40.40.5.0 [110/21] via 12.12.12.1, 00:19:52, FastEthernet0/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, FastEthernet0/0
14.0.0.0/24 is subnetted, 1 subnets
O E1 14.14.14.0 [110/21] via 12.12.12.1, 00:19:52, FastEthernet0/0
hostname Router3
!
interface FastEthernet0/0
ip address 23.23.23.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 23.23.23.1 0.0.0.0 area 1
!
Router3#sh ip route | b Gateway
Gateway of last resort is not set
23.0.0.0/24 is subnetted, 1 subnets
C 23.23.23.0 is directly connected, FastEthernet0/0
40.0.0.0/24 is subnetted, 6 subnets
O E2 40.40.0.0 [110/21] via 23.23.23.2, 00:12:46, FastEthernet0/0
O E2 40.40.1.0 [110/21] via 23.23.23.2, 00:12:46, FastEthernet0/0
O E2 40.40.2.0 [110/21] via 23.23.23.2, 00:12:46, FastEthernet0/0
O E2 40.40.3.0 [110/21] via 23.23.23.2, 00:12:46, FastEthernet0/0
O E2 40.40.4.0 [110/21] via 23.23.23.2, 00:12:46, FastEthernet0/0
O E2 40.40.5.0 [110/21] via 23.23.23.2, 00:12:46, FastEthernet0/0
12.0.0.0/24 is subnetted, 1 subnets
O E2 12.12.12.0 [110/1] via 23.23.23.2, 00:12:46, FastEthernet0/0
14.0.0.0/24 is subnetted, 1 subnets
O E2 14.14.14.0 [110/21] via 23.23.23.2, 00:12:46, FastEthernet0/0
Best Regards,
Joe Sanchez
On 12/18/13, 5:33 AM, "sameer khan" <khanzadap_at_hotmail.com> wrote:
>Thanks everyone, this scenario just came in my mind and all i though it
>cannot
>be done, but i was little bit wrong as i didn't thought about running
>multiple
>ospf processes. I think running multiple processes is the best case
>otherwise
>it might work or break
>
>
>> Date: Wed, 18 Dec 2013 11:59:56 +0100
>> Subject: Re: OSPF route-type per neighbor
>> From: alexeim73_at_gmail.com
>> To: sammybibs_at_gmail.com
>> CC: khanzadap_at_hotmail.com; ccielab_at_groupstudy.com
>>
>> distribute-list for OSPF won't work either, as it is designed for
>>filtering
>> OSPF routes from being installed in the RIP. Besides match ip address
>>in
>> this case is for route source which is OSPF router ID, has nothing to do
>> with actual prefix.
>> The only way I see is to run two OSPF processes on two sides of the
>>network
>> and do a route type manipulation while redistributing between them. But
>>as
>> Tony asked "why, oh why???" :-)
>>
>>
>> On 18 December 2013 10:14, Sam Bibby <sammybibs_at_gmail.com> wrote:
>>
>> > Sam,
>> >
>> > On R1 when redistributing set them as E2 as you put them in, that's
>>the
>> > easy part.
>> >
>> > For making them E1 on r2 on ingress you could *try*:
>> >
>> > !R2
>> > ip prefix-list SET->E1->To->E2 permit 1.1.1.0/24
>> > !
>> > route-map MED_TYPE_MOD permit 10
>> > match ip address prefix-list SET->E1->To->E2
>> > set metric-type type-1
>> > !
>> > route-map MED_TYPE_MOD permit 1000
>> > !
>> > Interface fas 0/0 !!!whatever interface is learning the routes
>> > ip policy route-map MED_TYPE_MOD
>> > !
>> >
>> >
>> > I am not saying this will work, but it may be worth giving it a shot
>>in
>> > the lab. Or you could try applying the route map within ospf:
>> > !!R2
>> > router osfp 1
>> > distribute-list route-map MED_TYPE_MOD in
>> >
>> > But as Al said, "would make the database inconsistent", so you prob
>>can
>do
>> > it, but you may break stuff.
>> >
>> > My 2 cents :)
>> >
>> > \Sam
>> >
>> >
>> >
>> >
>> > On Wed, Dec 18, 2013 at 8:59 AM, Alexei Monastyrnyi
><alexeim73_at_gmail.com>wrote:
>> >
>> >> Hi.
>> >> I reckon you can not, as the prefix is in the OSPF database and
>> >> manipulating the routs type on hop by hop basis would make the
>>database
>> >> inconsistent. Entire OSPF logic relies on the database being
>>consistent
>> >> across the board.
>> >>
>> >> Unless I am missing something.
>> >>
>> >> Cheers
>> >> A.
>> >>
>> >> Sent from my iPhone
>> >>
>> >> > On 18 dec 2013, at 09:39, sameer khan <khanzadap_at_hotmail.com>
>>wrote:
>> >> >
>> >> > hey folks
>> >> > 1.1.1.0/24|R1--R3| <http://1.1.1.0/24%7CR1--R3%7C> |R2--R4
>> >> >
>> >> > R1 is the asbr redistributing routes from rip (1.1.1.0/24). Is it
>> >> possible to
>> >> > set route-type to E1 for R2 and E2 for R3.
>> >> > Thanks
>> >> >
>> >> >
>> >> > Blogs and organic groups at http://www.ccie.net
>> >> >
>> >> >
>_______________________________________________________________________
>> >> > Subscription information may be found at:
>> >> > http://www.groupstudy.com/list/CCIELab.html
>> >>
>> >>
>> >> Blogs and organic groups at http://www.ccie.net
>> >>
>> >>
>>_______________________________________________________________________
>> >> Subscription information may be found at:
>> >> http://www.groupstudy.com/list/CCIELab.html
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>
>
>Blogs and organic groups at http://www.ccie.net
>
>_______________________________________________________________________
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Wed Dec 18 2013 - 07:20:53 ART
This archive was generated by hypermail 2.2.0 : Wed Jan 01 2014 - 20:26:19 ART