RE: BGP for address-family ipv6 issue

From: Brian McGahan <bmcgahan_at_ine.com>
Date: Thu, 19 Jan 2012 12:31:48 -0600

Post your "debug ip bgp". This will show what the error is during the
capabilities exchange.

Brian McGahan, CCIE #8593 (R&S/SP/Security)
bmcgahan_at_INE.com<mailto:bmcgahan_at_INE.com>

Internetwork Expert, Inc.
http://www.INE.com

From: GAURAV MADAN [mailto:gauravmadan1177_at_gmail.com]
Sent: Thursday, January 19, 2012 12:01 PM
To: Brian McGahan
Cc: Cisco certification
Subject: Re: BGP for address-family ipv6 issue

I think this is i did Brian ..

Forget next-hop for BGP learned routes .. my PE-CE session is giving following
error :

*Jan 18 22:51:34.291: %BGP-3-NOTIFICATION: received from neighbor 40.0.0.1
active 2/8 (no supported AFI/SAFI) 3 bytes 000101 (timer expired)

What address-family is mismatched ..

My configs are in earlier email ..

Thnx
Gaurav MAdan
On Thu, Jan 19, 2012 at 11:26 PM, Brian McGahan
<bmcgahan_at_ine.com<mailto:bmcgahan_at_ine.com>> wrote:
If you use IPv4 as the transport you need to manually set the next-hop of the
BGP learned routes to an IPv6 address. Here is an example config from my CCIE
SPv3 Advanced Technologies Class. The topology is:

R1--R2---MPLS---XR1--XR2

R1 and XR2 are the CEs, R2 and XR1 are the PEs running 6VPE. Note that on IOS
XR you don't need to change the next-hop to IPv6, it fixes this
automatically.

R1:
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
 ipv6 address 2001:10:1:1::1/128
!
interface FastEthernet0/0
 ip address 10.1.2.1 255.255.255.0
 ipv6 address 2001:10:1:2::1/64
!
router bgp 1
 network 10.1.1.1 mask 255.255.255.255
 neighbor 10.1.2.2 remote-as 100
 !
 address-family ipv6
 network 2001:10:1:1::1/128
 neighbor 10.1.2.2 activate
 neighbor 10.1.2.2 route-map 6VPE in
 exit-address-family
!
route-map 6VPE permit 10
 set ipv6 next-hop 2001:10:1:2::2

R2:
vrf definition A
 rd 100:1
 !
 address-family ipv4
 route-target export 100:1
 route-target import 100:1
 exit-address-family
 !
 address-family ipv6
 route-target export 100:1
 route-target import 100:1
 exit-address-family
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 20.2.2.2 255.255.255.255
!
interface FastEthernet1/0
 vrf forwarding A
 ip address 10.1.2.2 255.255.255.0
 ipv6 address 2001:10:1:2::2/64
!
router bgp 100
 no bgp default ipv4-unicast
 neighbor 10.1.2.1 remote-as 1
 neighbor 20.19.19.19 remote-as 100
 neighbor 20.19.19.19 update-source Loopback0
 !
 address-family vpnv4
 neighbor 20.19.19.19 activate
 neighbor 20.19.19.19 send-community extended
 exit-address-family
 !
 address-family vpnv6
 neighbor 20.19.19.19 activate
 neighbor 20.19.19.19 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf A
 neighbor 10.1.2.1 remote-as 1
 neighbor 10.1.2.1 activate
 exit-address-family
 !
 address-family ipv6 vrf A
 neighbor 10.1.2.1 remote-as 1
 neighbor 10.1.2.1 activate
 neighbor 10.1.2.1 route-map 6VPE in
 exit-address-family
!
route-map 6VPE permit 10
 set ipv6 next-hop 2001:10:1:2::1

XR1:
vrf A
 address-family ipv4 unicast
 import route-target
  100:1
 !
 export route-target
  100:1
 !
 !
 address-family ipv6 unicast
 import route-target
  100:1
 !
 export route-target
  100:1
 !
 !
!
interface Loopback0
 ipv4 address 20.19.19.19 255.255.255.255
!
interface GigabitEthernet0/1/0/2
 vrf A
 ipv4 address 10.19.20.19 255.255.255.0
 ipv6 address 2001:10:19:20::19/64
!
route-policy PASS
 pass
end-policy
!
router bgp 100
 address-family vpnv4 unicast
 !
 address-family vpnv6 unicast
 !
 neighbor 20.2.2.2
 remote-as 100
 update-source Loopback0
 address-family vpnv4 unicast
 !
 address-family vpnv6 unicast
 !
 !
 vrf A
 rd 100:1
 address-family ipv4 unicast
 !
 address-family ipv6 unicast
 !
 neighbor 10.19.20.20
  remote-as 20
  address-family ipv4 unicast
   route-policy PASS in
   route-policy PASS out
  !
  address-family ipv6 unicast
   route-policy PASS in
   route-policy PASS out
  !
 !
 !
!

XR2:
interface Loopback0
 ipv4 address 10.20.20.20 255.255.255.255
 ipv6 address 2001:10:20:20::20/128
!
interface GigabitEthernet0/4/0/2
 ipv4 address 10.19.20.20 255.255.255.0
 ipv6 address 2001:10:19:20::20/64
!
route-policy PASS
 pass
end-policy
!
router bgp 20
 address-family ipv4 unicast
 network 10.20.20.20/32<http://10.20.20.20/32>
 !
 address-family ipv6 unicast
 network 2001:10:20:20::20/128
 !
 neighbor 10.19.20.19
 remote-as 100
 address-family ipv4 unicast
  route-policy PASS in
  route-policy PASS out
 !
 address-family ipv6 unicast
  route-policy PASS in
  route-policy PASS out
 !
 !
!

HTH,

Brian McGahan, CCIE #8593 (R&S/SP/Security)
bmcgahan_at_INE.com<mailto:bmcgahan_at_INE.com>

Internetwork Expert, Inc.
http://www.INE.com

-----Original Message-----
From: nobody_at_groupstudy.com<mailto:nobody_at_groupstudy.com>
[mailto:nobody_at_groupstudy.com<mailto:nobody_at_groupstudy.com>] On Behalf Of
GAURAV MADAN
Sent: Thursday, January 19, 2012 11:35 AM
To: Cisco certification
Subject: Re: BGP for address-family ipv6 issue

Thnx to all who responded ..

This is a part of 6VPE thing that I am doing and I think that what I am doing
is right .

We can have a either IPV4 neighbor relationship between a PE and CE and
advertise a IPV6 prefix from CE Or We can have a IPV6 neighbor relationship
between PE and a CE and advertise a IPV6 prefix from CE

Option B work for me .. However Option A is giving problems

Any comments

Thnx in advance
Gaurav Madan

On Thu, Jan 19, 2012 at 11:24 AM, GAURAV MADAN
<gauravmadan1177_at_gmail.com<mailto:gauravmadan1177_at_gmail.com>>wrote:

> Any idea experts ..?
>
>
>
> ---------- Forwarded message ----------
> From: GAURAV MADAN
<gauravmadan1177_at_gmail.com<mailto:gauravmadan1177_at_gmail.com>>
> Date: Wed, Jan 18, 2012 at 10:56 PM
> Subject: BGP for address-family ipv6 issue
> To: Cisco certification
<ccielab_at_groupstudy.com<mailto:ccielab_at_groupstudy.com>>
>
>
> Hi All
>
> I have a very simple setup as follows . My intent is to let BGP form a
> transport session using IPV4 reachability and then using
> address-family
> IPV6 .. I am advertising route from R5 to R4 :
>
>
> R4 f/1(VRF) (40.0.0.1)---------------------------- (40.0.0.2) f1/0 R5
>
> R4 in AS 200
> R5 in AS 100
>
> R4 config
> =========
>
> R4#sh run | sec router bgp
> router bgp 200
> no synchronization
> bgp log-neighbor-changes
> no auto-summary
> !
> address-family ipv4 vrf TEST
> no synchronization
> exit-address-family
> !
> address-family ipv6 vrf TEST
> no synchronization
> neighbor 40.0.0.2 remote-as 100
> neighbor 40.0.0.2 activate
> exit-address-family
>
>
>
> R4#sh run int f1/1
> Building configuration...
>
> Current configuration : 142 bytes
> !
> interface FastEthernet1/1
> vrf forwarding TEST
> ip address 40.0.0.1 255.255.255.0
> speed auto
> duplex auto
> ipv6 address 2001:54::4/64
> end
>
>
> R5 Config
> ==========
> R5(config)#do sh run | sec router bgp
> router bgp 100
> no synchronization
> bgp log-neighbor-changes
> neighbor 40.0.0.1 remote-as 200
> no auto-summary
> !
> address-family ipv6
> no synchronization
> network 2001::5/128
> neighbor 40.0.0.1 activate
> exit-address-family
> R5(config)#
>
>
> Following is error message :
>
> *Jan 18 22:51:34.291: %BGP-3-NOTIFICATION: received from neighbor
> 40.0.0.1 active 2/8 (no supported AFI/SAFI) 3 bytes 000101 (timer
> expired)
>
> I feel that i have properly configured the address family to form IPV6
> neighbors .
> Please let me know where am i missing .
>
> Thanks
> Gaurav Madan

Blogs and organic groups at http://www.ccie.net
Received on Thu Jan 19 2012 - 12:31:48 ART

This archive was generated by hypermail 2.2.0 : Thu Feb 02 2012 - 11:52:51 ART