Re: redistribution help

From: marc edwards <renorider_at_gmail.com>
Date: Sun, 15 Jan 2012 14:53:26 -0800

!
router eigrp 162
 redistribute ospf 1 metric 10000 10 255 1 1500 route-map ospf
 redistribute rip metric 10000 10 255 1 1500 route-map rip
 network 135.15.16.1 0.0.0.0
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 area 10 virtual-link 135.15.104.1
 redistribute eigrp 162 subnets route-map eigrp
 redistribute rip subnets route-map rip
 network 135.15.12.1 0.0.0.0 area 20
 network 135.15.13.1 0.0.0.0 area 10
 network 135.15.14.1 0.0.0.0 area 10
 neighbor 135.15.12.2
!
router rip
 version 2
 redistribute ospf 1 metric 3 route-map ospf
 redistribute eigrp 162 metric 3 route-map eigrp
 passive-interface default
 no passive-interface FastEthernet0/1.50
 network 135.15.0.0
 no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
ip access-list standard eigrp
 permit 135.15.26.0
 permit 135.15.16.0
 permit 135.15.106.0
ip access-list standard ospf
 permit 135.15.10.0
 permit 135.15.34.0
ip access-list standard rip
 permit 135.15.25.0
 permit 135.15.20.0
 permit 135.15.23.0
 permit 135.15.35.0
 permit 135.15.105.0
 permit 135.15.102.0
 permit 135.15.103.0
!
!
!
!
route-map ospf permit 10
 match ip address ospf
!
route-map eigrp permit 10
 match ip address eigrp
!
route-map rip permit 10
 match ip address rip
!

On Sun, Jan 15, 2012 at 2:40 PM, marc edwards <renorider_at_gmail.com> wrote:

> Evening/Morning/Salutations Experts:
>
> I am quickly ending my game performing some mutual redistribution of
> eigrp<->ospf, eigrp<->rip, rip<->ospf. I attempted to reduce redistributed
> routes with route-maps that reference an access list that permits routes
> from the IGP.
>
> ex:
>
> !
> router eigrp 162
> redistribute ospf 1 metric 10000 10 255 1 1500 route-map ospf
> network 135.15.16.1 0.0.0.0
> no auto-summary
> !
> router ospf 1
> log-adjacency-changes
> area 10 virtual-link 135.15.104.1
> redistribute eigrp 162 subnets route-map eigrp
> redistribute rip subnets route-map rip
> network 135.15.12.1 0.0.0.0 area 20
> network 135.15.13.1 0.0.0.0 area 10
> network 135.15.14.1 0.0.0.0 area 10
> neighbor 135.15.12.2
> !
> router rip
> version 2
> redistribute ospf 1 metric 3 route-map ospf
> redistribute eigrp 162 metric 3 route-map eigrp
> passive-interface default
> no passive-interface FastEthernet0/1.50
> network 135.15.0.0
> no auto-summary
> !
> ip forward-protocol nd
> !
> !
> ip http server
> no ip http secure-server
> !
> ip access-list standard eigrp
> permit 135.15.26.0
> permit 135.15.16.0
> permit 135.15.106.0
> ip access-list standard ospf
> permit 3.3.3.0
> permit 111.1.1.1
> permit 135.15.10.0
> permit 135.15.12.0
> permit 135.15.13.0
> permit 135.15.14.0
> permit 135.15.34.0
> ip access-list standard rip
> permit 135.15.25.0
> permit 135.15.20.0
> permit 135.15.23.0
> permit 135.15.35.0
> permit 135.15.105.0
> permit 135.15.102.0
> permit 135.15.103.0
> !
>
> Got forked up somewhere and do not see all routes from farthest neighbor
> r5. This is currently the first and only router I have
> performed redistribution on.
>
> *Jan 16 07:39:18.030: RT: add 135.15.20.0/24 via 135.15.21.2, rip metric
> [120/2]
> *Jan 16 07:39:18.030: RT: NET-RED 135.15.20.0/24
> *Jan 16 07:39:18.030: RT: add 135.15.35.0/24 via 135.15.21.2, rip metric
> [120/2]
> *Jan 16 07:39:18.030: RT: NET-RED 135.15.35.0/24
> *Jan 16 07:39:18.034: RT: add 135.15.105.0/24 via 135.15.21.2, rip metric
> [120/2]
> *Jan 16 07:39:18.034: RT: NET-RED 135.15.105.0/24
> *Jan 16 07:39:20.058: RT: del 135.15.20.0/24 via 135.15.21.2, rip metric
> [120/2]
> *Jan 16 07:39:20.058: RT: delete subnet route to 135.15.20.0/24
> *Jan 16 07:39:20.058: RT: NET-RED 135.15.20.0/24
> *Jan 16 07:39:20.058: RT: del 135.15.35.0/24 via 135.15.21.2, rip metric
> [120/2]
> *Jan 16 07:39:20.058: RT: delete subnet route to 135.15.35.0/24
> *Jan 16 07:39:20.058: RT: NET-RED 135.15.35.0/24
> *Jan 16 07:39:20.062: RT: del 135.15.105.0/24 via 135.15.21.2, rip metric
> [120/2]
> *Jan 16 07:39:20.062: RT: delete subnet route to 135.15.105.0/24
> *Jan 16 07:39:20.062: RT: NET-RED 135.15.105.0/24
> *Jan 16 07:39:22.866: RT: add 135.15.103.0/24 via 135.15.21.2, rip metric
> [120/2]
> *Jan 16 07:39:22.866: RT: NET-RED 135.15.103.0/24
> *Jan 16 07:39:24.894: RT: del 135.15.103.0/24 via 135.15.21.2, rip metric
> [120/2]
> *Jan 16 07:39:24.894: RT: delete subnet route to 135.15.103.0/24
>
> please advise...
>
> Marc

Blogs and organic groups at http://www.ccie.net
Received on Sun Jan 15 2012 - 14:53:26 ART

This archive was generated by hypermail 2.2.0 : Thu Feb 02 2012 - 11:52:51 ART