In both scenarios, assuming SW2 is setup properly to trust and pass things
through that is expected behavior. "mls qos cos <value>" will assign the
given CoS value to any UNTAGGED frames entering the interface IF you are
trusting CoS there. You are not trusting CoS in the examples where CoS
ends up being 0 on the other end. SW1 is overwriting the CoS 6 set by R1
with a default CoS of 0.
Scenario 1.1 -- You are tagging the frames with a dot1q header and in that
header is a VLAN tag of 6. Since the ingress switch port does not trust
CoS it doesn't matter, and the switch overwrites the CoS to 0
Scenario 2.1 -- You are NOT tagging the frames with a dot1q header at all
because you are using the native VLAN. Therefore, an untagged frame
arrives on SW1 with no vlan tag. SW1's ingress interface has "mls qos cos
2" but it does not have "mls qos trust cos" so the CoS is not set.
On Wed, Jan 4, 2012 at 10:47 AM, Hasse <eriksson.hans_at_gmail.com> wrote:
> Question is why is there an Cos0 when having R1 with cos6 and Sw1 with
> cos2,
> it does not matter if the vlan is tagged or untagged as expected.
>
>
> I am doing some testing and config.
>
> Topology
>
> R1---------
> |
> |---------SW1--------SW2-----------R3
> |
> R2---------
>
> R1
> !
> interface FastEthernet0/0.100
> encapsulation dot1Q 100 native
> ip address 10.1.1.1 255.255.255.0
> service-policy output Ecos6
> end
>
> SW1 different but trunk to R1 only the Cos that changes
>
> R3 just a verification point
> !
> interface FastEthernet0/1.100
> encapsulation dot1Q 100
> ip address 10.1.1.3 255.255.255.0
> service-policy input cos0-7
> end
>
>
>
> This is the result
>
> One
> MLS QoS enabled on switch and q-tagged vlan
> R1 always cos6 out
> R3 just verification
> SW1 diffrent config.
>
> -Sw1 cos2
> result cos0 on R3 = why?
> -Sw1 cos2 and trust cos
> result cos6 on R3 = OK
> -Sw1 cos2 and override
> result cos2 on R3 = OK
>
> Two
> MLS QoS enabled on switch and Native Vlan
> R1 always cos6 out
> R3 just verification
> SW1 diffrent config.
>
> -Sw1 cos2
> result cos0 on R3 = why?
> -Sw1 cos2 and trust cos
> result cos2 on R3 = OK
> -Sw1 cos2 and override
> result cos6 on R3 = OK
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>
>
-- Regards, Joe Astorino CCIE #24347 Blog: http://astorinonetworks.com "He not busy being born is busy dying" - Dylan Blogs and organic groups at http://www.ccie.netReceived on Wed Jan 04 2012 - 11:08:46 ART
This archive was generated by hypermail 2.2.0 : Thu Feb 02 2012 - 11:52:51 ART