Hi i need help with the below question
Note : the diagram can be found on http://www.mediafire.com/?qd0b7jgy8rjn8ke
Configure R4 to be the master controller and R1 and R2 to be the Border routers.
The OER implementation should be optimized such that when the
packets with a DSCP of 41 is passing through the network, it is routed out to
R1 exit interface and also, when a DSCP of 31 is passing through, it is routed
out to R2 exit interface.
You are allowed to create only one ACL to accomplish this task.
Set active probes only
R1#sh run | sec key chain
key chain KEY
key 1
key-string CISCO
R1#sh run | sec oer border
oer border
logging
local Loopback0
master 1.1.4.4 key-chain KEY
R1#sh run int tun 0
interface Tunnel0
ip address 1.1.12.1 255.255.255.0
tunnel source Loopback0
tunnel destination 1.1.2.2
end
R2#sh run | sec key chain
key chain KEY
key 1
key-string CISCO
R2#sh run | sec oer border
oer border
logging
local Loopback0
master 1.1.4.4 key-chain KEY
R2#sh run int tun 0
interface Tunnel0
ip address 1.1.12.2 255.255.255.0
tunnel source Loopback0
tunnel destination 1.1.1.1
R4#sh run | sec key chain
key chain KEY
key 1
key-string CISCO
R4#sh run | sec oer master
oer master
policy-rules MAP
logging
!
border 1.1.1.1 key-chain KEY
interface FastEthernet0/0 external
interface Serial0/0 internal
interface Tunnel0 internal
!
border 1.1.2.2 key-chain KEY
interface FastEthernet0/0 external
interface Serial0/0 internal
interface Tunnel0 internal
no max range receive
R4#sh run | sec ip access
ip access-list extended CS2
permit ip 1.1.44.0 0.0.0.255 1.1.58.0 0.0.0.255 dscp cs2
ip access-list extended CS4
permit ip 1.1.44.0 0.0.0.255 1.1.58.0 0.0.0.255 dscp cs4
ip access-list extended EF
permit ip host 31.31.44.100 host 31.31.58.5 dscp ef
R4#sh run | sec oer-map
oer-map MAP 10
match traffic-class access-list CS2
set mode route control
set next-hop 1.1.17.7
oer-map MAP 20
match traffic-class access-list CS4
set mode route control
set next-hop 1.1.29.10
oer-map DSCP 30
match traffic-class access-list EF
set delay threshold 40
set jitter threshold 100
set active-probe jitter 31.31.58.5 target-port 1024 codec g729a
set probe frequency 20
R4#sh oer master traffic-class
OER Prefix Statistics:
Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
P - Percentage below threshold, Jit - Jitter (ms),
MOS - Mean Opinion Score
Los - Packet Loss (packets-per-million), Un - Unreachable (flows-per-million),
E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
# - Prefix monitor mode is Special, & - Blackholed Prefix
% - Force Next-Hop, ^ - Prefix is denied
DstPrefix Appl_ID Dscp Prot SrcPort DstPort SrcPrefix
Flags State Time CurrBR CurrI/F Protocol
PasSDly PasLDly PasSUn PasLUn PasSLos PasLLos EBw IBw
ActSDly ActLDly ActSUn ActLUn ActSJit ActPMOS
--------------------------------------------------------------------------------
1.1.58.0/24 N ef 256 N N 1.1.44.0/24
DEFAULT* 628 1.1.2.2 Fa0/0 U
1.1.58.0/24 N cs4 256 N N 1.1.44.0/24
% INPOLICY* 0 1.1.2.2 Fa0/0 PBR
U U 0 0 0 0 1 1
U U 0 0 N N
1.1.58.0/24 N cs2 256 N N 1.1.44.0/24
% INPOLICY* 0 1.1.1.1 Fa0/0 PBR
U U 0 0 0 0 1 1
U U 0 0 N N
R1#sh ip policy
Interface Route map
Fa0/0 OER-03/02/02-00:09:34.454-8-OER (Dynamic)
Serial0/0 OER-03/02/02-00:09:34.450-7-OER (Dynamic)
Tunnel0 OER-03/02/02-00:09:34.450-7-OER (Dynamic)
R1#sh ip access-lists dynamic
Extended IP access list oer#5
1073741823 permit ip 1.1.44.0 0.0.0.255 1.1.58.0 0.0.0.255 dscp cs2 (100 matches)
Extended IP access list oer#6
1073741823 permit ip 1.1.44.0 0.0.0.255 1.1.58.0 0.0.0.255 dscp cs2
Extended IP access list oer#7
1073741823 permit ip 1.1.44.0 0.0.0.255 1.1.58.0 0.0.0.255 dscp cs4
Extended IP access list oer#8
1073741823 permit ip 1.1.44.0 0.0.0.255 1.1.58.0 0.0.0.255 dscp cs4
R2#sh ip policy
Interface Route map
Fa0/0 OER-03/02/02-00:09:38.086-8-OER (Dynamic)
Serial0/0 OER-03/02/02-00:09:38.070-7-OER (Dynamic)
Tunnel0 OER-03/02/02-00:09:38.070-7-OER (Dynamic)
R2#sh ip access-lists dynamic
Extended IP access list oer#5
1073741823 permit ip 1.1.44.0 0.0.0.255 1.1.58.0 0.0.0.255 dscp cs2 (122 matches)
Extended IP access list oer#6
1073741823 permit ip 1.1.44.0 0.0.0.255 1.1.58.0 0.0.0.255 dscp cs2
Extended IP access list oer#7
1073741823 permit ip 1.1.44.0 0.0.0.255 1.1.58.0 0.0.0.255 dscp cs4 (122 matches)
Extended IP access list oer#8
1073741823 permit ip 1.1.44.0 0.0.0.255 1.1.58.0 0.0.0.255 dscp cs4
i
am not sure my solution is correct , why does R2 counts double R2 even
the next hop is set on both ? what i am missing ? should i set route
control ? or just monitor ?
Blogs and organic groups at http://www.ccie.net
Received on Sun Dec 18 2011 - 16:35:17 ART
This archive was generated by hypermail 2.2.0 : Sun Jan 01 2012 - 08:27:00 ART