Hi Joe,
Here's an example that doesn't use NBAR - I think the important part is to
include the "voip" keyword when you specify using auto qos
We start from here:
R1(config)#do sh run int s0/1
interface Serial0/1
bandwidth 512
ip address 10.1.13.1 255.255.255.0
end
R1(config-if)#int s0/1
R1(config-if)#auto qos voip trust
R1(config-if)#
*Mar 1 19:10:02.823: %LINK-3-UPDOWN: Interface Multilink2001100117,
changed state to down
*Mar 1 19:10:03.999: %RMON-5-FALLINGTRAP: Falling trap is generated
because the value of cbQosCMDropBitRate.162.632273 has fallen below the
falling-threshold value 0
*Mar 1 19:10:05.975: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/1, changed state to down
R1(config-if)#do sh run int s0/1
Building configuration...
Current configuration : 180 bytes
!
interface Serial0/1
bandwidth 512
no ip address
encapsulation ppp
auto qos voip trust
no fair-queue
clock rate 2000000
ppp multilink
ppp multilink group 2001100117
end
R1(config-if)#do sh auto qos int s0/1
Serial0/1 -
!
interface Serial0/1
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 2001100117
!
interface Multilink2001100117
bandwidth 512
ip address 10.1.13.1 255.255.255.0
ppp multilink
ppp multilink interleave
ppp multilink group 2001100117
ppp multilink fragment delay 10
service-policy output AutoQoS-Policy-Trust
ip rtp header-compression iphc-format
R1(config-if)#do sh policy-map
Policy Map AutoQoS-Policy-Trust
Class AutoQoS-VoIP-RTP-Trust
Strict Priority
Bandwidth 70 (%)
Class AutoQoS-VoIP-Control-Trust
Bandwidth 5 (%) Max Threshold 64 (packets)
Class class-default
Flow based Fair Queueing
Bandwidth 0 (kbps) Max Threshold 64 (packets)
R1(config-if)#do sh class-map
Class Map match-any class-default (id 0)
Match any
Class Map match-any AutoQoS-VoIP-RTP-Trust (id 1)
Match ip dscp ef (46)
Class Map match-any AutoQoS-VoIP-Control-Trust (id 2)
Match ip dscp cs3 (24)
Match ip dscp af31 (26)
As you can see NBAR is not used in classification here when we use auto qos
voip trust - if you don't use the trust keyword, the policy-map and
class-maps will be different but still will not be relying on NBAR - so my
guess would be you need to use "auto qos voip" rather than "auto qos" on
its own
Cheers,
Adam
On Sun, Nov 20, 2011 at 12:11 AM, George J. Sanchez <marco207p_at_gmail.com>wrote:
> I have to research this in greater detail, however I do not believe I've
> ever ran the auto QoS without the discovery command, I could only think of
> running auto QoS and if it uses the match protocol, I would have to quickly
> copy, paste, modify and paste back into the config. I however believe
> there should be a method to run the auto QoS like you mentioned with or
> without a parameter to accomplish this task.
>
> Regards,
> Joe Sanchez
>
> On Nov 19, 2011, at 3:05 AM, Adam Booth <adam.booth_at_gmail.com> wrote:
>
> Hi Joe,
>
> I believe that the idea is that you should avoid using "auto discovery
> qos" because that would use NBAR.
>
> How do you believe you should interpret things?
>
> Cheers,
> Adam
>
>
>
> On Sat, Nov 19, 2011 at 6:25 PM, George J. Sanchez < <marco207p_at_gmail.com>
> marco207p_at_gmail.com> wrote:
>
>> Let's say that you are required to configure auto QoS between two routers
>> on a serial interface, but you have to ensure that the routers do not use
>> protocols to match traffic in the configuration?
>>
>> What is the quickest method to accomplish this task?
>>
>> Regards,
>> Joe Sanchez
>>
>>
>> Blogs and organic groups at <http://www.ccie.net>http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> <http://www.groupstudy.com/list/CCIELab.html>
>> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Sun Nov 20 2011 - 09:11:35 ART
This archive was generated by hypermail 2.2.0 : Thu Dec 01 2011 - 06:29:31 ART