MPLS AToM

From: Nick Jay <wanttobeccde_at_yahoo.com>
Date: Sat, 2 Jul 2011 13:11:54 -0700 (PDT)

Hi Folks,

I am trying to work out some L2TP pseudowire emulation in GNS3. I
am trying to run frame relay over MPLS. I see status to be down. Attached is
the configuration file for R2 and R3 .. Can anyone help me in figuring out
what could be wrong in the config please?

R2#sh mpls l2transport vc 1

Local
intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ----------
----------
Se1/0 FR DLCI 100 2.2.2.2 1
 DOWN

When running a debug command "debug mpls l2transport vc events" I get
this.

*Mar 1 03:14:45.783: AToM SMGR: VC [2.2.2.2, 1]: default route not
available: entry had no valid path
CE1--------------->(S1/0)PE1(F0/0)---------->(F0/0)PE2(S1/0)-------->CE2
PE1
and PE2 are acting as frame relay switches with FR switching enabled.

R2#sh
mpls ldp discovery
 Local LDP Identifier:
    1.1.1.1:0
    Discovery Sources:
    Interfaces:
        FastEthernet0/0 (ldp): xmit/recv
            LDP Id:
2.2.2.2:0
        Serial1/0 (ldp): xmit
    Targeted Hellos:
        1.1.1.1
-> 2.2.2.2 (ldp): active/passive, xmit/recv
            LDP Id: 2.2.2.2:0
R2#sh mpls interface
Interface IP Tunnel Operational
FastEthernet0/0 Yes (ldp) No Yes
Serial1/0 Yes
(ldp) No Yes

R2#sh mpls ldp neighbor
    Peer LDP Ident: 2.2.2.2:0;
Local LDP Ident 1.1.1.1:0
        TCP connection: 2.2.2.2.25231 - 1.1.1.1.646
        State: Oper; Msgs sent/rcvd: 18/18; Downstream
        Up time:
00:09:42
        LDP discovery sources:
          FastEthernet0/0, Src IP
addr: 10.10.10.1
          Targeted Hello 1.1.1.1 -> 2.2.2.2, active, passive
        Addresses bound to peer LDP Ident:
          2.2.2.2
10.10.10.1
----PLEASE LET ME KNOW IF ANY OTHER OUTPUT NEEDS TO BE SHARED----
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
frame-relay switching
mpls label protocol ldp
mpls traffic-eng tunnels
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
pseudowire-class TEST
 encapsulation mpls
 interworking ip
 preferred-path interface Tunnel1
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Tunnel1
 ip unnumbered Loopback0
 shutdown
 mpls ip
 tunnel destination 2.2.2.2
!
interface FastEthernet0/0
 ip address 10.10.10.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 mpls ip
 serial restart-delay 0
 clock rate 64000
 frame-relay intf-type dce
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.10.10.2 0.0.0.0 area 0
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 update-source Loopback0
 !
 address-family ipv4
  redistribute static
  neighbor 2.2.2.2 activate
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family vpnv4
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community both
 exit-address-family
!
ip route 0.0.0.0 0.0.0.0 Tunnel1
!
!
no ip http server
no ip http secure-server
!
connect FR Serial1/0 100 l2transport
 xconnect 2.2.2.2 1 encapsulation mpls
 !
!
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!

!
webvpn cef
!
end
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
frame-relay switching
mpls label protocol ldp
mpls traffic-eng tunnels
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
pseudowire-class TEST
 encapsulation mpls
 interworking ip
 preferred-path interface Tunnel1
!
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Tunnel1
 ip unnumbered Loopback0
 shutdown
 mpls ip
 tunnel destination 1.1.1.1
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 mpls ip
 serial restart-delay 0
 clock rate 64000
 frame-relay intf-type dce
!
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 10.10.10.1 0.0.0.0 area 0
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback0
 !
 address-family ipv4
  redistribute static
  neighbor 1.1.1.1 activate
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community both
 exit-address-family
!
ip route 0.0.0.0 0.0.0.0 Tunnel1
!
!
no ip http server
no ip http secure-server
!
connect FR Serial1/0 200 l2transport
 xconnect 1.1.1.1 1 encapsulation mpls
 !
!
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!

!
webvpn cef
!
end

Blogs and organic groups at http://www.ccie.net
Received on Sat Jul 02 2011 - 13:11:54 ART

This archive was generated by hypermail 2.2.0 : Mon Aug 01 2011 - 06:30:05 ART