Re: How to advertise ethernet IP as /32 in BGP

From: jules NYA BAWEU <nyabaweu_at_gmail.com>
Date: Thu, 31 Mar 2011 08:44:24 -0700

I'm sorry for the delay; needed to catch up on sleep - I see Adam already
answered the question with regard to my config.

Actually I like Gary's idea better:
-----------------------
int loop32
ip add 32.32.32.32 255.255.255.255

int f0/1.1
ip unnumbered Loopback32

router bgp 32
network 32.32.32.32 255.255.255.255
-----------------------

I don't think you will be able to ping the device next to you with the above
without static; I think you could also get the connectivity once IGP is
enabled on the interfaces - prob just RIP/EIGRP not OSPF.

On Wed, Mar 30, 2011 at 9:38 PM, Mathew <mathewfer_at_gmail.com> wrote:

> Hi Jules,
>
> Thank you again for your reply & testing it.
>
> How did you get the loopback configured with the same IP as Ethernet
> with /32 mask.
> For me, I can not get the loopback. Did you have the Ethernet also
> with the same address but different mask - like 24. See below.
> I think if I can get the loopback interface configured, we can
> advertise it straight in BGP. Is'n it?
>
> What am I missing here?
>
> Please check your configuration again for me, how you tested it & let
> us see your full config with the IOS ver tested.
>
> Thank you again for your reply.
>
> R2#sho runn int fast 0/0
> Building configuration...
>
> Current configuration : 530 bytes
> !
> interface FastEthernet0/0
> ip address 10.100.40.2 255.255.255.0
> end
>
> R2#conf t
> Enter configuration commands, one per line. End with CNTL/Z.
> R2(config)#int loopback 44
> R2(config-if)#ip address 10.100.40.2 255.255.255.255
> % 10.100.40.2 overlaps with FastEthernet0/0
> R2(config-if)#
>
> Regards,
>
> Mathew
>
> On Thu, Mar 31, 2011 at 11:47 AM, jules NYA BAWEU <nyabaweu_at_gmail.com>
> wrote:
> > Can you try getting around with the PPPOE client config?
> >
> > loo100 -- > 10.100.40.2 255.255.255.255
> > dialer 1 -- > unnumbered loo100
> > then link fa0/0 to the dialer pool
> >
> > You should then use the /32 network in statement in the BGP section.
> >
> > I just tried it and able to advertise the /32. Sorry if I missed some
> > details in you requirement
> >
> > On Wed, Mar 30, 2011 at 5:33 PM, Mathew <mathewfer_at_gmail.com> wrote:
> >>
> >> Hi Aaron,
> >>
> >> Thank you for the reply.
> >>
> >> No, I did not try because I am trying to find a way to get /32. Reason
> >> is that this project involve many routers & we are limited with IPs.
> >>
> >> Any more ideas?
> >>
> >>
> >> Mathew
> >>
> >>
> >> On Thu, Mar 31, 2011 at 10:52 AM, Aaron <aaron1_at_gvtc.com> wrote:
> >> > You tried a /31?
> >> >
> >> > Aaron
> >> >
> >> > On Mar 30, 2011, at 6:21 PM, Mathew <mathewfer_at_gmail.com> wrote:
> >> >
> >> >> Hi Hubert/All,
> >> >>
> >> >> I tried the sub-interface options you suggested but it did not work,
> >> >> see below. I tried before to enter /32 IP under main Ethernet
> >> >> interface & it did not take /32 IP & it seems same with a
> >> >> sub-interface too.
> >> >>
> >> >> Any other ideas are welcome as I have ran out of options but I
> believe
> >> >> there should be a way to do this too.
> >> >>
> >> >> R2(config)#int FastEthernet0/0.1
> >> >>
> >> >> R2(config-subif)#encapsulation dot1Q 1
> >> >> R2(config-subif)#ip address 2.2.2.2 255.255.255.255
> >> >> Bad mask /32 for address 2.2.2.2
> >> >> R2(config-subif)#ip address 2.2.2.2 255.255.255.252
> >> >> R2(config-subif)#do sho runn int FastEthernet0/0.1
> >> >> Building configuration...
> >> >>
> >> >> Current configuration : 101 bytes
> >> >> !
> >> >> interface FastEthernet0/0.1
> >> >> encapsulation dot1Q 1 native
> >> >> ip address 2.2.2.2 255.255.255.252
> >> >> end
> >> >>
> >> >> R2(config-subif)#
> >> >>
> >> >> Regards
> >> >>
> >> >> Mathew
> >> >>
> >> >>
> >> >>
> >> >> On Thu, Mar 31, 2011 at 9:33 AM, Hubert Hinsley
> >> >> <hubert.hinsley_at_gmail.com> wrote:
> >> >>> Hello, would it be possible to achieve the solution via
> subinterfaces
> >> >>> on the
> >> >>> router ethernet interface? One with a /32 address and one with a
> /24?
> >> >>> Or,
> >> >>> possibly via primary and secondary ip addresses on the same
> interface?
> >> >>> Apologies if I have misunderstood the question.Regards, Hubert.
> >> >>>
> >> >>> On 30 Mar 2011 20:53, "Mathew" <mathewfer_at_gmail.com> wrote:
> >> >>>
> >> >>> Hi Stephen,
> >> >>>
> >> >>> Thank you for the reply.
> >> >>> Yes, I need to be advertise in BGP. So unfortunately, PPP idea can
> not
> >> >>> be used here.
> >> >>>
> >> >>> Mathew
> >> >>>
> >> >>> On Wed, Mar 30, 2011 at 6:32 AM, Narbik Kocharians <
> narbikk_at_gmail.com>
> >> >>> wrote:
> >> >>>> Mathew,
> >> >>>>
> >> >>>> Does it...
> >> >>>
> >> >>>> Sr. Technical Instructor
> >> >>>> Ask about our FREE Lab Voucher with our Boot Camps
> >> >>>> YES! We take Cisco...
> >> >>>
> >> >>> --
> >> >>>
> >> >>> Thanks
> >> >>>
> >> >>> Mathew
> >> >>>
> >> >>>
> >> >>> Blogs and organic groups at http://www.ccie.net
> >> >>>
> >> >>> __________________________________...
> >> >>
> >> >>
> >> >>
> >> >> --
> >> >> Thanks
> >> >>
> >> >> Mathew
> >> >>
> >> >>
> >> >> Blogs and organic groups at http://www.ccie.net
> >> >>
> >> >>
> _______________________________________________________________________
> >> >> Subscription information may be found at:
> >> >> http://www.groupstudy.com/list/CCIELab.html
> >> >>
> >> >>
> >> >>
> >> >>
> >> >>
> >> >>
> >> >>
> >> >
> >>
> >>
> >>
> >> --
> >> Thanks
> >>
> >> Mathew
> >>
> >>
> >> Blogs and organic groups at http://www.ccie.net
> >>
> >> _______________________________________________________________________
> >> Subscription information may be found at:
> >> http://www.groupstudy.com/list/CCIELab.html
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >
> >
>
>
>
> --
> Thanks
>
> Mathew

Blogs and organic groups at http://www.ccie.net
Received on Thu Mar 31 2011 - 08:44:24 ART

This archive was generated by hypermail 2.2.0 : Fri Apr 01 2011 - 06:35:42 ART