Hi Matt,
Here is your initial requirement -
"Is there a way to advertise Ethernet IP as /32 route in BGP?
I have a requirement to advertise Ethernet IP as /32 (host route) in
BGP so other routers will see it as a host route."
So say that I have three routers:
( R1 )fa0/0--------fa0/0( R2 )fa0/1 ------- fa0/1 (R3)
I configured the link between R1 and R2 as PPPoE. This is mainly so that I
can have the /32 routes in the routing table of the router. This is the
default behaviour of PPP. It creates a directly connected route of the other
side as connected. If you check the routing table of R1, you can see the IP
address of R2 as directly connected. This is then advertised into BGP as
seen in the routing table of R3.
You can use this method especially when you have the constraints of
reachability and no static routes allowed.
It was initially Narbik's idea, thank him :)
hostname R1
!
bba-group pppoe matt
virtual-template 1
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable group matt
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Virtual-Template1
ip address 10.0.0.1 255.0.0.0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
network 10.0.0.2 mask 255.255.255.255
neighbor 10.0.0.2 remote-as 2
no auto-summary
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.2/32 is directly connected, Virtual-Access2.1
C 10.0.0.0/8 is directly connected, Virtual-Access2.1
________________________________________
hostname R2
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
ip address 192.168.0.2 255.255.255.0
duplex auto
speed auto
!
interface Dialer1
ip address 10.0.0.2 255.0.0.0
encapsulation ppp
dialer pool 1
!
router bgp 2
no synchronization
bgp log-neighbor-changes
network 10.0.0.1 mask 255.255.255.255
neighbor 10.0.0.1 remote-as 1
neighbor 192.168.0.3 remote-as 3
no auto-summary
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/8 is directly connected, Dialer1
C 10.0.0.1/32 is directly connected, Dialer1
C 192.168.0.0/24 is directly connected, FastEthernet0/1
__________________________________________
hostname R3
!
interface FastEthernet0/0
ip address 192.168.0.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 3
no synchronization
bgp log-neighbor-changes
neighbor 192.168.0.2 remote-as 2
no auto-summary
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/32 is subnetted, 2 subnets
B 10.0.0.2 [20/0] via 192.168.0.2, 00:18:01
B 10.0.0.1 [20/0] via 192.168.0.2, 00:18:01
C 192.168.0.0/24 is directly connected, FastEthernet0/0
On Thu, Mar 31, 2011 at 12:46 PM, Mathew <mathewfer_at_gmail.com> wrote:
> Hi Bobola,
>
> Thank you for the reply.
>
> Can you please share a sample configuration as I am not getting it?
> This was suggested before but it was required to have a loopback with
> that IP which is not possible in IOS. So I could not get it going.
>
> Thanks
>
> Mathew
>
> On Thu, Mar 31, 2011 at 10:35 PM, Bobola Oke <okebobola_at_gmail.com> wrote:
> > Hi Matt,
> >
> > If you use a PPPoE connection, you get a peer neighbor route via IPCP
> which
> > is a /32 address in the routing table.
> >
> > You can then go ahead to advertise your /32 route via BGP.
> >
> > Regards,
> >
> > Bobola O. Oke
> >
> > On Thu, Mar 31, 2011 at 5:38 AM, Mathew <mathewfer_at_gmail.com> wrote:
> >>
> >> Hi Jules,
> >>
> >> Thank you again for your reply & testing it.
> >>
> >> How did you get the loopback configured with the same IP as Ethernet
> >> with /32 mask.
> >> For me, I can not get the loopback. Did you have the Ethernet also
> >> with the same address but different mask - like 24. See below.
> >> I think if I can get the loopback interface configured, we can
> >> advertise it straight in BGP. Is'n it?
> >>
> >> What am I missing here?
> >>
> >> Please check your configuration again for me, how you tested it & let
> >> us see your full config with the IOS ver tested.
> >>
> >> Thank you again for your reply.
> >>
> >> R2#sho runn int fast 0/0
> >> Building configuration...
> >>
> >> Current configuration : 530 bytes
> >> !
> >> interface FastEthernet0/0
> >> ip address 10.100.40.2 255.255.255.0
> >> end
> >>
> >> R2#conf t
> >> Enter configuration commands, one per line. End with CNTL/Z.
> >> R2(config)#int loopback 44
> >> R2(config-if)#ip address 10.100.40.2 255.255.255.255
> >> % 10.100.40.2 overlaps with FastEthernet0/0
> >> R2(config-if)#
> >>
> >> Regards,
> >>
> >> Mathew
> >>
> >> On Thu, Mar 31, 2011 at 11:47 AM, jules NYA BAWEU <nyabaweu_at_gmail.com>
> >> wrote:
> >> > Can you try getting around with the PPPOE client config?
> >> >
> >> > loo100 -- > 10.100.40.2 255.255.255.255
> >> > dialer 1 -- > unnumbered loo100
> >> > then link fa0/0 to the dialer pool
> >> >
> >> > You should then use the /32 network in statement in the BGP section.
> >> >
> >> > I just tried it and able to advertise the /32. Sorry if I missed some
> >> > details in you requirement
> >> >
> >> > On Wed, Mar 30, 2011 at 5:33 PM, Mathew <mathewfer_at_gmail.com> wrote:
> >> >>
> >> >> Hi Aaron,
> >> >>
> >> >> Thank you for the reply.
> >> >>
> >> >> No, I did not try because I am trying to find a way to get /32.
> Reason
> >> >> is that this project involve many routers & we are limited with IPs.
> >> >>
> >> >> Any more ideas?
> >> >>
> >> >>
> >> >> Mathew
> >> >>
> >> >>
> >> >> On Thu, Mar 31, 2011 at 10:52 AM, Aaron <aaron1_at_gvtc.com> wrote:
> >> >> > You tried a /31?
> >> >> >
> >> >> > Aaron
> >> >> >
> >> >> > On Mar 30, 2011, at 6:21 PM, Mathew <mathewfer_at_gmail.com> wrote:
> >> >> >
> >> >> >> Hi Hubert/All,
> >> >> >>
> >> >> >> I tried the sub-interface options you suggested but it did not
> work,
> >> >> >> see below. I tried before to enter /32 IP under main Ethernet
> >> >> >> interface & it did not take /32 IP & it seems same with a
> >> >> >> sub-interface too.
> >> >> >>
> >> >> >> Any other ideas are welcome as I have ran out of options but I
> >> >> >> believe
> >> >> >> there should be a way to do this too.
> >> >> >>
> >> >> >> R2(config)#int FastEthernet0/0.1
> >> >> >>
> >> >> >> R2(config-subif)#encapsulation dot1Q 1
> >> >> >> R2(config-subif)#ip address 2.2.2.2 255.255.255.255
> >> >> >> Bad mask /32 for address 2.2.2.2
> >> >> >> R2(config-subif)#ip address 2.2.2.2 255.255.255.252
> >> >> >> R2(config-subif)#do sho runn int FastEthernet0/0.1
> >> >> >> Building configuration...
> >> >> >>
> >> >> >> Current configuration : 101 bytes
> >> >> >> !
> >> >> >> interface FastEthernet0/0.1
> >> >> >> encapsulation dot1Q 1 native
> >> >> >> ip address 2.2.2.2 255.255.255.252
> >> >> >> end
> >> >> >>
> >> >> >> R2(config-subif)#
> >> >> >>
> >> >> >> Regards
> >> >> >>
> >> >> >> Mathew
> >> >> >>
> >> >> >>
> >> >> >>
> >> >> >> On Thu, Mar 31, 2011 at 9:33 AM, Hubert Hinsley
> >> >> >> <hubert.hinsley_at_gmail.com> wrote:
> >> >> >>> Hello, would it be possible to achieve the solution via
> >> >> >>> subinterfaces
> >> >> >>> on the
> >> >> >>> router ethernet interface? One with a /32 address and one with a
> >> >> >>> /24?
> >> >> >>> Or,
> >> >> >>> possibly via primary and secondary ip addresses on the same
> >> >> >>> interface?
> >> >> >>> Apologies if I have misunderstood the question.Regards, Hubert.
> >> >> >>>
> >> >> >>> On 30 Mar 2011 20:53, "Mathew" <mathewfer_at_gmail.com> wrote:
> >> >> >>>
> >> >> >>> Hi Stephen,
> >> >> >>>
> >> >> >>> Thank you for the reply.
> >> >> >>> Yes, I need to be advertise in BGP. So unfortunately, PPP idea
> can
> >> >> >>> not
> >> >> >>> be used here.
> >> >> >>>
> >> >> >>> Mathew
> >> >> >>>
> >> >> >>> On Wed, Mar 30, 2011 at 6:32 AM, Narbik Kocharians
> >> >> >>> <narbikk_at_gmail.com>
> >> >> >>> wrote:
> >> >> >>>> Mathew,
> >> >> >>>>
> >> >> >>>> Does it...
> >> >> >>>
> >> >> >>>> Sr. Technical Instructor
> >> >> >>>> Ask about our FREE Lab Voucher with our Boot Camps
> >> >> >>>> YES! We take Cisco...
> >> >> >>>
> >> >> >>> --
> >> >> >>>
> >> >> >>> Thanks
> >> >> >>>
> >> >> >>> Mathew
> >> >> >>>
> >> >> >>>
> >> >> >>> Blogs and organic groups at http://www.ccie.net
> >> >> >>>
> >> >> >>> __________________________________...
> >> >> >>
> >> >> >>
> >> >> >>
> >> >> >> --
> >> >> >> Thanks
> >> >> >>
> >> >> >> Mathew
> >> >> >>
> >> >> >>
> >> >> >> Blogs and organic groups at http://www.ccie.net
> >> >> >>
> >> >> >>
> >> >> >>
> _______________________________________________________________________
> >> >> >> Subscription information may be found at:
> >> >> >> http://www.groupstudy.com/list/CCIELab.html
> >> >> >>
> >> >> >>
> >> >> >>
> >> >> >>
> >> >> >>
> >> >> >>
> >> >> >>
> >> >> >
> >> >>
> >> >>
> >> >>
> >> >> --
> >> >> Thanks
> >> >>
> >> >> Mathew
> >> >>
> >> >>
> >> >> Blogs and organic groups at http://www.ccie.net
> >> >>
> >> >>
> _______________________________________________________________________
> >> >> Subscription information may be found at:
> >> >> http://www.groupstudy.com/list/CCIELab.html
> >> >>
> >> >>
> >> >>
> >> >>
> >> >>
> >> >>
> >> >>
> >> >
> >> >
> >>
> >>
> >>
> >> --
> >> Thanks
> >>
> >> Mathew
> >>
> >>
> >> Blogs and organic groups at http://www.ccie.net
> >>
> >> _______________________________________________________________________
> >> Subscription information may be found at:
> >> http://www.groupstudy.com/list/CCIELab.html
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >
> >
>
>
>
> --
> Thanks
>
> Mathew
Blogs and organic groups at http://www.ccie.net
Received on Thu Mar 31 2011 - 14:34:50 ART
This archive was generated by hypermail 2.2.0 : Fri Apr 01 2011 - 06:35:42 ART